#opendaylight-integration: Integration

Meeting started by dfarrell07 at 17:02:03 UTC (full logs).

Meeting summary

    1. need to remove lacp from distribution (jamoluhrsen, 17:05:47)
    2. vratko has a patch for lacp removal (jamoluhrsen, 17:06:01)
    3. sdninterfaceapp wants in distribution but they are not running single feature test (jamoluhrsen, 17:06:34)
    4. monday openflowplugin meeting to discuss how to deal with two plugin impls going forward? (jamoluhrsen, 17:07:40)
    5. patch 32248 looking to test distribution before merge job success (jamoluhrsen, 17:11:43)
    6. LuisGomez would like zxiiro to look at patch 32248, but it will be some time before zxiiro can look. (jamoluhrsen, 17:14:52)
    7. might be a way to remove submit from reviewers and give that task to jenkins who will do it after checks are made (jamoluhrsen, 17:20:42)
    8. snbi still does not have features in distribution. anipbu has sent email (jamoluhrsen, 17:21:18)
    9. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1401406837 (anipbu, 17:21:53)
    10. https://lists.opendaylight.org/pipermail/integration-dev/2016-January/005537.html (jamoluhrsen, 17:23:54)
    11. packaging making technical progress. upstream ODL puppet module is live (jamoluhrsen, 17:24:59)
    12. rpm changes being made and opnfv CI taking advantage (jamoluhrsen, 17:26:35)
    13. .deb packaging project added as a mentor project. (jamoluhrsen, 17:27:12)
    14. robot VMs are now only running with 2GB and no problems so far. (jamoluhrsen, 17:28:28)
    15. robot VM limit increased from 15 to 20 (jamoluhrsen, 17:28:37)
    16. can we migrate the el6 mininet VMs to the ubuntu VMs? (jamoluhrsen, 17:29:23)
    17. https://github.com/redhat-openstack/openstack-puppet-modules/tree/master/opendaylight puppet-opendaylight in the OpenStack Puppet Modules project (dfarrell07, 17:29:39)
    18. Major updates to ODL RPM CentOS Community Build System stuff, adds nice features including ability to pin to an SR (vs just major version), finally approved by CentOS admins (dfarrell07, 17:30:40)
    19. ACTION: jamoluhrsen create trello card to start changing CSIT jobs to use ubuntu mininet vms (jamoluhrsen, 17:31:35)
    20. moved JJB related jobs to it's own system off of the jenkins master (jamoluhrsen, 17:32:23)
    21. Jenkins looks really good now :) (LuisGomez, 17:33:55)
    22. Beryllium weekly sync discussed multi-openflowplugin impls, copyright headers, renaming features. (jamoluhrsen, 17:35:38)
    23. new robot requests library causing issues with json data and headers (jamoluhrsen, 17:38:41)
    24. vrpolak thinks short term solution is to use yang+json header and then not worry to configure data to json. (jamoluhrsen, 17:39:39)
    25. vrpolak thinks long term solution is to contribute to requests library project to make this more consumable (jamoluhrsen, 17:40:16)
    26. https://lists.opendaylight.org/pipermail/integration-dev/2016-January/005551.html (jamoluhrsen, 17:40:47)
    27. ACTION: vrpolak to send email explaining the requestslibrary "retry" warnings; why it comes, how to fix, etc (jamoluhrsen, 17:41:59)
    28. please encourage community to broadcast emails. seems like more unicasts are coming recently (jamoluhrsen, 17:42:55)
    29. test breakages recently. verify python job fixed. pep8 more strict, but fix believed to be in. (jamoluhrsen, 17:45:34)
    30. Vratko also fixed the verify library job (LuisGomez, 17:46:56)
    31. Boron release planning conversations happening now. TWS calls. (jamoluhrsen, 17:47:28)
    32. congrats to radhika on career move. thanks for all the contributions. (jamoluhrsen, 17:52:27)
    33. Radhika got a job, she will be less available in ODL, thanks Radhika for your contribution. (LuisGomez, 17:52:27)
    34. dfarrell07 would like to move Int/Pak trello work to Jira. tykeal says we need TSC to take care of stuff before we can move jira to production (jamoluhrsen, 17:54:57)


Meeting ended at 18:00:39 UTC (full logs).

Action items

  1. jamoluhrsen create trello card to start changing CSIT jobs to use ubuntu mininet vms
  2. vrpolak to send email explaining the requestslibrary "retry" warnings; why it comes, how to fix, etc


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen create trello card to start changing CSIT jobs to use ubuntu mininet vms


People present (lines said)

  1. jamoluhrsen (30)
  2. dfarrell07 (4)
  3. odl_meetbot (4)
  4. LuisGomez (3)
  5. odp-gerritbot (2)
  6. anipbu (1)


Generated by MeetBot 0.1.4.