#opendaylight-integration: integration

Meeting started by dfarrell07 at 17:03:37 UTC (full logs).

Meeting summary

    1. anipbu gives Be release updates (dfarrell07, 17:05:56)
    2. worries about infra issues reported during Be sync, sshpass and similar (dfarrell07, 17:06:18)
    3. infra issues was a concern earlier in week, but zxiiro has fixed this. big thanks (jamoluhrsen, 17:06:20)
    4. no blocking bugs on Be (dfarrell07, 17:06:25)
    5. release reviews are still in progress (dfarrell07, 17:06:41)
    6. group agrees that documentation should be a higher priority (jamoluhrsen, 17:08:02)
    7. https://jenkins.opendaylight.org/releng/job/topoprocessing-csit-1node-topology-operations-only-beryllium/329/robot/report/log.html (anipbu, 17:09:33)
    8. jamoluhrsen has been auditing system tests, finding very poor examples for many projects (dfarrell07, 17:11:01)
    9. jamoluhrsen reports that some projects have tests, but they never pass, are generally crap (dfarrell07, 17:11:20)
    10. ACTION: jamoluhrsen to give link to An for system test expectations. (jamoluhrsen, 17:15:33)
    11. anipbu proposes three-phase testing checks for Boron release plan - 1) have tests 2) have functional coverage 3) have tests passing (or pointing at bugs that describe why they are failing) (dfarrell07, 17:17:07)
    12. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=83290213 (anipbu, 17:18:45)
    13. ACTION: jamoluhrsen to start email about making system test a little more formal and top-of-mind for Boron (jamoluhrsen, 17:22:00)
    14. ACTION: jamoluhrsen to send email for anipbu's tool for web crawling and reporting (jamoluhrsen, 17:26:56)
    15. not much news from distribution. (jamoluhrsen, 17:28:02)
    16. some bugs fixed in projects to stop full exception traces (jamoluhrsen, 17:28:38)
    17. of-config has bug in Be release where they give a 1M character single log line (jamoluhrsen, 17:29:58)
    18. vratko points out that autorelease is having trouble with lithium (jamoluhrsen, 17:30:51)
    19. distribution test CSIT jobs are triggered even when autorelease fails. (jamoluhrsen, 17:31:16)
    20. we need to configure autorelease to *NOT* trigger when unstable as well as fail. (jamoluhrsen, 17:33:06)
    21. ACTION: zxiiro to make this change ^^^ (jamoluhrsen, 17:33:28)
    22. packaging is keeping the flow of Be RC distros going to OPNFV (jamoluhrsen, 17:34:01)
    23. bootstrapping docs for packing... link below (jamoluhrsen, 17:34:28)
    24. packaging intern accepted and ramping up. (jamoluhrsen, 17:35:33)
    25. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Packaging:ODL_Bootstrap Int/Pack ODL bootstrap docs, may be useful for other Int/* projects (dfarrell07, 17:37:24)
    26. ACTION: LuisGomez to send email to get topics for dev-forum. (jamoluhrsen, 17:37:39)
    27. vratko shaing his templated requests patch (jamoluhrsen, 17:40:33)
    28. https://git.opendaylight.org/gerrit/#/c/33987/ (jamoluhrsen, 17:40:35)
    29. super cool to have unittests for system test libraries (jamoluhrsen, 17:41:31)


Meeting ended at 17:55:28 UTC (full logs).

Action items

  1. jamoluhrsen to give link to An for system test expectations.
  2. jamoluhrsen to start email about making system test a little more formal and top-of-mind for Boron
  3. jamoluhrsen to send email for anipbu's tool for web crawling and reporting
  4. zxiiro to make this change ^^^
  5. LuisGomez to send email to get topics for dev-forum.


Action items, by person

  1. anipbu
    1. jamoluhrsen to send email for anipbu's tool for web crawling and reporting
  2. jamoluhrsen
    1. jamoluhrsen to give link to An for system test expectations.
    2. jamoluhrsen to start email about making system test a little more formal and top-of-mind for Boron
    3. jamoluhrsen to send email for anipbu's tool for web crawling and reporting
  3. LuisGomez
    1. LuisGomez to send email to get topics for dev-forum.


People present (lines said)

  1. jamoluhrsen (20)
  2. dfarrell07 (12)
  3. odl_meetbot (4)
  4. odp-gerritbot (2)
  5. anipbu (2)
  6. LuisGomez (1)


Generated by MeetBot 0.1.4.