#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:06:57 UTC (full logs).

Meeting summary

    1. distribution has no news (jamoluhrsen, 17:07:33)
    2. vratko points out there is an odl-jolokia feature (jamoluhrsen, 17:07:42)
    3. ACTION: vratko to send email about using odl-jolokia feature (jamoluhrsen, 17:07:52)
    4. packaging talk went well at design forum (jamoluhrsen, 17:08:47)
    5. main action item was to add more features to CI (jamoluhrsen, 17:08:59)
    6. tykeal gives shortform version of what/why/how of zuul and nodepool. (jamoluhrsen, 17:10:47)
    7. zuul and nodepool have different mechanisms for triggering jobs and bringing up VMs (jamoluhrsen, 17:12:38)
    8. tykeal thinks it's still worth the effort to trim the job queue. (jamoluhrsen, 17:13:17)
    9. netconf job was changed to not use c6 VM so it can be deprecated (jamoluhrsen, 17:14:18)
    10. ACTION: zxiiro to double check ^^ and remove c6 vm (jamoluhrsen, 17:14:37)
    11. Lithium SR4 is good to go. (jamoluhrsen, 17:15:05)
    12. kindly ask projects to start marking test cases for Beryllium with their bug ids (jamoluhrsen, 17:18:10)
    13. vratko asks if we can delete helium jobs (jamoluhrsen, 17:18:52)
    14. ACTION: zxiiro to merge patch https://git.opendaylight.org/gerrit/#/c/32928 (jamoluhrsen, 17:19:16)
    15. new openstack + opendaylight sub group created at dev design forum (jamoluhrsen, 17:22:26)
    16. https://trello.com/b/T3U8seZx/opendaylight-openstack-system-test (jamoluhrsen, 17:22:48)
    17. ACTION: Int/Dist to generate requirements for extra tools being pushed to distribution (jamoluhrsen, 17:25:34)
    18. perf/scale dashboard needed. intern possibility from ghzao (jamoluhrsen, 17:27:31)
    19. mgkwill brought up the idea of having a release by release white paper outlining our perf/scale observations. (jamoluhrsen, 17:28:53)
    20. mgkwill confirms we are going to start a periodic call to find a set of metrics to use in this white paper (jamoluhrsen, 17:29:30)
    21. perf tracking group to meet tomorrow at 8am, maybe weekly after that. (jamoluhrsen, 17:29:53)
    22. mgkwill might have inside lead to some resources to help on a dashboard (jamoluhrsen, 17:30:11)
    23. jamoluhrsen wonders what format/where/how the white paper(s) would be maintained. (jamoluhrsen, 17:30:52)
    24. anipbu asks what the requirements are for the performance metrics? can any project contribute? (jamoluhrsen, 17:31:47)
    25. upgrade story not well defined but when it is, it's important to get in CSIT (jamoluhrsen, 17:34:59)
    26. jamoluhrsen lobbies all projects to tighten up and clean all their current system test as top priority (jamoluhrsen, 17:37:01)
    27. vratko, jozef sending sporadic system test results and seems possible that it's working to create more visibility and probably better quality (jamoluhrsen, 17:39:03)
    28. anipbu gives big +1 on the sporadic test report (jamoluhrsen, 17:39:45)
    29. https://lists.opendaylight.org/pipermail/integration-dev/2016-March/006008.html (jamoluhrsen, 17:40:37)
    30. anipbu points out that new projects with only 1 committer need to be made very aware of all the overhead, especially system test (jamoluhrsen, 17:41:21)
    31. jamoluhrsen asks where we should start keeping our docker containers? (jamoluhrsen, 17:45:13)
    32. mgkwill says maybe nexus, but tykeal says no way! (jamoluhrsen, 17:45:26)
    33. mgkwill wonders if we can just put the binary artifacts there? (jamoluhrsen, 17:46:03)
    34. dfarrell07 thinks Int/Pack can help figure this out. maybe an official dockerhub account. (jamoluhrsen, 17:46:58)
    35. mgkwill wants a local repo, but we need to wait until nexus v3 shows up. (jamoluhrsen, 17:47:46)
    36. ACTION: jamoluhrsen and dfarrell07 to start email discussion about this docker stuff (jamoluhrsen, 17:48:37)
    37. mgkwill asks about spinning docker containers instead VMs in private cloud. (jamoluhrsen, 17:49:19)
    38. figure this out would be a serious chunk of work, and we can't start until we migrate to the private cloud. (jamoluhrsen, 17:50:16)
    39. vratko has releng/builder patch to add new variable to pybot to include ${stream} string. (jamoluhrsen, 17:51:25)
    40. action jamoluhrsen to look at sfc job, thinks it's broken based on ODL_VERSION (jamoluhrsen, 17:52:35)


Meeting ended at 17:59:13 UTC (full logs).

Action items

  1. vratko to send email about using odl-jolokia feature
  2. zxiiro to double check ^^ and remove c6 vm
  3. zxiiro to merge patch https://git.opendaylight.org/gerrit/#/c/32928
  4. Int/Dist to generate requirements for extra tools being pushed to distribution
  5. jamoluhrsen and dfarrell07 to start email discussion about this docker stuff


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen and dfarrell07 to start email discussion about this docker stuff
  2. UNASSIGNED
    1. vratko to send email about using odl-jolokia feature
    2. zxiiro to double check ^^ and remove c6 vm
    3. zxiiro to merge patch https://git.opendaylight.org/gerrit/#/c/32928
    4. Int/Dist to generate requirements for extra tools being pushed to distribution


People present (lines said)

  1. jamoluhrsen (42)
  2. odl_meetbot (3)
  3. odp-gerritbot (1)


Generated by MeetBot 0.1.4.