#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:03:37 UTC (full logs).

Meeting summary

    1. vratko now Integration/Distribution PTL. congrats! (jamoluhrsen, 16:04:28)
    2. SR1 Beryllium bumping finished. (jamoluhrsen, 16:04:37)
    3. some distro changes coming (e.g. python verify init file) (jamoluhrsen, 16:05:24)
    4. bug 4296 being worked on and now some java code will end up in distribution (jamoluhrsen, 16:05:56)
    5. opnfv now consuming Be SR1 from packaging (rpms) (jamoluhrsen, 16:08:15)
    6. @ ONS, ODL was noticed as the easiest consumed by OPNFV (jamoluhrsen, 16:09:20)
    7. LuisGomez asks if there was any idea of what kind of features are consumed in downstream (jamoluhrsen, 16:10:49)
    8. jamoluhrsen knows that odl-ovsdb-openstack is one main feature in use. sfc must be there too (jamoluhrsen, 16:11:08)
    9. LuisGomez recaps the performance/scale test report that was published and talked about at ONS (jamoluhrsen, 16:14:31)
    10. perf/scale numbers were all tested in at least 2 different labs (jamoluhrsen, 16:15:02)
    11. white paper was published. (jamoluhrsen, 16:15:13)
    12. https://www.opendaylight.org/resources/odl-performance (jamoluhrsen, 16:15:51)
    13. tests not done in clustered environment, but it was asked for by others. (jamoluhrsen, 16:16:17)
    14. LuisGomez thinks just producing a white paper each release is best format (jamoluhrsen, 16:17:24)
    15. this kind of perf/scale work needs a little more time to produce a better report (maybe a month?) (jamoluhrsen, 16:18:53)
    16. high praise to everyone involved in that testing. a great example of a broad community effort in a short time frame. (jamoluhrsen, 16:19:39)
    17. anipbu asks for a simple 1-page conclusion of white paper. (infographic) (jamoluhrsen, 16:21:04)
    18. this infographic would have been a cool thing to hand out at OpenDaylight booths at difference summits/conferences (jamoluhrsen, 16:21:53)
    19. gvrangan noticed that VTN jobs started failing because OVS/Mininet versions have changed on the backend (jamoluhrsen, 16:23:28)
    20. we have no answer as to why the versions changed, but gvrangan says he has a patch to deal with the change going forward (jamoluhrsen, 16:26:16)
    21. asks how Integration/Test wants to do committer status? (jamoluhrsen, 16:29:12)
    22. ACTION: jamoluhrsen to get rid of committer names on main Integration page (jamoluhrsen, 16:33:28)
    23. jamoluhrsen complains that autorelease feels different than snapshot distributions. (jamoluhrsen, 16:35:03)
    24. LuisGomez notes that we might need a new strategy for what distributions we run all CSIT on. (jamoluhrsen, 16:36:23)
    25. autorelease (e.g., daily) does trigger distribution-test so we can at least start comparing vs snapshot (as far as CSIT goes) (jamoluhrsen, 16:39:03)
    26. vratko mentions that we should change our {periodic} jobs (aka daily) to run using autorelease distributions, instead of snapshot (jamoluhrsen, 16:41:03)
    27. ACTION: jamoluhrsen to make a trello card for this idea (daily csit on autorel) (jamoluhrsen, 16:41:31)
    28. jamoluhrsen asks how we want to address features ending up as experimental at the end of the release? (jamoluhrsen, 16:43:58)
    29. start sending emails, start marking tests excluded now. (jamoluhrsen, 16:44:13)
    30. need to still run (maybe daily) the test cases that are marked "exclude" (jamoluhrsen, 16:47:43)
    31. need to make projects include their system tests in the distribution-test job (jamoluhrsen, 16:49:37)
    32. ACTION: jamoluhrsen to add that to release plan (ASAP) (jamoluhrsen, 16:49:47)
    33. Int/Test does not need any other branches besides master (jamoluhrsen, 16:53:01)
    34. LuisGomez wants to organize an IRC meeting with all projects test contacts (jamoluhrsen, 16:53:38)
    35. ACTION: LuisGomez to set that meeting up (jamoluhrsen, 16:53:44)
    36. jamoluhrsen got confused why non-master branches were there on github. can be manually removed if needed (email helpdesk if it's important) (jamoluhrsen, 16:56:26)
    37. ACTION: jamoluhrsen to send helpdesk (jamoluhrsen, 16:56:39)
    38. jamoluhrsen notes it's time to get rid of AD-SAL system tests (jamoluhrsen, 16:57:06)
    39. ACTION: LuisGomez for the above (jamoluhrsen, 16:57:15)
    40. how do we want projects to figure out ports to use? (jamoluhrsen, 16:58:52)
    41. LuisGomez notes the port wiki is the one best place to enforce this. (jamoluhrsen, 16:59:08)


Meeting ended at 17:00:58 UTC (full logs).

Action items

  1. jamoluhrsen to get rid of committer names on main Integration page
  2. jamoluhrsen to make a trello card for this idea (daily csit on autorel)
  3. jamoluhrsen to add that to release plan (ASAP)
  4. LuisGomez to set that meeting up
  5. jamoluhrsen to send helpdesk
  6. LuisGomez for the above


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to get rid of committer names on main Integration page
    2. jamoluhrsen to make a trello card for this idea (daily csit on autorel)
    3. jamoluhrsen to add that to release plan (ASAP)
    4. jamoluhrsen to send helpdesk
  2. UNASSIGNED
    1. LuisGomez to set that meeting up
    2. LuisGomez for the above


People present (lines said)

  1. jamoluhrsen (45)
  2. odl_meetbot (3)
  3. anipbu (1)
  4. dfarrell07 (1)


Generated by MeetBot 0.1.4.