#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:04:16 UTC (full logs).

Meeting summary

  1. distribution update (jamoluhrsen, 16:04:46)
    1. Vatko is now PTL of Int/Dist, congrats (dfarrell07, 16:04:48)
    2. rough draft created for Int/Dist release plan (jamoluhrsen, 16:05:03)
    3. ACTION: jamoluhrsen to email Jaime about overrides.properties (jamoluhrsen, 16:06:08)

  2. packaging (jamoluhrsen, 16:06:18)
    1. major refactor of vagrant basebox happening (jamoluhrsen, 16:06:37)
    2. new effort underway from DDF around creating tutorials and making things more "usable" (jamoluhrsen, 16:07:00)
    3. should have some help from LF interns, mentorship by dfarrell07 (jamoluhrsen, 16:07:17)
    4. main idea is to improve vagrant base boxes, and then create tutorials around those (e.g. l2switch with mininet) (jamoluhrsen, 16:07:52)

  3. builder (jamoluhrsen, 16:08:47)
    1. some outages happening, another one this saturday (jamoluhrsen, 16:09:24)
    2. gpg now available for us in gerrit (jamoluhrsen, 16:09:37)
    3. must use master key, subkeys don't work. (jamoluhrsen, 16:10:18)
    4. start using if your master key is also a signing key (jamoluhrsen, 16:10:42)
    5. need local git version of 2.6+ (jamoluhrsen, 16:10:51)
    6. this is all done with a git config cmd (ask google how) (jamoluhrsen, 16:11:34)

  4. misc (jamoluhrsen, 16:14:50)
    1. jamoluhrsen presented features as experimental when they dont meet system test expectations in monday's TWS (jamoluhrsen, 16:15:18)
    2. LuisGomez notes that there are other non system test release things can mark features experimental (e.g. documentation) (jamoluhrsen, 16:16:34)
    3. catohornet stepping down as committer in Boron (jamoluhrsen, 16:16:55)
    4. do we want to enable heapdumps by default in our release distribution, or only enable it when needed (like system test) (jamoluhrsen, 16:19:03)
    5. ACTION: vratko to email release and discuss about heapdumps coming by default or not (jamoluhrsen, 16:20:17)
    6. jamoluhrsen asks if we can analyze all the current ODL projects system tests and send a warning that they are not meeting system test expectations (jamoluhrsen, 16:21:57)
    7. ACTION: jamoluhrsen to send email to Int/Test asking for volunteers to investigate each projects to see if their system test is ok or not (jamoluhrsen, 16:24:02)
    8. next week divvy out projects, the following week we'll have a full report (jamoluhrsen, 16:24:42)
    9. colindixon asked (via email) if we should put our packaging stuff on our release downloads page? (jamoluhrsen, 16:26:07)
    10. dfarrell07_sick notes two trains of thought. 1) we shouldn't post things there unless it's build in nexus. 2) we should put these things there anyway, because it really helps usability. (jamoluhrsen, 16:27:00)
    11. ACTION: dfarrell07_sick to respond to colins email that we should start posting these things to downloads (jamoluhrsen, 16:27:30)
    12. jamoluhrsen does not think we should not put our deployment scripts there though as they are very specific to our infra needs and not made for usability (jamoluhrsen, 16:28:28)

  5. YANG python bindings project (jamoluhrsen, 16:30:06)
    1. yang python binding project will push patches to Integration/Test, create wiki and make real examples in lisp (jamoluhrsen, 16:49:28)
    2. jamoluhrsen to continue working on port checker suite (jamoluhrsen, 16:58:54)
    3. ACTION: vratko to give his comments about port variables (different order and need them for all branches) in gerrit itself (jamoluhrsen, 17:00:01)


Meeting ended at 17:00:07 UTC (full logs).

Action items

  1. jamoluhrsen to email Jaime about overrides.properties
  2. vratko to email release and discuss about heapdumps coming by default or not
  3. jamoluhrsen to send email to Int/Test asking for volunteers to investigate each projects to see if their system test is ok or not
  4. dfarrell07_sick to respond to colins email that we should start posting these things to downloads
  5. vratko to give his comments about port variables (different order and need them for all branches) in gerrit itself


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to email Jaime about overrides.properties
    2. jamoluhrsen to send email to Int/Test asking for volunteers to investigate each projects to see if their system test is ok or not
  2. UNASSIGNED
    1. vratko to email release and discuss about heapdumps coming by default or not
    2. dfarrell07_sick to respond to colins email that we should start posting these things to downloads
    3. vratko to give his comments about port variables (different order and need them for all branches) in gerrit itself


People present (lines said)

  1. jamoluhrsen (34)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)
  4. dfarrell07 (1)


Generated by MeetBot 0.1.4.