#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:01:28 UTC (full logs).

Meeting summary

    1. http://bluejeans.com/numbers (tykeal, 16:03:58)

  1. packaging (jamoluhrsen, 16:06:43)
    1. lots of work getting vagrant things in line. new patch to update all the docs (jamoluhrsen, 16:07:28)
    2. vagrant base boxes will be the basis for the tutorials work. (jamoluhrsen, 16:07:45)
    3. hoping this work will help with user facing tutorials, as opposed to dev focused things (jamoluhrsen, 16:08:13)
    4. python verify job now in place for Int/Pak (jamoluhrsen, 16:09:01)
    5. packing work (version bumping etc) really needs to get some automation around it. (jamoluhrsen, 16:09:32)
    6. ACTION: dfarrell07 will work with Phil to get whatever packing work we need on the downloads page (jamoluhrsen, 16:11:21)

  2. distribution (jamoluhrsen, 16:11:38)
    1. LuisGomez creating bash script to disable persistence. idea came out of performance testing work. (jamoluhrsen, 16:12:43)
    2. disabling persistence will increase performance with things like flow config (jamoluhrsen, 16:13:00)
    3. jamoluhrsen working on patch to configure custom sharding in cluster deployer . (jamoluhrsen, 16:14:25)
    4. https://git.opendaylight.org/gerrit/#/c/37105/ (jamoluhrsen, 16:14:32)
    5. all branches seem to be building properly (jamoluhrsen, 16:14:56)

  3. builder (jamoluhrsen, 16:15:14)
    1. nexus problems are fully resolved now (jamoluhrsen, 16:15:26)
    2. sonar migration coming next, but not this weekend (jamoluhrsen, 16:15:42)
    3. CSIT jobs aborting (jamoluhrsen, 16:19:23)
    4. jamoluhrsen thinks jobs are aborting too frequently right now, as compared to how it felt in the past (jamoluhrsen, 16:20:46)
    5. if slaves are not coming up because we've run out of ip addresses, that problem will go away when we move to the private cloud. (jamoluhrsen, 16:21:38)
    6. we don't know why jobs are aborting more so right now, but tykeal is informed now (jamoluhrsen, 16:22:25)
    7. https://jenkins.opendaylight.org/releng/view/CSIT-1node/job/openflowplugin-csit-1node-flow-services-lithium-redesign-only-beryllium/ (LuisGomez, 16:23:19)
    8. job abort problem might be happening in sandbox too. reported by vrpolak (jamoluhrsen, 16:23:53)

  4. release (jamoluhrsen, 16:24:58)
    1. onboarding reviews for projects happening currently (jamoluhrsen, 16:25:14)
    2. onboarding slide deck https://docs.google.com/presentation/d/1bHlGS4sTUcFKMj13vx_DdkD1SVDcFvo1URvHpVvSWQc/edit#slide=id.g11e66ce540_0_0 (jamoluhrsen, 16:25:36)
    3. https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=1240622178 (anipbu, 16:28:42)
    4. https://www.opendaylight.org/project-lifecycle-releases (anipbu, 16:36:44)
    5. team will start looking at all project CSIT jobs in order to warn projects if they are going to have experimental features (jamoluhrsen, 16:36:52)
    6. anipbu notes that old integration project needs to have a termination review (jamoluhrsen, 16:37:11)
    7. dfarrell07 explains that you have a termination review to bring you to archive state (jamoluhrsen, 16:38:10)
    8. pushed patch for devstack jobs https://git.opendaylight.org/gerrit/#/c/37280/ (gvrangan, 16:39:08)
    9. currently in draft (gvrangan, 16:39:17)
    10. working on rediuucting time to deploy and ehtn enable the pybot command (gvrangan, 16:39:38)
    11. https://wiki.opendaylight.org/view/Archive_Proposals/Integration Wiki required for termination review to archived state (dfarrell07, 16:42:02)
    12. team walks through trello board (jamoluhrsen, 16:45:03)
    13. ACTION: zxiiro to give Int/Test a demo of readthedocs (jamoluhrsen, 16:50:33)


Meeting ended at 16:59:58 UTC (full logs).

Action items

  1. dfarrell07 will work with Phil to get whatever packing work we need on the downloads page
  2. zxiiro to give Int/Test a demo of readthedocs


Action items, by person

  1. dfarrell07
    1. dfarrell07 will work with Phil to get whatever packing work we need on the downloads page
  2. zxiiro
    1. zxiiro to give Int/Test a demo of readthedocs


People present (lines said)

  1. jamoluhrsen (35)
  2. dfarrell07 (11)
  3. anipbu (5)
  4. tykeal (4)
  5. LuisGomez (4)
  6. odl_meetbot (4)
  7. zxiiro (3)
  8. gvrangan (3)
  9. odp-gerritbot (2)


Generated by MeetBot 0.1.4.