#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:03:03 UTC (full logs).

Meeting summary

    1. ACTION: LuisGomez jamoluhrsen to see why distribution-check is taking longer now, than it used to (jamoluhrsen, 16:04:07)

  1. distribution (jamoluhrsen, 16:08:39)
    1. stable/lithium distribution deploy was failing because of port conflicts (e.g. port 8282 with iotdm and controller) (jamoluhrsen, 16:09:17)
    2. iotdm feature was disabled in stable/lithium (jamoluhrsen, 16:09:34)
    3. these port conflicts are probably still there in other branches, but the bindexpections are just not noticed in distribution-check. (jamoluhrsen, 16:10:49)
    4. port automation checker aprox 50% complete: https://git.opendaylight.org/gerrit/#/c/36795/ (jamoluhrsen, 16:12:25)
    5. https://wiki.opendaylight.org/view/Weather#Nexus_URL_requires_HTTPS <--- Weather item for Nexus URL (anipbu, 16:15:58)
    6. weather report was created around nexus and projects using https (jamoluhrsen, 16:16:01)
    7. seems most projects could be affected by this weather item. (jamoluhrsen, 16:17:04)
    8. anipbu wonders if we should bring this action to projects via some milestone (jamoluhrsen, 16:17:26)
    9. projects are going to start getting more affected as artifacts age out after 3 weeks. (jamoluhrsen, 16:18:29)
    10. projects need to be checking and fixing their merge jobs. (jamoluhrsen, 16:19:49)
    11. ACTION: zxiiro LuisGomez to send a mail to projects about checking/fixing their merge jobs (jamoluhrsen, 16:22:07)
    12. two new scripts merged in distribution. persistence and cluster config (jamoluhrsen, 16:22:54)
    13. location of new distribution scripts: https://github.com/opendaylight/integration-distribution/blob/master/distribution-karaf/src/main/assembly/bin/ (jamoluhrsen, 16:26:01)
    14. vratko points out that some projects have ports that can be used that are not on by default. (jamoluhrsen, 16:26:52)

  2. packaging (jamoluhrsen, 16:27:12)
    1. opnfv is extremely active in consuming our rpms based on our daily autorelease (good news) (jamoluhrsen, 16:27:40)
    2. opnfv is reporting bugs/issues back to us. (jamoluhrsen, 16:27:52)
    3. our method of creating releases are not up to standards that some packaging requirements have (jamoluhrsen, 16:28:43)
    4. intern interviews recently and 3 will be hired to help get our user-focused tutorials up and running (jamoluhrsen, 16:29:17)
    5. dfarrell07 working to get a new tutorials project (i.e., a new repo) for this user-tutorials work. (jamoluhrsen, 16:30:19)
    6. CaseyODL notes that coretutorials is not against us renaming it to something more relevant (e.g. user_tutorials, etc) (jamoluhrsen, 16:30:54)
    7. still discussion for project specific tutorials to still live in those project repos (jamoluhrsen, 16:31:14)

  3. builder (jamoluhrsen, 16:31:37)
    1. workflow created recently for projects that are not part of the autorelease build. (jamoluhrsen, 16:32:04)
    2. projects no longer have push permission to push to opendaylight repo. (jamoluhrsen, 16:36:25)
    3. https://lists.opendaylight.org/pipermail/release/2016-April/006268.html (jamoluhrsen, 16:36:33)

  4. release (jamoluhrsen, 16:37:04)
    1. beryllium SR2 cut-off is this sunday. SR2 coming in one week. (jamoluhrsen, 16:37:30)
    2. there is a request to have more frequent releases (jamoluhrsen, 16:38:06)
    3. https://lists.opendaylight.org/pipermail/release/2016-April/006282.html (jamoluhrsen, 16:38:51)
    4. just taking our daily autorelease is the first step, but those builds are not getting the full release style vetting (checking system tests, etc) (jamoluhrsen, 16:40:18)
    5. zxiiro points out that version bumping will be very cumbersome if more frequent releases are required. it will only get worse as more projects come online (jamoluhrsen, 16:41:00)
    6. vratko points out that branches are frozen during the version bumping so if this happens more frequently, there will be more windows where branches are locked (jamoluhrsen, 16:42:26)
    7. int/packaging could potentially create their own releases which takes the burden off of releng (jamoluhrsen, 16:44:14)
    8. could we potentially get to the point where we are making sure daily autorelease distributions are up to standard as far as CSIT (jamoluhrsen, 16:45:25)
    9. one driving force for these faster releases is that downstream is finding bugs in ODL and wants them fixed. (jamoluhrsen, 16:45:53)

  5. misc (jamoluhrsen, 16:46:55)
    1. question around what jobs should be in distribution tests (jamoluhrsen, 16:49:52)
    2. dfarrell07 thinks we dont want to include perf/stress/scale in distribution-test. more just all fundamental system test (jamoluhrsen, 16:51:16)
    3. LuisGomez thinks we can probably just get by with the -only- jobs in distribution-test, but jamoluhrsen thinks we still need -all- test (jamoluhrsen, 16:51:52)
    4. vratko thinks we can have two versions of distribution-test. one with just -only- and fundamental system tests (jamoluhrsen, 16:52:13)
    5. the other distrubtion test job could be run on a slower cadence with -all- and maybe some perf/stress/scale (jamoluhrsen, 16:52:44)
    6. vratko has an idea where each CSIT job definition can have a flag that tells us when/where to run those jobs. (jamoluhrsen, 16:55:44)
    7. main point is that we need some tooling that will help us automatically generate these bigger jobs that trigger all the system test, instead of asking projects to manually add their -csit- job to the distribution-test definition (jamoluhrsen, 16:56:48)
    8. CaseyODL asks that we starting taking more looks at ask.opendaylight.org to help answer questions. (jamoluhrsen, 16:57:58)


Meeting ended at 17:00:51 UTC (full logs).

Action items

  1. LuisGomez jamoluhrsen to see why distribution-check is taking longer now, than it used to
  2. zxiiro LuisGomez to send a mail to projects about checking/fixing their merge jobs


Action items, by person

  1. jamoluhrsen
    1. LuisGomez jamoluhrsen to see why distribution-check is taking longer now, than it used to
  2. zxiiro
    1. zxiiro LuisGomez to send a mail to projects about checking/fixing their merge jobs


People present (lines said)

  1. jamoluhrsen (49)
  2. odl_meetbot (3)
  3. odp-gerritbot (3)
  4. zxiiro (2)
  5. anipbu (1)


Generated by MeetBot 0.1.4.