#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:00:56 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:02:54)
    1. stable/lithium has features removed because there is port conflict (jamoluhrsen, 16:03:21)
    2. https://git.opendaylight.org/gerrit/#/c/37729 (jamoluhrsen, 16:03:48)
    3. there is a very likely chance that we will not have a stable distribution. there is probably no feature even close to being "stable" (jamoluhrsen, 16:04:26)
    4. it seems too hard for features to be stable. tykeal notes that core projects need to get this ball rolling (jamoluhrsen, 16:05:07)
    5. vratko thinks the best option is a southbound only feature first. they would depend only on yangtools and yangtools gets system test waiver. (jamoluhrsen, 16:05:57)
    6. actually, odlparent needs to be mature, then stable, before yangtools or mdsal or controller or mdsal... on and on. (jamoluhrsen, 16:06:50)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Stable_and_Extended_Features (jamoluhrsen, 16:07:42)
    8. ACTION: vratko to send email to release notifying that we will not have stable distribution in Boron (jamoluhrsen, 16:09:02)

  2. builder (jamoluhrsen, 16:09:42)
    1. archive.apache.org was starting to limit our downloads (5G daily max) (jamoluhrsen, 16:10:26)
    2. projects can try to use mirrors, but they only use latest version of packages. so if our scripts need very specific versions the mirrors wont work. (jamoluhrsen, 16:11:01)
    3. the next option is to put those specific versions on ODL's nexus and then download from there. (jamoluhrsen, 16:11:41)
    4. https://lists.opendaylight.org/pipermail/tsdr-dev/2016-April/000780.html (jamoluhrsen, 16:12:15)
    5. LuisGomez points out that ideally these pieces of software are baked in to the VM to start with. (jamoluhrsen, 16:15:58)
    6. migration to private cloud still in the works. sandbox system getting stood up now. (jamoluhrsen, 16:18:07)
    7. hoping to have sandbox migrated in 2 weekends from now and we'll cut over after that. (jamoluhrsen, 16:19:14)
    8. jamoluhrsen notes that VTN was having problem with "yum install" in sandbox but not releng. this should not be a problem once everything is migrated to same private cloud (jamoluhrsen, 16:20:30)

  3. packaging (jamoluhrsen, 16:21:23)
    1. plaurin adding fedora pipeline to packaging (jamoluhrsen, 16:21:54)
    2. https://hub.docker.com/r/opendaylight/odl/tags/ (jamoluhrsen, 16:23:03)
    3. https://git.opendaylight.org/gerrit/38120 plaurin's patch to add Fedora 23 Vagrant base boxes (libvirt, vbox) and Docker images (all for 3.3, 4.0 and 4.1) (dfarrell07, 16:24:46)

  4. release (jamoluhrsen, 16:24:51)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/SR2/Status (anipbu, 16:24:53)
    2. beryllium SR2 not coming out this week. ovsdb has blocking issues (jamoluhrsen, 16:25:10)
    3. bug to track https://bugs.opendaylight.org/show_bug.cgi?id=5809 (jamoluhrsen, 16:25:52)
    4. dfarrell07 meant 3.4 (Li SR4), not SR3 in Packer ODL versions above (dfarrell07, 16:26:02)
    5. first blocker issue is that functionality is broken (can't update ovs port ip) (jamoluhrsen, 16:28:06)
    6. second issue is that ovsdb features are not coming up fast enough, so br-int is not created when system test is run. if you wait longer, things will work. (jamoluhrsen, 16:28:33)
    7. ACTION: jamoluhrsen will binary search distros to find when feature loading started taking longer (jamoluhrsen, 16:29:06)
    8. probably no real movement on ovsdb fix until monday since all devs are at openstack summit (jamoluhrsen, 16:32:22)

  5. cluster keyword consolidation (jamoluhrsen, 16:33:04)
    1. we have multiple clustering libraries in robot. we should try to consolidate. (jamoluhrsen, 16:34:20)
    2. goals for consolidation: 1) single clear library. 2) remove duplicate work. 3) similar keywords can call each other (keyword doing more calls keyword doing less) (jamoluhrsen, 16:36:10)
    3. keywords are grouped such that some use an index in to a list of controller ips vs keywords that require a specific ip (jamoluhrsen, 16:37:05)
    4. all REST action keywords require index. (jamoluhrsen, 16:37:21)
    5. ACTION: LuisGomez to send cluster keyword consolidation questions to integration-dev list to get answers from team. (jamoluhrsen, 16:39:38)
    6. vratko points out that keeping ssh sessions open for reuse during entire suite has troubles (bugs in sshlibrary). suggests that, even though slower, it probably is better to open and close ssh session for each action. (jamoluhrsen, 16:48:36)
    7. we can have ssh keywords that allow us to have both options. 1) to reuse already open session and 2) create and close a new one (jamoluhrsen, 16:49:35)
    8. no objections to granting system test waiver to neutron project (jamoluhrsen, 17:01:36)
    9. congrats to gvrangan on getting unanimous approval on promotion to committer (jamoluhrsen, 17:02:02)
    10. ACTION: jamoluhrsen to email tsc to vote on gvrangan's promotion. (jamoluhrsen, 17:02:16)


Meeting ended at 17:02:21 UTC (full logs).

Action items

  1. vratko to send email to release notifying that we will not have stable distribution in Boron
  2. jamoluhrsen will binary search distros to find when feature loading started taking longer
  3. LuisGomez to send cluster keyword consolidation questions to integration-dev list to get answers from team.
  4. jamoluhrsen to email tsc to vote on gvrangan's promotion.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen will binary search distros to find when feature loading started taking longer
    2. jamoluhrsen to email tsc to vote on gvrangan's promotion.
  2. LuisGomez
    1. LuisGomez to send cluster keyword consolidation questions to integration-dev list to get answers from team.


People present (lines said)

  1. jamoluhrsen (41)
  2. dfarrell07 (5)
  3. odl_meetbot (4)
  4. plaurin (2)
  5. anipbu (2)
  6. tykeal (1)
  7. zxiiro (0)
  8. LuisGomez (0)


Generated by MeetBot 0.1.4.