#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:14 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:02:50)
    1. distribution check job started failing with new patch, but it's been reverted and things are ok now (jamoluhrsen, 16:03:32)
    2. https://git.opendaylight.org/gerrit/#/c/38365/ (jamoluhrsen, 16:03:58)
    3. karaf version will be upgraded next week. (jamoluhrsen, 16:04:49)
    4. https://git.opendaylight.org/gerrit/#/c/26323/ (jamoluhrsen, 16:05:19)
    5. distribution team may need to force odlparent merge, because distribution-check will probably fail. (jamoluhrsen, 16:06:07)

  2. packing (jamoluhrsen, 16:07:25)
    1. no news this week (jamoluhrsen, 16:07:40)

  3. builder (jamoluhrsen, 16:08:01)
    1. lots of vagrant defn changes recently (jamoluhrsen, 16:08:15)
    2. private cloud migration of sandbox soon (pending resolving issue with rackspace) (jamoluhrsen, 16:08:41)
    3. hopefully migration in two weekends from now. (jamoluhrsen, 16:09:02)
    4. https://jenkins.opendaylight.org/sandbox-new/ (jamoluhrsen, 16:09:24)
    5. vagrant updates topic branch here: https://git.opendaylight.org/gerrit/#/q/status:merged+project:releng/builder+branch:master+topic:vagrant_updates (jamoluhrsen, 16:10:18)
    6. fedora21 system still being used by 2 jobs. We want to move those jobs to use new ubuntu mininet system because there is not a fedora vm in new sandbox. (jamoluhrsen, 16:12:41)
    7. ACTION: jamoluhrsen to see if those fedora21 jobs can work in current sandbox with other mininet vm (jamoluhrsen, 16:13:22)
    8. luisgomez notes that the fedora vm is not stable, so best if we move away from it anyway (jamoluhrsen, 16:13:54)
    9. don't need to move jobs in releng right now, just verify that sandbox is ok without fedora (jamoluhrsen, 16:14:35)
    10. JJB 1.5 is out, will upgrade soon after Be SR2 (zxiiro, 16:14:52)
    11. JJB 1.5 supports parallel job updates (zxiiro, 16:14:52)
    12. next release JJB 2.0 breaks API (zxiiro, 16:14:52)
    13. Experimenting with linking documentation project to infrastructure docs (zxiiro, 16:15:41)
    14. https://git.opendaylight.org/gerrit/38394 releng/builder project patch (zxiiro, 16:15:41)
    15. https://git.opendaylight.org/gerrit/38393 Documentation project patch (zxiiro, 16:15:41)
    16. https://opendaylight.readthedocs.io/en/latest/ (tykeal, 16:18:50)

  4. release (jamoluhrsen, 16:20:04)
    1. Be SR2 still on hold. openflowplugin has a blocking bug still being worked out. (jamoluhrsen, 16:20:28)
    2. big question is if we should release with this bug, or delay SR2 (jamoluhrsen, 16:21:12)
    3. don't know of any consumers urgently waiting on SR2. opnfv is not. (jamoluhrsen, 16:22:01)
    4. anipbu notes that SRs are consistently delayed. how can we get ahead of the curve? (jamoluhrsen, 16:23:09)
    5. can projects give us more info on their test failures in beryllium so we aren't asking the same questions every time we do an SR and have to analyze their system test failures. (jamoluhrsen, 16:24:17)

  5. misc (jamoluhrsen, 16:24:55)
    1. offset2 M2 is now, but only one project has asked for a system test waiver (jamoluhrsen, 16:26:11)
    2. ACTION: anipbu to email likely projects to formally request their system test waivers (jamoluhrsen, 16:26:33)
    3. congratulations to gvrangan on committer status. (jamoluhrsen, 16:27:42)
    4. Thanks Jamo and thanks everyone for the votes (gvrangan, 16:28:16)
    5. jamoluhrsen looking for help reviewing https://git.opendaylight.org/gerrit/#/c/35060/ (jamoluhrsen, 16:28:30)
    6. for once we cut the meeting short. 30m back to everyone. (jamoluhrsen, 16:32:37)


Meeting ended at 16:32:39 UTC (full logs).

Action items

  1. jamoluhrsen to see if those fedora21 jobs can work in current sandbox with other mininet vm
  2. anipbu to email likely projects to formally request their system test waivers


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to see if those fedora21 jobs can work in current sandbox with other mininet vm


People present (lines said)

  1. jamoluhrsen (32)
  2. zxiiro (7)
  3. odl_meetbot (3)
  4. tykeal (2)
  5. odp-gerritbot (2)
  6. dfarrell07 (1)
  7. gvrangan (1)


Generated by MeetBot 0.1.4.