#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:34 UTC (full logs).

Meeting summary

    1. SR2 is released (jamoluhrsen, 16:04:26)
    2. SR2 rpms built and handed over to OPNFV. (jamoluhrsen, 16:04:48)
    3. build setup is fairly automated, but we can be better. probably some better tools can be used. (jamoluhrsen, 16:05:27)
    4. version bump is still going on, should be done today. (jamoluhrsen, 16:06:29)
    5. stable/beryllium branch still locked until version bump is done. zxiiro sends emails when that is done; (jamoluhrsen, 16:06:55)
    6. jamoluhrsen points out that didm is still not part of Boron autorelease, but the ball is in their court to get it back in. risk is they will not be part of the released distro. (jamoluhrsen, 16:07:53)
    7. https://bugs.opendaylight.org/show_bug.cgi?id=5821 jamoluhrsen asks about bug where autorelease distro is having troubles vs normal snapshot distro (jamoluhrsen, 16:09:05)
    8. one idea is to have autorelease build all the projects except int/dist (jamoluhrsen, 16:09:44)
    9. ACTION: jamoluhrsen to update bug/trello with a task to analyze the files/folders between the different distribution (jamoluhrsen, 16:14:42)

  1. distribution (jamoluhrsen, 16:14:54)
    1. port conflict is still there for every release. (jamoluhrsen, 16:15:43)
    2. we don't want to see this port conflict test failure every time we release. (jamoluhrsen, 16:16:16)
    3. we will start pulling projects from distribution that have these port conflicts (jamoluhrsen, 16:17:02)

  2. packaging (jamoluhrsen, 16:18:53)
    1. opnfv plugfest going well and packaging conversations happening and hoping to move opnfv installers toward more upstream packaging tools (jamoluhrsen, 16:20:12)
    2. brady from opnfv still looking for better/quicker/stable releases. (jamoluhrsen, 16:22:28)
    3. dfarrell07 asks if we can keep our autorelease artifacts around longer. (jamoluhrsen, 16:22:44)
    4. autorelease can only be kept for aprox 60days, and we can't really keep more than that. (jamoluhrsen, 16:23:06)
    5. jamoluhrsen wants to create another distribution-test job that only contains 100% passing CSIT jobs (jamoluhrsen, 16:25:25)
    6. idea might just be to remove unstable tests from current distribution-test (jamoluhrsen, 16:27:12)
    7. ACTION: jamoluhrsen to send email that CSIT jobs will be removed from distribution-test unless they meet test case expectations (jamoluhrsen, 16:29:03)

  3. builder (jamoluhrsen, 16:29:16)
    1. jenkins webui was slow several times in the past week or so. (jamoluhrsen, 16:29:49)
    2. zxiiro kicked jenkins and now it seems better. (jamoluhrsen, 16:30:18)
    3. there are latency tests on the webui and releng folks do get alerts so they can know good times to restart (jamoluhrsen, 16:30:43)
    4. jamoluhrsen still needs to test that we don't need fedora21 in sandbox. (jamoluhrsen, 16:31:38)
    5. still blocked by rackspace on private cloud migration. (jamoluhrsen, 16:31:58)
    6. migration in two weekends maybe (jamoluhrsen, 16:32:14)
    7. vratko asks why the merge job keeps failing? (jamoluhrsen, 16:32:42)
    8. zxiiro points out that when jenkins is slow, the merge job will fail. we need to move things off of jenkins (like archive artifacts) (jamoluhrsen, 16:33:14)
    9. no solution for moving artifacts to nexus yet, but zxiiro has a plugin that may help. (jamoluhrsen, 16:35:10)
    10. https://lists.opendaylight.org/pipermail/spectrometer-dev/2016-May/000137.html Spectrometer Report Tool (zxiiro, 16:35:50)

  4. spectrometer (jamoluhrsen, 16:37:16)
    1. spectrometer now pulling useful stats. (jamoluhrsen, 16:37:36)
    2. https://lists.opendaylight.org/pipermail/spectrometer-dev/2016-May/000137.html Spectrometer Report Tool (jamoluhrsen, 16:37:41)
    3. some projects were not tagged correctly so stats were not accurate in initial report. (jamoluhrsen, 16:38:10)

  5. system test waivers (jamoluhrsen, 16:39:07)
    1. jamoluhrsen asks if we can give documentation system test waiver (jamoluhrsen, 16:39:31)
    2. AGREED: (jamoluhrsen, 16:39:41)
    3. AGREED: (jamoluhrsen, 16:39:43)
    4. AGREED: documentation granted system test waiver (jamoluhrsen, 16:40:11)

  6. vpn service system test patch (jamoluhrsen, 16:41:02)
    1. new patch is now using robot requests library (jamoluhrsen, 16:41:51)
    2. https://git.opendaylight.org/gerrit/#/c/38662/ vpn service patch needs review (jamoluhrsen, 16:57:22)
    3. vpn service also is in need of a CSIT topology where there is a gateway router (jamoluhrsen, 16:57:29)
    4. mahendar will send out an email with a diagram of this topology so we can figure out how to accommodate (jamoluhrsen, 16:57:34)

  7. performance update (jamoluhrsen, 16:57:40)
    1. there is a 2nd version of the performance document that we presented at ONF 2016 (jamoluhrsen, 16:57:44)
    2. ONOS has since given a new version of their controller and asked ODL to re-test with that new version (jamoluhrsen, 16:57:49)
    3. there is a better script to run northbound flow config (jamoluhrsen, 16:57:58)
    4. only the openflow tests are redone. (jamoluhrsen, 16:58:03)
    5. results are similar, but ONOS is still a little bit better. (jamoluhrsen, 16:58:08)
    6. the new paper will give a better explanation on why we are doing tests the way we are (e.g. using REST to program flows vs using java api to push flows) (jamoluhrsen, 16:58:14)


Meeting ended at 16:58:57 UTC (full logs).

Action items

  1. jamoluhrsen to update bug/trello with a task to analyze the files/folders between the different distribution
  2. jamoluhrsen to send email that CSIT jobs will be removed from distribution-test unless they meet test case expectations


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to update bug/trello with a task to analyze the files/folders between the different distribution
    2. jamoluhrsen to send email that CSIT jobs will be removed from distribution-test unless they meet test case expectations


People present (lines said)

  1. jamoluhrsen (55)
  2. vorburger (3)
  3. dfarrell07 (3)
  4. odl_meetbot (3)
  5. zxiiro (3)
  6. tykeal (2)
  7. skitt (2)


Generated by MeetBot 0.1.4.