#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:04:36 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:05:15)
    1. fix for failures in test suites for netconf suites that required changes in karaf (jamoluhrsen, 16:05:53)
    2. now while we compile distribution, we are having to edit some things in a jar file (jamoluhrsen, 16:06:50)
    3. migration of distribution towards using karaf parent (jamoluhrsen, 16:07:11)
    4. people are asking that ODL version is available outside of restconf (jamoluhrsen, 16:07:42)
    5. a new config file will be present in order to expose this ${version} (jamoluhrsen, 16:08:28)
    6. didm was removed from distribution (jamoluhrsen, 16:08:58)

  2. packaging (jamoluhrsen, 16:09:29)
    1. dfarrell07 in spain :) (jamoluhrsen, 16:09:45)
    2. new rpms created with fixes for opnfv (jamoluhrsen, 16:09:59)
    3. bug fixes in ansible role made it this week (jamoluhrsen, 16:10:10)
    4. ODL interns starting monday, but packaging intern already working on .deb (jamoluhrsen, 16:10:37)
    5. tutorial group looking at l2switch as the first tutorial worked on by LF interns (jamoluhrsen, 16:11:17)

  3. release (jamoluhrsen, 16:14:54)
    1. atrium & snmp4sdn asking for system test waivers (jamoluhrsen, 16:15:21)
    2. boron will see a restconf migration and CSIT jobs are going to be affected. (jamoluhrsen, 16:16:57)
    3. restconf deprecation will happen at the *end* of boron. (jamoluhrsen, 16:16:57)
    4. vratko suggests that in Carbon we a library that can detect the ODL_STREAM and then contstruct the proper URL (jamoluhrsen, 16:18:38)
    5. next Wed (6/1) @ 10am PST, we'll have a meeting for projects that have questions around M3 (e.g. how to add karaf features? how to create initial system test job? how to upload ascii outlines for docs?) (jamoluhrsen, 16:20:46)

  4. builder stuff (jamoluhrsen, 16:22:07)
    1. sandbox is broken, and we don't know what's up. something broken in last day or two (jamoluhrsen, 16:22:38)
    2. sandbox issue open with rackspace, but no ETA yet (jamoluhrsen, 16:23:17)
    3. releng migration can't happen until we know issues like we have in sandbox are not happening (jamoluhrsen, 16:24:17)
    4. zxiiro's builder patches still need to be rebased when pushing jobs to sandbox until releng migration happens and then those patches can be merged (jamoluhrsen, 16:25:31)

  5. misc (jamoluhrsen, 16:26:42)
    1. sshpass issue after karaf upgrade still an issue. (jamoluhrsen, 16:27:28)
    2. LuisGomez points out sshpass issue is environment related (e.g. OS, jdk, etc) (jamoluhrsen, 16:28:06)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=5923 (vrpolak, 16:30:09)
    4. https://bugs.opendaylight.org/show_bug.cgi?id=5923 bug to track sshpass/karaf issue. (jamoluhrsen, 16:30:55)
    5. jamoluhrsen thinks this needs to be fixed before we release Boron (jamoluhrsen, 16:31:08)
    6. we have a plan to start publishing artifacts to nexus. (jamoluhrsen, 16:31:55)
    7. pushing to nexus still needs the work to happen, but should be feasible. (jamoluhrsen, 16:32:37)
    8. vratko has a new suite that is around controller upgrade (jamoluhrsen, 16:33:46)
    9. upgrade suite, copies data (snapshot and journal) from older version of controller and starts newer version and validates that the data is seen there. (jamoluhrsen, 16:34:21)

  6. system test waivers (jamoluhrsen, 16:38:26)
    1. SNMP4SDN granted system test waiver, but the request is there that we get external system test results in a periodic manner if possible (jamoluhrsen, 16:39:22)
    2. anipbu points out that we are expecting these external results to be reported in the system test report (jamoluhrsen, 16:40:39)
    3. https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report system test report info (jamoluhrsen, 16:41:20)
    4. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template system test feature report template (dfarrell07, 16:42:18)
    5. ACTION: jamoluhrsen to put link to system test template at top of reports landing page (jamoluhrsen, 16:42:46)
    6. ACTION: jamoluhrsen too add section to system test template for projects to report their external results (jamoluhrsen, 16:43:14)
    7. ATRIUM project is from ONF and uses multiple switch vendors for the data plane and that is not possible in our CI environment (jamoluhrsen, 16:45:17)
    8. ATRIUM granted system test waiver (jamoluhrsen, 16:45:44)
    9. suggested that ATRIUM could possibly trigger their system test on gerrit patches, but that would be a long term goal. In the short term we'll get test result dumps (jamoluhrsen, 16:46:43)
    10. ACTION: jamoluhrsen to inform projects about waivers (jamoluhrsen, 16:46:58)

  7. open items (jamoluhrsen, 16:47:36)
    1. jamoluhrsen pushed patches to remove unstable CSIT jobs from distribution-test (jamoluhrsen, 16:48:03)
    2. https://git.opendaylight.org/gerrit/#/c/39451 patch to remove unstable tests from beryllium distribution-test job (jamoluhrsen, 16:51:53)
    3. https://git.opendaylight.org/gerrit/#/c/39453/ patch to remove unstable tests from boron distribution-test job (jamoluhrsen, 16:52:12)
    4. ACTION: jamoluhrsen to get patches merged and email relevant projects and release list about what's happening (jamoluhrsen, 16:52:44)
    5. robot framework install on robot VM is being removed from jenkins scripts, because it's being done in venv now (jamoluhrsen, 16:55:28)
    6. https://git.opendaylight.org/gerrit/39341 (vrpolak, 16:55:55)
    7. https://git.opendaylight.org/gerrit/39341 patch to remove robot install (jamoluhrsen, 16:56:29)


Meeting ended at 16:57:02 UTC (full logs).

Action items

  1. jamoluhrsen to put link to system test template at top of reports landing page
  2. jamoluhrsen too add section to system test template for projects to report their external results
  3. jamoluhrsen to inform projects about waivers
  4. jamoluhrsen to get patches merged and email relevant projects and release list about what's happening


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to put link to system test template at top of reports landing page
    2. jamoluhrsen too add section to system test template for projects to report their external results
    3. jamoluhrsen to inform projects about waivers
    4. jamoluhrsen to get patches merged and email relevant projects and release list about what's happening


People present (lines said)

  1. jamoluhrsen (53)
  2. dfarrell07 (6)
  3. odl_meetbot (3)
  4. vrpolak (2)


Generated by MeetBot 0.1.4.