#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:31 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 16:05:27)
    1. Be SR2 docker/vagrant stuff finally built and available (jamoluhrsen, 16:05:55)
    2. ODL puppet module maintenance happening (jamoluhrsen, 16:06:10)
    3. skitt helping clarify specifics around creating .deb packaging (jamoluhrsen, 16:07:09)

  2. distribution (jamoluhrsen, 16:08:05)
    1. controller merge job blocking issue is fixed. (jamoluhrsen, 16:08:39)
    2. for M3 we want to merge the new config feature, but we need change in controller for it to work. (jamoluhrsen, 16:09:37)
    3. this new config feature is the enhancement to allow us to externally check the versoin of ODL (jamoluhrsen, 16:10:32)
    4. ACTION: vratko to remind controller about their change to be merged (jamoluhrsen, 16:11:35)
    5. sandbox not able to build distribution at this point (jamoluhrsen, 16:12:48)

  3. builder (jamoluhrsen, 16:13:53)
    1. sandbox workaround in place to allow us to push jobs to sandbox... which works. (jamoluhrsen, 16:14:22)
    2. https://lists.opendaylight.org/pipermail/integration-dev/2016-June/006945.html small issues pointed out by vratko (jamoluhrsen, 16:14:49)
    3. sandbox private cloud cannot access resources in releng public cloud (jamoluhrsen, 16:15:33)
    4. migration for releng cloud to private cloud planned for 3 weeks from now (tentatively) (jamoluhrsen, 16:16:16)
    5. seems that there are some differences/problems in sandbox that we do/don't see in releng. And it seems that maybe new problems are now happening that were ok before the recent breakage on Rackspace side. (jamoluhrsen, 16:18:54)
    6. ACTION: jamoluhrsen to send email release list to request projects to test their CSIT jobs in the new sandbox (aka private cloud) before we get to the releng migration (jamoluhrsen, 16:20:03)
    7. differences in sandbox 1) newer version of jenkins 2) plugins updated 3) all slave images are now updated (jamoluhrsen, 16:20:34)
    8. another difference, moved to jclouds plugin from openstack plugin (jamoluhrsen, 16:20:55)
    9. secondary changes are jjb related (e.g. naming) (jamoluhrsen, 16:21:20)
    10. LuisGomez asks if we can upgrade the openjdk version in releng now, or do we have to wait for migration to private cloud? (jamoluhrsen, 16:23:52)
    11. need openjdk upgraded in order to verify the sshpass, /bin/client breakage is fixed with newer version (jamoluhrsen, 16:25:12)
    12. we can validate this sshpass, /bin/client issue is fixed in the sandbox (jamoluhrsen, 16:25:50)

  4. release (jamoluhrsen, 16:29:07)
    1. M3 working session via IRC happened with some success helping new projects (jamoluhrsen, 16:29:47)
    2. autorelease has not been successful for a *very* long time. (jamoluhrsen, 16:30:05)
    3. anipbu suggests we need to start removing projects from Boron autorelease. We've hit M4 already. (jamoluhrsen, 16:30:38)
    4. M3 milestone is today, so we should get a better idea of features that will end up in distribution. (jamoluhrsen, 16:31:17)
    5. ACTION: anipbu will start checking autorelease daily and we may start removing projects on a daily basis (jamoluhrsen, 16:31:57)

  5. misc (jamoluhrsen, 16:33:20)
    1. hackfest is coming up (6/29-6/30) (jamoluhrsen, 16:33:53)
    2. https://www.opendaylight.org/events/2016-06-29-000000-2016-06-30-000000/opendaylight-june-hackfest-2016 hackfest registration (jamoluhrsen, 16:34:09)
    3. ACTION: LuisGomez to send email to integration-dev to get a list of topics/agenda for hackfest (jamoluhrsen, 16:34:37)
    4. cluster/perf friday meeting was ok via bluejeans (8:30am PST every friday) (jamoluhrsen, 16:36:13)
    5. we will also discuss this bulkomatic feature on the friday call. (jamoluhrsen, 16:36:44)
    6. demo next week from intern doing Longevity test work. (jamoluhrsen, 16:37:16)
    7. ACTION: LuisGomez to put aaa CSIT back in distribution-test after double checking that it's truly stable (jamoluhrsen, 16:40:24)
    8. ACTION: gvrangan VTN coordinator job failing in releng (oddly, not in sandbox) so we need to remove it from distribution-test (jamoluhrsen, 16:41:40)
    9. vratko suggests we could create another verify job that only builds offset 0 projects (jamoluhrsen, 16:44:07)
    10. ACTION: vratko can give it a try, but can't test in current sandbox state (jamoluhrsen, 16:45:17)
    11. ACTION: LuisGomez to check/merge version patch https://git.opendaylight.org/gerrit/#/c/37210/ (jamoluhrsen, 16:47:43)
    12. ACTION: vratko to check if the heapdump patch is merged in all the right branches (jamoluhrsen, 16:55:35)


Meeting ended at 16:57:44 UTC (full logs).

Action items

  1. vratko to remind controller about their change to be merged
  2. jamoluhrsen to send email release list to request projects to test their CSIT jobs in the new sandbox (aka private cloud) before we get to the releng migration
  3. anipbu will start checking autorelease daily and we may start removing projects on a daily basis
  4. LuisGomez to send email to integration-dev to get a list of topics/agenda for hackfest
  5. LuisGomez to put aaa CSIT back in distribution-test after double checking that it's truly stable
  6. gvrangan VTN coordinator job failing in releng (oddly, not in sandbox) so we need to remove it from distribution-test
  7. vratko can give it a try, but can't test in current sandbox state
  8. LuisGomez to check/merge version patch https://git.opendaylight.org/gerrit/#/c/37210/
  9. vratko to check if the heapdump patch is merged in all the right branches


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send email release list to request projects to test their CSIT jobs in the new sandbox (aka private cloud) before we get to the releng migration
  2. UNASSIGNED
    1. vratko to remind controller about their change to be merged
    2. anipbu will start checking autorelease daily and we may start removing projects on a daily basis
    3. LuisGomez to send email to integration-dev to get a list of topics/agenda for hackfest
    4. LuisGomez to put aaa CSIT back in distribution-test after double checking that it's truly stable
    5. gvrangan VTN coordinator job failing in releng (oddly, not in sandbox) so we need to remove it from distribution-test
    6. vratko can give it a try, but can't test in current sandbox state
    7. LuisGomez to check/merge version patch https://git.opendaylight.org/gerrit/#/c/37210/
    8. vratko to check if the heapdump patch is merged in all the right branches


People present (lines said)

  1. jamoluhrsen (45)
  2. dfarrell07 (7)
  3. odl_meetbot (3)
  4. vrpolak (1)
  5. odp-gerritbot (1)


Generated by MeetBot 0.1.4.