#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:03:02 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:04:54)
    1. version support job is there, but the actual string is not ready pending merge in controller project (jamoluhrsen, 16:05:36)
    2. migrating dist-karaf under karaf-parent (jamoluhrsen, 16:05:50)
    3. system test template has been filled for distribution project (jamoluhrsen, 16:06:27)
    4. documentation coming next. (e.g. those config scripts, etc) (jamoluhrsen, 16:06:59)
    5. https://jenkins.opendaylight.org/releng/view/Distribution-Jobs/job/distribution-csit-1node-userfeatures-all-boron/ <-- job for controller version check (jamoluhrsen, 16:08:45)
    6. https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin <-- weather report for karaf-parent migratoin (jamoluhrsen, 16:09:27)
    7. LuisGomez notes that this release our distribution jobs are not breaking as frequently (jamoluhrsen, 16:10:45)

  2. packaging (jamoluhrsen, 16:10:54)
    1. we deleted all of our code in the old Integration git repo. This helped immediately because OPNFV was still consuming it. They have been fixed :) (jamoluhrsen, 16:11:46)
    2. boron autorelease completed twice recently, so now we have a boron rpm to consume (jamoluhrsen, 16:12:13)

  3. release (jamoluhrsen, 16:13:50)
    1. https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration (anipbu, 16:14:43)
    2. https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration <-- netvirt vpnservice migration weather item (jamoluhrsen, 16:14:57)

  4. builder (jamoluhrsen, 16:15:58)
    1. jamoluhrsen points out that new sandbox is giving different results than what we see in the current releng silo (jamoluhrsen, 16:17:44)
    2. ACTION: jamoluhrsen to send email with list of sandbox issues. (jamoluhrsen, 16:20:39)
    3. migration for releng silo to new private cloud is scheduled for June 25th. (jamoluhrsen, 16:23:09)
    4. thanhs review patch now uses the new openstack plugin, not jclouds plugin (jamoluhrsen, 16:24:04)
    5. all the VMs are now 4G instead of 8G and all periodic jobs passed with this smaller setup (jamoluhrsen, 16:25:12)
    6. autorelease job now will now be doing "release candidate" builds. instead of "daily". (jamoluhrsen, 16:26:22)
    7. JJB 1.6.1 released this morning. fixes issue on windows. (jamoluhrsen, 16:27:32)
    8. VM lifecycle question --> the VMs are destroyed if idle after only 1m (jamoluhrsen, 16:28:40)
    9. https://lists.opendaylight.org/pipermail/release/attachments/20160609/59c3290a/attachment-0001.png <-- new autorelease branch visual (jamoluhrsen, 16:32:32)
    10. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/lastSuccessfulBuild/artifact/deploy-staged-repository.log <-- how to find staging repository (jamoluhrsen, 16:36:14)
    11. dfarrell07 points out that we aren't sure if this helps external projects grab daily distros that we know are stable (based on CSIT results) (jamoluhrsen, 16:36:50)

  5. demos (jamoluhrsen, 16:55:10)
    1. Kumar gave demo of longevity testing work where we can collect JVM metrics and create plots (jamoluhrsen, 16:55:38)
    2. Rohit demos dashboard project. (jamoluhrsen, 16:57:01)
    3. http://52.88.253.242:8080/main/ <-- temp dashboard URL (jamoluhrsen, 16:57:21)
    4. please provide feedback on dashboard project. we'll spend some time at hackfest talking about it as well. (jamoluhrsen, 17:00:50)

  6. misc (jamoluhrsen, 17:16:40)
    1. didn't get to a few items (jamoluhrsen, 17:17:08)
    2. 1) karaf ssh issue coming in next update (https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140&version=12334639) (jamoluhrsen, 17:18:23)
    3. 2) OPFLEX and INFRAUTILS system test waiver requested. will work on that via email (jamoluhrsen, 17:18:58)
    4. 3) didn't get to talk about hooking external CI in to gerrit review path (jamoluhrsen, 17:19:34)
    5. 4) natapp was removed from compatible-with-all list (jamoluhrsen, 17:20:11)


Meeting ended at 17:20:15 UTC (full logs).

Action items

  1. jamoluhrsen to send email with list of sandbox issues.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send email with list of sandbox issues.


People present (lines said)

  1. jamoluhrsen (39)
  2. dfarrell07 (7)
  3. odl_meetbot (4)
  4. edwarnicke (3)
  5. tykeal (2)
  6. zxiiro (2)
  7. anipbu (1)
  8. LuisGomez (0)


Generated by MeetBot 0.1.4.