#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:54 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:03:10)
    1. we have a patch for distribution documentation (cluster config and persistence config scripts) (jamoluhrsen, 16:03:47)
    2. ACTION: LuisGomez to document the version API. (jamoluhrsen, 16:04:36)
    3. small changes in distribution this week (projects adding features) (jamoluhrsen, 16:05:12)
    4. version api changes in stable/beryllium now (jamoluhrsen, 16:05:22)
    5. Vratko working on a project that will use the latest greatest karaf version (SNAPSHOT) and not a static released version (jamoluhrsen, 16:06:04)
    6. anipbu wants to know if we'll be getting a "stable distribution" this release. LuisGomez notes that there is no stable feature yet, so probably no chance to get a "stable distribution" (jamoluhrsen, 16:08:39)
    7. Vratko confirms he doesn't expect any stable features this release either. (jamoluhrsen, 16:09:45)
    8. LuisGomez argues the reasoning behind creating a stable distribution (only containing stable features) might not be worth it. (jamoluhrsen, 16:17:14)
    9. dfarrell07 points out the idea of a stable distro came from user advisory group. (jamoluhrsen, 16:17:30)
    10. another idea is that we can create two feature repos where one is the stable repo, but the artifacts you download as the ODL .zip would still have every feature. (jamoluhrsen, 16:20:11)

  2. packaging (jamoluhrsen, 16:20:48)
    1. we now have a .deb package that can be built from Int repo. w00t! (jamoluhrsen, 16:21:07)
    2. https://git.opendaylight.org/gerrit/#/c/40350 Patch to remove code from old Int repo li branch (dfarrell07, 16:21:38)
    3. patches are ready to wipe the other branches in the old Integration repo (jamoluhrsen, 16:21:45)
    4. https://git.opendaylight.org/gerrit/#/c/40349 Patch to remove code from old Int repo master branch (dfarrell07, 16:21:49)

  3. release (jamoluhrsen, 16:22:38)
    1. lots of weather items this week, so maybe some choppy waters for us? (jamoluhrsen, 16:23:07)

  4. builder (jamoluhrsen, 16:23:41)
    1. submodule timeout during cloning bumped to 60 minutes due to slow network (zxiiro, 16:23:51)
    2. signal15 issue seen randomly because of slow network causing timeouts. (jamoluhrsen, 16:24:17)
    3. network slowness is believed to be the pipe between the public and private clouds, so we will wait to see if it goes away after we migrate releng to private cloud (jamoluhrsen, 16:24:59)
    4. VM sizes were all reduced earlier this week, but there so many jobs that needed 8G for builder that it's now back to the default. (jamoluhrsen, 16:26:03)
    5. testing CSIT jobs with small (4G) VMs (jamoluhrsen, 16:26:51)
    6. jamoluhrsen suggest to run openflowplugin switch scalability with small VM (jamoluhrsen, 16:27:47)
    7. https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-periodic-sw-scalability-daily-lithium-redesign-only-beryllium/ <--- mininet VM goes to 500 switches. might need extra memory for that mininet vm (jamoluhrsen, 16:29:16)
    8. JJB needs admin rights to query plugins info (zxiiro, 16:31:23)
    9. current workaround is to disable it via configuration (zxiiro, 16:31:24)
    10. https://review.openstack.org/326722/ Potential Fix for admin rights (zxiiro, 16:31:24)
    11. Started looking into pushing logs off of Jenkins, seems to work but need a web frontend to handle gzipped text files (zxiiro, 16:32:29)
    12. https://spectrometer.opendaylight.org/ (zxiiro, 16:33:45)
    13. still on track for the 25th to migrate releng to private cloud (jamoluhrsen, 16:34:10)
    14. vratko points out some failures starting VMs earlier in week, but now fixed. (jamoluhrsen, 16:34:42)
    15. we now have a log of what changes made it in to the current distro (inside .zip) (jamoluhrsen, 16:35:54)

  5. misc (jamoluhrsen, 16:36:03)
    1. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/lastSuccessfulBuild/artifact/patches/taglist.log/*view*/ taglist.log (zxiiro, 16:36:19)
    2. no disagreement to granting systest waiver to opflex and infrautils (jamoluhrsen, 16:36:42)
    3. ACTION: jamoluhrsen to update wiki, send email about system test waivers being granted (jamoluhrsen, 16:39:06)
    4. question about whether we have a CSIT job that uses the persistence config script? (jamoluhrsen, 16:40:03)
    5. no CSIT job uses it yet, but it will be coming. (jamoluhrsen, 16:40:15)
    6. work was coming to change the 200 status code on PUT calls which would affect CSIT jobs that are expecting that. (jamoluhrsen, 16:41:23)
    7. the patch to change this 200 response code got a -1 so not sure if it will come in Boron or not. (jamoluhrsen, 16:41:47)
    8. netconf EOS suite has been merged recently. (jamoluhrsen, 16:43:06)
    9. we need more consistent 100% passing CSIT verify jobs. (jamoluhrsen, 16:48:16)
    10. some conversation around longevity tests. one idea is that we let those jobs burst back to the public cloud and not use resources in our faster private cloud (jamoluhrsen, 16:59:08)


Meeting ended at 17:00:01 UTC (full logs).

Action items

  1. LuisGomez to document the version API.
  2. jamoluhrsen to update wiki, send email about system test waivers being granted


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to update wiki, send email about system test waivers being granted


People present (lines said)

  1. jamoluhrsen (40)
  2. zxiiro (9)
  3. dfarrell07 (3)
  4. odl_meetbot (3)
  5. vrpolak (1)


Generated by MeetBot 0.1.4.