#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:55 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:04:05)
    1. m4 status report has been updated with missing items. e.g. all top level features need dev guide. (jamoluhrsen, 16:04:39)
    2. maven central requirements not quite done. (e.g. meta data in pom files) (jamoluhrsen, 16:05:51)
    3. ACTION: vratko to send quick email for help, and hopefully someone can jump in to help (jamoluhrsen, 16:06:53)
    4. probably not pushing artifacts to maven central this release, so probably not biggest priority anyway (jamoluhrsen, 16:07:37)
    5. jamoluhrsen notes that beryllium was not building earlier this week, because of a merge job failure in USC project (jamoluhrsen, 16:08:43)
    6. LuisGomez asks about the nexus conn timeout issues. (jamoluhrsen, 16:09:53)
    7. there is a helpdesk ticket for nexus timeout. (jamoluhrsen, 16:12:37)

  2. packaging (jamoluhrsen, 16:12:50)
    1. lots of good rpm work happened at the hackfest. good automation done. (jamoluhrsen, 16:13:20)
    2. packaging wiki improvements made. (jamoluhrsen, 16:13:42)
    3. plaurin still working on vagrant base boxes (jamoluhrsen, 16:13:59)
    4. tutorials interns pushing patches now. (jamoluhrsen, 16:14:23)
    5. .deb work committed now and automation for new builds is in progress. (jamoluhrsen, 16:14:56)

  3. release (jamoluhrsen, 16:16:01)
    1. Be SR3 coming up in less than a month. (3 weeks before cut off date) (jamoluhrsen, 16:16:31)
    2. build test failures in bgpcep (jamoluhrsen, 16:16:47)
    3. ietf yang type upgrade happening late in Boron release, but lots of people working on it. (jamoluhrsen, 16:17:05)
    4. boron autorel *still* failing, also because bgpcep (jamoluhrsen, 16:17:33)
    5. looks like there is email visibility for bgpcep for Boron in compilation error (jamoluhrsen, 16:18:53)
    6. not sure if anyone is looking at Beryllium bgpcep test failures. (jamoluhrsen, 16:19:26)
    7. probably an IRC working session coming to help power through ietf yang stuff. maybe next wed (jamoluhrsen, 16:22:39)

  4. builder (jamoluhrsen, 16:22:49)
    1. jenkins seems to be relatively stable finally, since we began migration. (jamoluhrsen, 16:23:17)
    2. still tuning the minions (aka slaves) to maximize the number of jobs we can run in parallel without running out of resources (jamoluhrsen, 16:23:59)
    3. new wrapper macro opendaylight-infra-wrappers with parameter build-timeout (zxiiro, 16:24:42)
    4. https://git.opendaylight.org/gerrit/41421/ opendaylight-infra-wrappers macro (zxiiro, 16:24:42)
    5. all jobs are single use for nodes, so jobs are thrown away after every job. (jamoluhrsen, 16:24:45)
    6. single use might help with jobs that were hanging before. instances do get brought up quickly so this is not much of a problem. (jamoluhrsen, 16:25:14)
    7. new job types should always use the new opendaylight-infra wrapper (jamoluhrsen, 16:25:45)
    8. ACTION: zxiiro to send an email about using this new opendaylight-infra wrapper (jamoluhrsen, 16:26:03)
    9. SSH credentials are now opendaylight-jenkins-ssh instead of {ssh-credentials} variable (zxiiro, 16:26:34)
    10. https://git.opendaylight.org/gerrit/41424/ simplify ssh-credentials (zxiiro, 16:26:34)
    11. sandbox has 64 cores (jamoluhrsen, 16:32:46)
    12. we now have 2 external CI systems that now have access to vote on projects (jamoluhrsen, 16:34:50)
    13. LuisGomez thinks we might need a new, separate set of resources just to run our performance tests. (jamoluhrsen, 16:36:00)
    14. Docs now themed now with bootstrap (zxiiro, 16:37:54)
    15. http://docs.opendaylight.org/ (zxiiro, 16:37:54)
    16. http://opendaylight.readthedocs.io/en/latest/_static/integration/robot/Utils.robot.html robot library docs now online. (jamoluhrsen, 16:40:02)

  5. new gerrit workflow being proposed (jamoluhrsen, 16:40:30)
    1. basic workflow, gerrit submission -> +1 verify -> +2 code-review -> next it new category for "approve". if "approve" is given +1 then project defined set of jobs is then run (e.g. CSIT). if these jobs come back clean, "approve" gets +2 and then automatically the patch is submitted and merged. (jamoluhrsen, 16:43:28)
    2. this new workflow would allow CSIT to gate patches, which is something people have wanted in the past, but others have not (jamoluhrsen, 16:44:21)
    3. singlefeature test now has a 10m timeout for features to come up, which is needed for some projects (e.g. netvirt) with the smaller VMs after migration (went from 4 to 2 cores) (jamoluhrsen, 16:46:01)
    4. one idea is to figure out if we can give larger VMs to specific projects build jobs, and zxiiro is looking for ways. (jamoluhrsen, 16:47:31)
    5. should we give the multipatch test job more cores, since it's infrequently used, but when it is used we don't like to wait so long for it to complete. (jamoluhrsen, 16:48:50)
    6. ACTION: jamoluhrsen to figure out if we can just give a one off larger slave for the multipatch job (jamoluhrsen, 16:49:32)
    7. do we want to give build rights to project committers or not? with migration, some committers lost those rights. (jamoluhrsen, 16:51:04)
    8. LuisGomez thinks we should grant access to all committers, maybe on an "as requested" basis. (jamoluhrsen, 16:51:57)
    9. tykeal notes that we lost a lot of permissions in the migration and we need to just work through and add permissions back. (jamoluhrsen, 16:52:40)
    10. releng will be going back to get permissions back for build rights (jamoluhrsen, 16:55:00)
    11. TSDR noticed issues with unit test reports after migration, but not sure whats going on. they can still get reports in some fashion, and their tests *are* running (jamoluhrsen, 16:56:17)


Meeting ended at 16:58:21 UTC (full logs).

Action items

  1. vratko to send quick email for help, and hopefully someone can jump in to help
  2. zxiiro to send an email about using this new opendaylight-infra wrapper
  3. jamoluhrsen to figure out if we can just give a one off larger slave for the multipatch job


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to figure out if we can just give a one off larger slave for the multipatch job
  2. zxiiro
    1. zxiiro to send an email about using this new opendaylight-infra wrapper


People present (lines said)

  1. jamoluhrsen (50)
  2. zxiiro (9)
  3. odl_meetbot (3)
  4. tykeal (2)
  5. vorburger (2)
  6. dfarrell07 (1)
  7. odp-gerritbot (1)


Generated by MeetBot 0.1.4.