#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:11 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:04:09)
    1. maven central requirements work happened this past week. one question on how to do developers section? (jamoluhrsen, 16:04:59)
    2. distribution jobs were broken for over a week. distro size was too big. (jamoluhrsen, 16:05:38)
    3. reason too large, other projects pulling in duplicate dependencies. (jamoluhrsen, 16:06:04)
    4. distribution changes coming that should help with overall size (jamoluhrsen, 16:06:43)
    5. tykeal still emphatic that we will not increase the nexus upload cap at 512MB (jamoluhrsen, 16:07:57)
    6. jamoluhrsen points out that it seems we are always going to be building bigger and bigger distros, so even if well behaved, as we add more projects to ODL we will eventually hit this cap anyway. (jamoluhrsen, 16:09:14)
    7. tykeal notes we probably need a new paradigm, with minimal distro that pulls new features from external resources as needed. (jamoluhrsen, 16:09:52)
    8. we need to find out how much we can reduce the size for now, and then go from there. (jamoluhrsen, 16:14:52)

  2. packaging (jamoluhrsen, 16:15:36)
    1. opnfv sfc project was trying to use recent boron distro, but it was broken (jamoluhrsen, 16:16:02)

  3. builder (jamoluhrsen, 16:16:21)
    1. our log archive will keep artifacts for 6 months. (jamoluhrsen, 16:17:07)
    2. plan is to get all jobs to push their artifacts to the log server (jamoluhrsen, 16:17:28)
    3. hoping to get gerrit comments and emails to report links to log server (jamoluhrsen, 16:18:22)
    4. currently not worried about storage space for log server (jamoluhrsen, 16:19:10)
    5. we have plenty of disk space (jamoluhrsen, 16:19:28)
    6. LuisGomez points out that we do use artifacts from one job to pass to another job, so can those end up on log server? (jamoluhrsen, 16:20:31)
    7. plot data is not an artifact, so we don't need to worry about those. (jamoluhrsen, 16:20:46)
    8. so if we want to get everyone off of jenkins we do need to figure out a way to stop viewing plots on jenkins (jamoluhrsen, 16:22:19)
    9. no more python scripting wrapping around JJB as of this week. everything is pure JJB (jamoluhrsen, 16:23:23)
    10. now it should be easier to allow projects to pick build slaves specifically (jamoluhrsen, 16:24:07)
    11. down the road, all jobs might move to regular free style jobs, removing maven and matrix jobs. (jamoluhrsen, 16:24:40)
    12. it can potentially be hard to convert from maven/matrix to freestyle, but zxiiro thinking of ideas. (jamoluhrsen, 16:26:06)
    13. one benefit should be faster jobs compared to maven job types. (jamoluhrsen, 16:30:01)
    14. public cloud work still underway, but one problem remains. (jamoluhrsen, 16:30:58)
    15. when public cloud is available, we'll just need to use a different "label" in order to know which cloud the jobs will run. (jamoluhrsen, 16:31:41)
    16. new ETA for public cloud access is unknown. depends on RackSpace solution (jamoluhrsen, 16:32:30)
    17. some issues we still have are random networking issues (rejected connections) and nexus upload rejects. (jamoluhrsen, 16:34:19)
    18. no clue on networking issues, but some things in progress to help with nexus (e.g. moving ldap) (jamoluhrsen, 16:35:07)
    19. mgkwill asking about running containers directly in infra, but we can run docker instances inside the VMs we get from infra (jamoluhrsen, 16:37:35)
    20. jamoluhrsen knows how to use sshuttle to access docker instances in one vm from external system (jamoluhrsen, 16:39:06)
    21. we have a demo repo ready for testing new gerrit workflow, but it's been on hold. (jamoluhrsen, 16:41:44)
    22. releng folks thinking about building their own pipeline system... (jamoluhrsen, 16:49:04)

  4. release (jamoluhrsen, 16:49:22)
    1. ietf upgrade happened yesterday, but still one patch waiting (atrium), and two other issues to figure out. (jamoluhrsen, 16:50:07)
    2. is there a deadline for deciding traditional release plan or fast phased for Carbon. (jamoluhrsen, 16:50:59)
    3. best idea to get to fast phased is to start with one root project, but there feels like no real momentum so seems likely that Carbon will stick with traditional release plan (jamoluhrsen, 16:51:52)
    4. SR3 cutoff in 10 days, release hopefully in 2 weeks? (jamoluhrsen, 16:52:55)
    5. for Boron there are 3 projects not in distribution, but time is running out and they are at risk to miss the release. (jamoluhrsen, 16:54:18)
    6. zxiiro points out that if he removes tcpmd5 from boron, because they are not participating, it will break other project. there is a weather item for htat. (jamoluhrsen, 16:54:48)

  5. misc (jamoluhrsen, 16:56:04)
    1. mgkwill advertises performance report work kickoff meeting tomorrow morning and should meet every week on Fridays 8:30. (jamoluhrsen, 16:56:55)
    2. Meeting details for perf report plan kickoff "Cluster & S3P Test" Meet https://wiki.opendaylight.org/view/Meetings (mgkwill, 16:58:24)
    3. how do we want to trigger CSIT? probably easiest just to take all offset 2 projects and have them only trigger on offset 1. (jamoluhrsen, 16:58:37)
    4. ACTION: LuisGomez or zxiiro to send email about these trigger consolidations. (jamoluhrsen, 17:00:03)
    5. https://wiki.opendaylight.org/view/Meetings Meeting details for perf report plan kickoff "Cluster & S3P Test" Meet (jamoluhrsen, 17:00:56)


Meeting ended at 17:00:59 UTC (full logs).

Action items

  1. LuisGomez or zxiiro to send email about these trigger consolidations.


People present (lines said)

  1. jamoluhrsen (48)
  2. odl_meetbot (3)
  3. mgkwill (1)
  4. odp-gerritbot (1)


Generated by MeetBot 0.1.4.