#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:02:20 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:03:39)
    1. Boron distro failures in singlefeaturetest recently, but not good visibility on why the failures are happening (jamoluhrsen, 16:04:35)
    2. two features from distro from test-index (snmp4sdn and tsdr) have been removed now to make distribution build pass (jamoluhrsen, 16:07:28)
    3. new patch coming in odlparent that should help gain a little more visibility in to these failures. (jamoluhrsen, 16:09:43)
    4. opflex next yangide are not in distribution, but we don't expect them to be. (jamoluhrsen, 16:12:39)
    5. projects missing from distribution: atrium, didm, of-config, vbd, eman, uscplugin (anipbu, 16:13:29)
    6. if these projects are not in the distribution by RC time, then they are not in the common karaf distribution (jamoluhrsen, 16:15:04)
    7. Beryllium SR3 is coming, and autorelease is fine for Beryllium so no major concerns from Int/Dist on Beryllium (jamoluhrsen, 16:16:44)
    8. LuisGomez points out that we should all take a look at the karaf logs as we approach Boron RC to file bugs for exceptions and errors (jamoluhrsen, 16:18:16)

  2. packaging (jamoluhrsen, 16:18:38)
    1. rpm building automation is upstream. should let us build custom rpms using jenkins (jamoluhrsen, 16:19:17)
    2. next step is to get autorelease triggering this job so each autorel creates an rpm. w00t! (jamoluhrsen, 16:19:44)
    3. intern projects for tutorials are making progress. (jamoluhrsen, 16:20:46)
    4. trying for a demo on this integration call for these tutorials in two weeks time (8/3) (jamoluhrsen, 16:21:13)

  3. builder (jamoluhrsen, 16:22:23)
    1. new ldap server is up and mirrors old server and should fix a few infra issues (nexus timeout, auth errors) (jamoluhrsen, 16:23:01)
    2. the public cloud is now working and we can start moving jobs back there. (jamoluhrsen, 16:23:48)
    3. https://git.opendaylight.org/gerrit/#/c/42186/ (zxiiro, 16:24:29)
    4. the first proposal is that our robot VMs will be in our private cloud, but all the other VMs (ODL, mininet, etc) will exist in the public cloud. (jamoluhrsen, 16:24:54)
    5. the networking between both clouds should be wide-open, so we do not expect any networking issues between the two clouds. (jamoluhrsen, 16:25:32)
    6. LuisGomez asks about network performance. downloading ODL in public cloud used to take a long time sometimes so that might be an issue. (jamoluhrsen, 16:26:04)
    7. https://git.opendaylight.org/gerrit/#/c/42186 <---- example of how to run things in the public cloud (jamoluhrsen, 16:31:01)
    8. there are new node labels will not apply to the new public cloud because we can't fully control the size of those VMs. (jamoluhrsen, 16:34:36)
    9. first step is to start running our other VMs in the public cloud. once that is working we can worry about adding new node labels to more accurate to what is running in the public cloud. (jamoluhrsen, 16:36:06)
    10. https://git.opendaylight.org/gerrit/#/q/project:releng/builder+topic:remove-matrix remove-matrix verify jobs (zxiiro, 16:37:34)
    11. matrix verfiy jobs are being deprecated for freestyle jobs (jamoluhrsen, 16:37:38)
    12. the job type runs a little faster (aprox 4m) (jamoluhrsen, 16:38:18)
    13. currently we can't do vagrant builds in public cloud, but packer seems to work, so all the vagrant profiles are now all packer. (jamoluhrsen, 16:39:13)
    14. another benefit is that our packer build will now build in both clouds at the same time. (jamoluhrsen, 16:39:38)
    15. we'll get a job that can hopefully verify and build the packer builds on merges (jamoluhrsen, 16:40:36)
    16. at some point we want to move all jobs to start installing their specific python dependencies so that we don't have to install ALL for every job; but this probably wont happen until after Boron. (jamoluhrsen, 16:42:01)
    17. https://git.opendaylight.org/gerrit/42175 build matplotlib with packer (zxiiro, 16:42:06)

  4. release (jamoluhrsen, 16:44:05)
    1. branch cutting/version bumping happening at M5 (jamoluhrsen, 16:44:40)
    2. Beryllium SR3 release candidate coming next week, so CSIT jobs will have to be monitored and understood. (jamoluhrsen, 16:45:42)
    3. it's hard to figure out the distribution-test job per autorelease job. (jamoluhrsen, 16:46:11)

  5. misc (jamoluhrsen, 16:49:00)
    1. new build failure management plugin available in jenkins (sandbox now). not sure how useful it is yet (jamoluhrsen, 16:50:17)
    2. new plugin requires user input. (jamoluhrsen, 16:50:48)
    3. when do we want to move our CSIT verify to using boron, as it's currently using beryllium? (jamoluhrsen, 16:52:16)
    4. we need to wait until when we think Boron is stable before we move. (jamoluhrsen, 16:52:39)
    5. should the distribution be able to run when not connected to the internet? answer is yes, but currently that is not the case (jamoluhrsen, 16:54:02)
    6. ACTION: jamoluhrsen to file a bug for offline distro not working (jamoluhrsen, 16:55:04)
    7. ACTION: LuisGomez to send email about offline distro not working? (jamoluhrsen, 16:55:18)
    8. jvm monitoring demo in two weeks time as well. (jamoluhrsen, 16:57:02)


Meeting ended at 16:57:27 UTC (full logs).

Action items

  1. jamoluhrsen to file a bug for offline distro not working
  2. LuisGomez to send email about offline distro not working?


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to file a bug for offline distro not working
  2. LuisGomez
    1. LuisGomez to send email about offline distro not working?


People present (lines said)

  1. jamoluhrsen (43)
  2. odl_meetbot (4)
  3. zxiiro (3)
  4. dfarrell07 (3)
  5. odp-gerritbot (2)
  6. anipbu (1)
  7. LuisGomez (0)


Generated by MeetBot 0.1.4.