#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:03:19 UTC (full logs).

Meeting summary

    1. https://git.opendaylight.org/gerrit/#/c/41183/ Gerrit with L2 Switch tutorial docs, dfarrell07 requests feedback from everyone (dfarrell07, 16:11:59)
    2. https://git.opendaylight.org/gerrit/#/c/41110/ Vagrantfile with L2Switch tutorial, LuisGomez to review for use in ODL Summit (dfarrell07, 16:12:28)
    3. dfarrell07 and LuisGomez talk about combining efforts to build ODL Summit tutorial envs with intern tutorial work (dfarrell07, 16:12:52)
    4. ACTION: LuisGomez, phrobb and dfarrell07 to talk about Summit tutorials and how to get more value with modern tools/tutorials effort (dfarrell07, 16:13:32)
    5. tykeal and zxiiro are still having to restart Jenkins a lot, but things are moving fairly quickly otherwise (dfarrell07, 16:14:59)
    6. tykeal talks about timeout issue Jenkins/Nexus, is about to move to new LDAP server which ~"should" fix this (dfarrell07, 16:15:37)
    7. anipbu reports that there are still 8 projects not in distro, has sent emails and CC'd LuisGomez and Vratko (dfarrell07, 16:17:48)
    8. anipbu notes that TSC can start dropping projects at RC0, and maybe should (dfarrell07, 16:18:10)
    9. all projects are in autorel, but it's breaking (and has been for a loooongg time) (dfarrell07, 16:18:26)
    10. SDNI issue has been resolved, can likely add back to distro (dfarrell07, 16:18:42)
    11. discussion about us patching to add SDNI to distro or them sending patch, without setting precedent we'll do it this time, expect projects to do it themselves in the future (dfarrell07, 16:20:23)
    12. Some bugs still failing in Be SR3 (dfarrell07, 16:20:48)
    13. Discussion about impact of bugs in SR3, if we can release with them, what is downstream of NIC and SXP (dfarrell07, 16:23:04)
    14. LuisGomez thinks non-responsive projects shouldn't block a release (dfarrell07, 16:23:26)
    15. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1820514274 (anipbu, 16:23:39)
    16. https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1820514274 SR3 tracking spreadsheet with bug info (dfarrell07, 16:24:03)
    17. Discussion about needing support network for projects, like collaboration groups for core/plugins/support/apps/mature/core, to help projects along with rel process (dfarrell07, 16:29:42)
    18. Discussion about how TSC refactoring goes perfectly with this idea of support between projects, can use RGs, have weekly/monthly meetings for RGs (dfarrell07, 16:30:35)
    19. Clustering work is making progress, LuisGomez also has new clustering lib in places and tests moved over to it, will do TWS on it when ready (dfarrell07, 16:31:03)
    20. LuisGomez reports that work for clustering for Boron for Int/Test is mostly done, projects now need to take this lib we've build and use in system tests (dfarrell07, 16:31:33)
    21. Now starting on perf work via S3P group, to do Boron whitepaper by Summit (dfarrell07, 16:31:51)
    22. S3P group needs to build all test automation between now and release, then do all tests and write paper between release and summit (3 weeks) (dfarrell07, 16:32:35)
    23. LuisGomez asks Vratko about OF and other plugin testing, please share on list (dfarrell07, 16:33:01)
    24. mgkwill is driving ODL S3P efforts (dfarrell07, 16:33:12)
    25. dfarrell07 talks about how Apex is hitting no-internet karaf bug, fairly big deal, Vratko is working it and will ++ prio (dfarrell07, 16:37:05)
    26. dfarrell07 talks about no existing Boron autorel builds for OPNFV to test, very few successful builds, the three that worked (175-177) didn't publish artifacts to Nexus so still not aval for testing (dfarrell07, 16:37:53)
    27. dfarrell07 knows people are working on getting autorel building, just wanted to add info that OPNFV is looking/needing (dfarrell07, 16:38:16)
    28. https://paste.fedoraproject.org/396889/69717053/ Apex log for non-internet karaf bug (dfarrell07, 16:40:00)
    29. https://lists.opendaylight.org/pipermail/integration-dev/2016-July/007548.html HEAD of email thread about no-internet karaf bug (dfarrell07, 16:40:16)
    30. https://bugs.opendaylight.org/show_bug.cgi?id=6187 No-internet karaf bug (dfarrell07, 16:40:27)
    31. LuisGomez reports that JVM monitoring framework is ready, both for single node and cluster (dfarrell07, 16:42:00)
    32. LuisGomez needs to talk to intern about impact of any perf impact of framework, likely nbd (dfarrell07, 16:43:02)
    33. People should start playing around and using this JVM framework (dfarrell07, 16:43:23)
    34. There is a wiki about JVM stuff, LuisGomez will send out link in email (or dfarrell07 will find before) (dfarrell07, 16:43:49)
    35. LuisGomez gives a demo of JVM framework output, seems cool, dfarrell07 can't see because booo WebEx (dfarrell07, 16:44:39)
    36. this JVM mon stuff will be great for perf tests (dfarrell07, 16:45:06)
    37. Vratko reports that suite to test maven plugin is ready for merge, sandbox needs a patched version of plugin so can't <do something dfarrell07 didn't follow> (dfarrell07, 16:46:53)
    38. Vratko also has some updates to make SSH keywords lib better involving smarter working dirs (dfarrell07, 16:47:16)
    39. Also some changes going in to robot libs about working in py venvs (dfarrell07, 16:47:40)
    40. Will be able to use this lib to install whatever you want with pip in venv (dfarrell07, 16:48:10)
    41. LuisGomez talks about docing libs people should use, standardize which libs to use, consolidate (dfarrell07, 16:49:27)
    42. ACTION: Vratko and LuisGomez to sort out which libs are modern and should be used, doc in appropate place (textfile in repo? readthedocs?), maybe move tests to use only new libs (dfarrell07, 16:51:52)
    43. ACTION: dfarrell07 to stub out readthedocs page with modern, old and unsorted libs, with links from libs to auto-gen'd docs, others to update into right sections via patches (dfarrell07, 16:56:54)
    44. Venkat talks about some jobs failing, may be infra, will send details to mail (dfarrell07, 16:58:36)
    45. dfarrell07 asks for help from LuisGomez et al about L2Switch issue with hosts not being found sometimes (dfarrell07, 17:00:42)
    46. https://lists.opendaylight.org/pipermail/integration-dev/2016-July/007597.html link to email from intern with bug discussion^^ (dfarrell07, 17:00:55)
    47. ACTION: LuisGomez to help those interns^^ (dfarrell07, 17:01:04)


Meeting ended at 17:01:07 UTC (full logs).

Action items

  1. LuisGomez, phrobb and dfarrell07 to talk about Summit tutorials and how to get more value with modern tools/tutorials effort
  2. Vratko and LuisGomez to sort out which libs are modern and should be used, doc in appropate place (textfile in repo? readthedocs?), maybe move tests to use only new libs
  3. dfarrell07 to stub out readthedocs page with modern, old and unsorted libs, with links from libs to auto-gen'd docs, others to update into right sections via patches
  4. LuisGomez to help those interns^^


Action items, by person

  1. dfarrell07
    1. LuisGomez, phrobb and dfarrell07 to talk about Summit tutorials and how to get more value with modern tools/tutorials effort
    2. dfarrell07 to stub out readthedocs page with modern, old and unsorted libs, with links from libs to auto-gen'd docs, others to update into right sections via patches
  2. UNASSIGNED
    1. Vratko and LuisGomez to sort out which libs are modern and should be used, doc in appropate place (textfile in repo? readthedocs?), maybe move tests to use only new libs
    2. LuisGomez to help those interns^^


People present (lines said)

  1. dfarrell07 (50)
  2. odl_meetbot (4)
  3. anipbu (1)


Generated by MeetBot 0.1.4.