#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:02:48 UTC (full logs).

Meeting summary

  1. packagin (jamoluhrsen, 16:04:30)
  2. packaging (jamoluhrsen, 16:04:36)
    1. now building fedora packages (thanks to plaurin) (jamoluhrsen, 16:05:09)
    2. l2switch tutorial is now done, but sporadic behavior noticed (jamoluhrsen, 16:05:53)
    3. clustering tutorial coming next. (jamoluhrsen, 16:06:43)
    4. was a mention of tutorial using python cluster deployer, but suggestion is that we use the new cluster deployer scripts shipped in the distribution (jamoluhrsen, 16:08:13)
    5. new patch coming for cluster config scripts to make it slightly easier (don't need to give controller index) (jamoluhrsen, 16:09:50)
    6. https://opendaylight.readthedocs.io/en/latest/getting-started-guide/common-features/clustering.html?highlight=clustering <--- clustering config docs (jamoluhrsen, 16:10:26)
    7. the list of tutorials is now listed for the summit and hopefully we can leverage some of these l2switch/clustering/etc tutorials for the summit (jamoluhrsen, 16:13:16)

  3. distribution (jamoluhrsen, 16:17:25)
    1. saw temp issue with karaf not starting. fixed now. (jamoluhrsen, 16:17:57)
    2. distribution is WAY TOO BIG and now it will not upload to nexus, which breaks everything in CI (jamoluhrsen, 16:18:25)
    3. no system tests are running (jamoluhrsen, 16:18:41)
    4. autorelease can not produce anything for us. (jamoluhrsen, 16:19:19)
    5. LuisGomez thinks we cannot go much longer with this problem or we have to delay release or we have to change upload size limit on nexus (jamoluhrsen, 16:19:58)
    6. one solution is to revert patch to allow us to start offline, which brought in apache cxf (jamoluhrsen, 16:20:30)
    7. skitt notes that some of the biggest jars are coming from atrium (jamoluhrsen, 16:20:50)
    8. tykeal does not want to change upload limit, but if TSC chooses so we will change it. (jamoluhrsen, 16:21:42)
    9. atrium is just an example among many (skitt, 16:23:15)
    10. the distribution increased in size by nearly 80M just recently. (jamoluhrsen, 16:23:43)
    11. we need a blocking bug for this distribution size issue. (jamoluhrsen, 16:24:33)
    12. ACTION: skitt to file the dist size blocking bug (jamoluhrsen, 16:24:41)
    13. the bug is https://bugs.opendaylight.org/show_bug.cgi?id=6341 (skitt, 16:26:19)
    14. https://bugs.opendaylight.org/show_bug.cgi?id=6341 (skitt, 16:26:41)
    15. ACTION: LuisGomez, vratko to revert this patch https://git.opendaylight.org/gerrit/#/c/42842 (jamoluhrsen, 16:27:18)
    16. LuisGomez suggests that we add some tests to check for distribution growth (jamoluhrsen, 16:27:45)
    17. https://git.opendaylight.org/gerrit/43136 <--revert of 42842 (jamoluhrsen, 16:28:36)
    18. we should change distribution to use odl-parent, then revert patch. (jamoluhrsen, 16:31:49)
    19. ACTION: jamoluhrsen to reopen the offline distro bug and make it a blocker (jamoluhrsen, 16:32:35)
    20. basic growth test can be to check if distro size is > 500M to at least give us a warning that we are close to the nexus limit (jamoluhrsen, 16:33:17)
    21. it should now be safe to remove tcpmd5 from autorelease.... (jamoluhrsen, 16:35:06)
    22. zxiiro notes it's already been removed since july 22nd (jamoluhrsen, 16:35:27)
    23. beryllium SR3 distro ready to ship (jamoluhrsen, 16:35:44)

  4. infra/builder (jamoluhrsen, 16:36:02)
    1. public cloud now seems to be working again now. close to 24hour outage (jamoluhrsen, 16:36:32)
    2. not sure how things happened, but rackspace was doing maintenance and maybe that was part of the reason (jamoluhrsen, 16:37:16)
    3. similar problems have happened in the past (jamoluhrsen, 16:38:14)
    4. the nexus timeout issue is still happening, even after LDAP mirror is in place. Feels like it's happening less often though. (jamoluhrsen, 16:39:41)
    5. jamoluhrsen points out that we are still seeing the ssh EOFError issues. (jamoluhrsen, 16:42:04)
    6. ssh EOFError started happening when we migrated to private cloud. are still happening now that we have moved test VMs to public with robot VM still in private (jamoluhrsen, 16:46:15)
    7. no major infra changes coming now, so hopefully we can stabilize going forward (jamoluhrsen, 16:47:34)

  5. misc (jamoluhrsen, 16:47:43)
    1. robot library organization was brought up last week.... we need better docs for these, and we better structure to be able to help new people coming to CSIT (jamoluhrsen, 16:48:59)
    2. also other projects are starting to use our robot tests. (jamoluhrsen, 16:49:30)
    3. overall questions around what Integration/* can/should do about helping fast and/or phased release strategy. (jamoluhrsen, 16:50:53)
    4. things like more automation around packaging, a working autorelease... (jamoluhrsen, 16:51:31)
    5. dfarrell07 points out that ODL dev design forum is there in Sep to help plan some kind of pilot for fast/phased. (jamoluhrsen, 16:54:31)
    6. vratko notes that now is the deadline for us to decide if we are creating a stable distro, and it's pretty clear that we are NOT creating this. (jamoluhrsen, 16:55:14)
    7. odlparent needs to get the ball rolling in order for us to get any kind of stable release... first odlparent needs to become mature. skitt is driving this. (jamoluhrsen, 16:56:11)
    8. jamoluhrsen and LuisGomez on PTO next thurs. might cancel the meeting or dfarrell07 can run. will decide later (jamoluhrsen, 16:57:10)


Meeting ended at 16:57:16 UTC (full logs).

Action items

  1. skitt to file the dist size blocking bug
  2. LuisGomez, vratko to revert this patch https://git.opendaylight.org/gerrit/#/c/42842
  3. jamoluhrsen to reopen the offline distro bug and make it a blocker


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to reopen the offline distro bug and make it a blocker
  2. LuisGomez
    1. LuisGomez, vratko to revert this patch https://git.opendaylight.org/gerrit/#/c/42842
  3. skitt
    1. skitt to file the dist size blocking bug


People present (lines said)

  1. jamoluhrsen (49)
  2. skitt (5)
  3. odl_meetbot (4)
  4. zxiiro (3)
  5. dfarrell07 (3)
  6. odp-gerritbot (2)
  7. tykeal (1)
  8. LuisGomez (1)
  9. anipbu (0)


Generated by MeetBot 0.1.4.