#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:03:08 UTC (full logs).

Meeting summary

    1. low attendance. (jamoluhrsen, 16:08:58)
    2. vrpolak also looking for a way to give data to a dashboard graph. (jamoluhrsen, 16:10:02)
    3. in the process of disabling Lithium CSIT jobs (jamoluhrsen, 16:11:10)
    4. correction, not just CSIT, but everything with Lithium in the name, and no plan to re-enabled (jamoluhrsen, 16:11:43)

  1. release (jamoluhrsen, 16:12:11)
    1. Boron RC0 released yesterday. RC1 coming today. (jamoluhrsen, 16:12:33)
    2. Boron release review starting next friday (jamoluhrsen, 16:12:48)
    3. ACTION: jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again (colindixon, 16:12:52)
    4. 9 projects with mods to yang files last week and that should not be happening. these changes need to have an API waiver and/or bug to do this. (jamoluhrsen, 16:14:30)
    5. possibly TSC approved these to be ok. (jamoluhrsen, 16:14:46)
    6. RC0 distribution-test saw a bunch of red dots; assumption is infra problems. RC1 coming so soon, we probably don't need to debug those. (jamoluhrsen, 16:16:11)

  2. distribution (jamoluhrsen, 16:16:46)
    1. distro size is now under 500M. (jamoluhrsen, 16:17:20)
    2. ACTION: jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again (jamoluhrsen, 16:17:31)
    3. offline test is failing now because of a karaf bug where bin/client is not working. (jamoluhrsen, 16:18:32)
    4. ACTION: vrpolak to check if we are using newer karaf (3.0.7) and report back (jamoluhrsen, 16:19:10)
    5. nobody really caring/focused on carbon distro (jamoluhrsen, 16:20:16)
    6. karaf 3.0.7 patch is still under review: https://git.opendaylight.org/gerrit/#/c/43527/ (LuisGomez, 16:20:21)
    7. https://git.opendaylight.org/gerrit/#/c/43527/ <- karaf 3.0.7 patch is still under review: (jamoluhrsen, 16:20:47)

  3. builder (jamoluhrsen, 16:21:27)
    1. no update on the RackSpace ssh problem yet. (jamoluhrsen, 16:21:59)
    2. ssh problem only happening with public cloud. (jamoluhrsen, 16:22:11)
    3. aprox 1 in 6 nodes is having this issue. (jamoluhrsen, 16:22:49)
    4. the infra issues we have seen during this release cycle are not sustainable. we need a long term solution if they can't be resolved. (jamoluhrsen, 16:25:07)
    5. LuisGomez and jamoluhrsen would like to note that our value we have given to the opendaylight product was very minimal this release (jamoluhrsen, 16:26:29)

  4. packaging (jamoluhrsen, 16:29:49)
    1. no update, daniel on pto (jamoluhrsen, 16:29:59)
    2. no update on tutorial side of things. (jamoluhrsen, 16:31:16)
    3. l2switch tutorial is done. clustering in progress but probably not done before internship is over at the end of the month (jamoluhrsen, 16:32:38)

  5. misc (jamoluhrsen, 16:32:47)
    1. response code changes in CSIT happened, and 4+ patches have been merged to account for this. probably more should be coming when projects finally analyze their results (jamoluhrsen, 16:34:27)
    2. vrpolak has added more options to dsbenchmark suite, and now it's breaking the plot plugin in jenkins (jamoluhrsen, 16:35:22)
    3. perf dashboard work is good place to solve this, so we can post perf numbers to database with robot then the dashboard can pull from database. (jamoluhrsen, 16:38:16)
    4. ACTION: jamoluhrsen to add link from wiki to our robot lib readthedocs location (jamoluhrsen, 16:40:37)
    5. http://docs.opendaylight.org/en/latest/_static/integration/robot/index.html <--robot lib docs (jamoluhrsen, 16:41:13)
    6. we need a stub page to start helping point people to the right libraries to use for system test (jamoluhrsen, 16:42:18)
    7. ACTION: jamoluhrsen to find out more on this from old integration meeting notes and follow up (jamoluhrsen, 16:42:43)
    8. ACTION: vrpolak Int/Dist still needs some minor comment in developer guide about the version feature (jamoluhrsen, 16:44:52)
    9. discussion about rejected SSH when connecting to karaf. (jamoluhrsen, 16:52:22)
    10. apparently when netconf-connector finally comes around we think ssh might break for a brief period and then come back. maybe we are hitting htis. (jamoluhrsen, 16:56:06)


Meeting ended at 16:57:53 UTC (full logs).

Action items

  1. jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again
  2. jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again
  3. vrpolak to check if we are using newer karaf (3.0.7) and report back
  4. jamoluhrsen to add link from wiki to our robot lib readthedocs location
  5. jamoluhrsen to find out more on this from old integration meeting notes and follow up
  6. vrpolak Int/Dist still needs some minor comment in developer guide about the version feature


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again
    2. jamoluhrsen should add to the bug that we need to have the nexus file size limit set to 512 MB again
    3. jamoluhrsen to add link from wiki to our robot lib readthedocs location
    4. jamoluhrsen to find out more on this from old integration meeting notes and follow up
  2. vrpolak
    1. vrpolak to check if we are using newer karaf (3.0.7) and report back
    2. vrpolak Int/Dist still needs some minor comment in developer guide about the version feature


People present (lines said)

  1. jamoluhrsen (47)
  2. colindixon (7)
  3. odl_meetbot (5)
  4. vrpolak (2)
  5. skitt (2)
  6. LuisGomez (1)
  7. zxiiro (1)


Generated by MeetBot 0.1.4.