#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:01:23 UTC (full logs).

Meeting summary

    1. dfarrell07 requires anyone starting these irc meeting notes to ONLY call it "integration" (jamoluhrsen, 16:03:29)
    2. ACTION: jamoluhrsen to put a link to robot libs in readthedocs on wiki (jamoluhrsen, 16:04:03)
    3. ACTION: jamoluhrsen figure out what/where we are going to do about robot lib organization (jamoluhrsen, 16:04:34)
    4. vratko verified that boron snapshot is using karaf version 3.0.7, but latest autorel build is using 3.0.6. it's possible that new version is available but autorel is having trouble recently. (jamoluhrsen, 16:05:41)
    5. current autorelease not triggering distro test jobs. workaround is that we have to manually kick-off jobs. (jamoluhrsen, 16:07:08)
    6. ACTION: jamoluhrsen to send email to [releng] about this looking for a fix. (jamoluhrsen, 16:07:21)
    7. ACTION: vrpolak to add some minor comment about version feature in dev guide (jamoluhrsen, 16:07:53)

  1. distribution (jamoluhrsen, 16:08:04)
    1. question if we can close the distro size too big bug? (jamoluhrsen, 16:09:21)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=6341 (vrpolak, 16:10:53)
    3. http://cbs.centos.org/repos/nfv7-opendaylight-43-release/x86_64/os/Packages/ ODL Be SR3 RPM is 269MB (dfarrell07, 16:11:24)
    4. ACTION: tykeal to put nexus file size limit back to where it was before bug 6341 was filed (jamoluhrsen, 16:11:24)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=6341 <-- distro size too big bug (jamoluhrsen, 16:11:42)
    6. LuisGomez points out that Beryllium was in the 300M range, but Boron is well over 400M (jamoluhrsen, 16:12:02)
    7. ACTION: LuisGomez to give us a trello card for us to add some test around checking size limit (jamoluhrsen, 16:13:37)

  2. release (jamoluhrsen, 16:14:26)
    1. release reviews starting tomorrow (jamoluhrsen, 16:14:45)
    2. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 <-- release review schedule (jamoluhrsen, 16:16:07)
    3. projects CSIT needs to be analyzed to see if they meet expectations. (jamoluhrsen, 16:16:35)
    4. Boron RC2 coming today, meaning one more week until RC3 which is normally what we want to present to TSC (jamoluhrsen, 16:17:35)
    5. RC1 did have some CSIT with failures which have (may have) bugs filed (jamoluhrsen, 16:17:53)
    6. anipbu points out that we are still seeing new features coming in to Boron although we are in RC timeframes (jamoluhrsen, 16:18:38)
    7. TSC seemed open to allowing this kind of development, so it is what it is. (jamoluhrsen, 16:19:39)

  3. builder (jamoluhrsen, 16:20:12)
    1. still having nexus timeout issues and no idea why it's happening. (jamoluhrsen, 16:20:37)
    2. still have open tickets (without RackSpace response) for issues in the public cloud. (jamoluhrsen, 16:21:00)
    3. jamoluhrsen noticed that he didn't hit any of the typical public cloud issues while using the sandbox extensively yesterday (8/24) (jamoluhrsen, 16:21:56)
    4. tykeal has a new idea to get rid of jclouds with something like heat/cloud-orchestration from the robot VM (jamoluhrsen, 16:23:17)
    5. standing issues might just be the nexus timeout and maybe public cloud VM connectivity (jamoluhrsen, 16:24:47)

  4. packaging (jamoluhrsen, 16:26:15)
    1. internships are ending, so final outcomes were 1 L2Switch tutorial, and a gerrit that needs work to get .deb packaging working (jamoluhrsen, 16:27:09)
    2. dfarrell07 looking in to hosting rpms on nexus, which could help downstream partners like apex from opnfv. looking for help to get that done. (jamoluhrsen, 16:27:57)
    3. finding autorelease builds is hard. we need an easier way (jamoluhrsen, 16:28:20)
    4. tutorial involving netvirt in the works (jamoluhrsen, 16:30:18)

  5. misc (jamoluhrsen, 16:30:38)
    1. jamoluhrsen points out that distribution-check is no longer giving us the distro .zip could this be happening be coming from the migration to freestyle job? (jamoluhrsen, 16:32:04)
    2. we need to add the distribution to the right place for the new archive tool. (jamoluhrsen, 16:32:36)
    3. ACTION: LuisGomez to check if we are storing the artifacts in jenkins the right way, so that depended jobs can use it. (jamoluhrsen, 16:34:26)
    4. is it ok to disable the Lithium csit jobs now? the patch vrpolak gave did not work. (jamoluhrsen, 16:36:41)
    5. LuisGomez asks can we just delete the Lithium jobs? (jamoluhrsen, 16:37:45)
    6. let's just wait until Boron to release and then we'll delete (just a few more weeks). (jamoluhrsen, 16:38:05)
    7. question if we can change csit verify jobs to use Boron now? vrpolak says yes (jamoluhrsen, 16:38:32)
    8. ACTION: LuisGomez to change verify jobs to use Boron (jamoluhrsen, 16:38:43)
    9. do we have or not a VM with ovs 2.3 or higher? We have a vm with a label that says 2.3 but we get emails that say it's only 2.0 (jamoluhrsen, 16:40:14)
    10. tykeal says what we have in packer is what we will get. and the comment in packer is that it's installing ovs 2.3.1 (jamoluhrsen, 16:41:50)
    11. LuisGomez suggests that we just move to ovs 2.5 (jamoluhrsen, 16:43:08)
    12. LuisGomez notes that there is not much difference with performance jobs in public cloud the state of persistence (on or off) does not seem to matter. (jamoluhrsen, 16:46:39)


Meeting ended at 17:02:46 UTC (full logs).

Action items

  1. jamoluhrsen to put a link to robot libs in readthedocs on wiki
  2. jamoluhrsen figure out what/where we are going to do about robot lib organization
  3. jamoluhrsen to send email to [releng] about this looking for a fix.
  4. vrpolak to add some minor comment about version feature in dev guide
  5. tykeal to put nexus file size limit back to where it was before bug 6341 was filed
  6. LuisGomez to give us a trello card for us to add some test around checking size limit
  7. LuisGomez to check if we are storing the artifacts in jenkins the right way, so that depended jobs can use it.
  8. LuisGomez to change verify jobs to use Boron


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to put a link to robot libs in readthedocs on wiki
    2. jamoluhrsen figure out what/where we are going to do about robot lib organization
    3. jamoluhrsen to send email to [releng] about this looking for a fix.
  2. tykeal
    1. tykeal to put nexus file size limit back to where it was before bug 6341 was filed
  3. vrpolak
    1. vrpolak to add some minor comment about version feature in dev guide
  4. UNASSIGNED
    1. LuisGomez to give us a trello card for us to add some test around checking size limit
    2. LuisGomez to check if we are storing the artifacts in jenkins the right way, so that depended jobs can use it.
    3. LuisGomez to change verify jobs to use Boron


People present (lines said)

  1. jamoluhrsen (46)
  2. dfarrell07 (4)
  3. odl_meetbot (4)
  4. vrpolak (2)
  5. tykeal (1)
  6. plaurin (1)
  7. anipbu (0)


Generated by MeetBot 0.1.4.