#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:57 UTC (full logs).

Meeting summary

    1. new cluster/entity changes require changes in test code (jamoluhrsen, 16:04:46)
    2. question around how we want to address this in test code. (jamoluhrsen, 16:06:06)
    3. since it's affecting all projects using clustering, so probably best to put in Cluster Management library (jamoluhrsen, 16:07:04)
    4. vratko has an idea where the tests can work for both boron (with this new change) as well as Beryllium which will not have this change. (jamoluhrsen, 16:09:03)
    5. ACTION: vrpolak to look at Priya's patch to see if that's the approach we want to use. (jamoluhrsen, 16:10:40)
    6. https://git.opendaylight.org/gerrit/#/c/45363/ <--- Priya's patch (jamoluhrsen, 16:11:03)
    7. this change only impacts tests that check entity owner (jamoluhrsen, 16:12:21)
    8. will take aprox 2 days to get cluster tests changed and jobs rerun and analyzed (jamoluhrsen, 16:14:01)

  1. release (jamoluhrsen, 16:15:09)
    1. Boron will be delayed still. still two issues pending. (jamoluhrsen, 16:15:37)
    2. DLUX has 20 patches they want to merge, but push back from community. some blocker bugs they want to fix for their new feature "yangman" (jamoluhrsen, 16:16:11)
    3. release missed these because blockers were not made known until very late (jamoluhrsen, 16:16:28)
    4. blocker bug in OFP (6638). one line patch ready to merge (jamoluhrsen, 16:16:45)
    5. vbd had blockers but they were fixed and verified. (jamoluhrsen, 16:17:29)
    6. hopefully a respin will happen shortly after TSC call. (jamoluhrsen, 16:18:44)
    7. any new blockers coming after today, we recommend projects talk to TSC (jamoluhrsen, 16:19:17)
    8. means the build will be ready tomorrow (Friday), and then projects vote GO/NO-GO which takes a couple days. (jamoluhrsen, 16:19:48)
    9. conclusion is that we hope to release would happen closer to the 13th (jamoluhrsen, 16:20:40)
    10. ODL marketing release is targeted at 21st to sync with OPNFV and to give us breathing room (dfarrell07, 16:22:08)
    11. phrobb points out that this group should really weigh in to the TSC about the DLUX blocker bug 20 patch issue (jamoluhrsen, 16:24:17)
    12. dfarrell07 notes that the safest plan is to put DLUX patches in to SR1 (jamoluhrsen, 16:25:27)
    13. anipbu points out that this new feature "yangman" is already there in Boron, and that these 20 patches are just bug fixes to this new feature. (jamoluhrsen, 16:26:24)
    14. the UI version of anipbu thinks the patches are ok. (jamoluhrsen, 16:27:32)
    15. the release manager version of anipbu is very anxious about this. (jamoluhrsen, 16:27:46)
    16. there are zero tests in place for these dlux features. nothing upstream. these features are not even loaded in distribution test, so we have nothing. (jamoluhrsen, 16:29:31)
    17. Since we don't have UT/ST for GUI, we'd need to do manual retesting, and there's more risk (dfarrell07, 16:30:59)
    18. The applications that build on DLUX would be the people who would need to retest, not so easy to do (dfarrell07, 16:32:22)

  2. distribution (jamoluhrsen, 16:34:39)
    1. some Carbon issues recently. single feature test was taking really long, had OOM issues and then still passed. (jamoluhrsen, 16:35:36)
    2. distro size for RCs is ~400M which is much lower than the 550+ (jamoluhrsen, 16:37:07)
    3. vrpolak points out that Beryllium distro jobs are failing because TSDR merges are failing. (jamoluhrsen, 16:37:52)
    4. ACTION: jamoluhrsen, LuisGomez, or vrpolak to email TSDR about there Be merge job failure (jamoluhrsen, 16:38:12)
    5. LuisGomez asks if it's ok that we are building things by pulling artifacts from external repos? (jamoluhrsen, 16:40:03)
    6. ACTION: LuisGomez to send an email about these failures when pulling from external repos. may be a sporadic problem. (jamoluhrsen, 16:42:23)
    7. we do have CSIT to check version feature for Boron RC. (jamoluhrsen, 16:43:40)
    8. we do have CSIT jobs that use the cluster config script (jamoluhrsen, 16:45:22)
    9. we do have jobs that *use* the "set persistence" script from the distribution (jamoluhrsen, 16:45:40)

  3. packaging (jamoluhrsen, 16:46:00)
    1. lots of rpms for opnfv and now that work is done with jenkins jobs (jamoluhrsen, 16:46:38)

  4. builder (jamoluhrsen, 16:47:41)
    1. still investigating the nexus timeout issues. speed issues are there too. (jamoluhrsen, 16:48:28)
    2. tykeal notices that he can bypass some of the network and not see the speed issues. (jamoluhrsen, 16:49:47)
    3. we still have the ssh key copy timeout. not sure if it's related. (jamoluhrsen, 16:51:45)
    4. all other infra issues seemed to have been hunted down and resolved. (jamoluhrsen, 16:53:22)
    5. releng/builder committers have a vote to promote Anil to committer (jamoluhrsen, 16:54:20)

  5. misc (jamoluhrsen, 16:54:32)
    1. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum <--- topics for DDF at ODL Summit. Sign yourself up. (jamoluhrsen, 16:55:19)
    2. we did have log file size issues with ODL VMs setting 100G log file size on VMs with smaller disks (jamoluhrsen, 16:56:54)
    3. we need to fix cluster jobs though because they first copy the logs to robot VM then archive them. need a patch for that. (jamoluhrsen, 16:57:14)


Meeting ended at 16:57:43 UTC (full logs).

Action items

  1. vrpolak to look at Priya's patch to see if that's the approach we want to use.
  2. jamoluhrsen, LuisGomez, or vrpolak to email TSDR about there Be merge job failure
  3. LuisGomez to send an email about these failures when pulling from external repos. may be a sporadic problem.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen, LuisGomez, or vrpolak to email TSDR about there Be merge job failure
  2. LuisGomez
    1. jamoluhrsen, LuisGomez, or vrpolak to email TSDR about there Be merge job failure
    2. LuisGomez to send an email about these failures when pulling from external repos. may be a sporadic problem.


People present (lines said)

  1. jamoluhrsen (51)
  2. dfarrell07 (11)
  3. odl_meetbot (4)
  4. LuisGomez (2)
  5. plaurin (2)


Generated by MeetBot 0.1.4.