#opendaylight-integration: integration

Meeting started by dfarrell07 at 16:02:51 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:05:36)
    1. there was a distro check issue earlier in the week because of the maven to freestyle job type (jamoluhrsen, 16:06:50)
    2. all distro checks were failing because of this job migration, so the job types were reverted from back to maven type (jamoluhrsen, 16:07:26)
    3. Int/Dist needs to send their email stating their intent to join the Carbon release. (jamoluhrsen, 16:09:58)
    4. note that Int/Pak and Int/Test need to formally decline this SR participation (jamoluhrsen, 16:10:14)

  2. release (jamoluhrsen, 16:10:23)
    1. Boron was officially announced yesterday. (jamoluhrsen, 16:10:48)
    2. autorelease builds are now failing because of unit test failures (both Carbon and Boron, but Beryllium is working) (jamoluhrsen, 16:11:45)
    3. can't be sure if autorelease is triggering dist-test job because they are failing (jamoluhrsen, 16:12:44)

  3. packaging (jamoluhrsen, 16:12:57)
    1. merged CSIT tutorial vagrantfile (jamoluhrsen, 16:13:30)
    2. rpms for boron in the right place now. (jamoluhrsen, 16:13:50)
    3. some work happening still on the .deb based installs (jamoluhrsen, 16:16:27)

  4. builder (jamoluhrsen, 16:17:14)
    1. the belief is there that our nexus timeout is done. (jamoluhrsen, 16:18:31)
    2. ssh key copy failures still happen. zxiiro is still investigating. (jamoluhrsen, 16:18:57)
    3. other ssh failures inside robot jobs also still happening (jamoluhrsen, 16:19:14)
    4. both ssh issues are being debugged at some level (jamoluhrsen, 16:21:19)
    5. zxiiro needs to be the one that merges the new patches to convert to freestyle. (jamoluhrsen, 16:23:32)
    6. packer builds are being automated with patch validation, so that merged patches will update the vm systems faster (it has been manual until now) (jamoluhrsen, 16:24:21)
    7. yaml validation on the way to help validate jjb work (jamoluhrsen, 16:26:45)
    8. dfarrell07 asks why our nexus download speeds are still slow. tykeal says it will cost us money to make it faster (jamoluhrsen, 16:27:32)
    9. releng team still looking to bring in odlforge (jamoluhrsen, 16:28:36)
    10. we need a bigger private cloud for odlforge, and if so we would also try to put CSIT back in private cloud. the public cloud would be for overflow (jamoluhrsen, 16:29:20)
    11. LuisGomez asks for a ddf session around infra. Maybe it can be a good unconference (jamoluhrsen, 16:30:28)

  5. misc (jamoluhrsen, 16:31:32)
    1. https://github.com/opendaylight/integration-packaging/tree/master/tutorials/csit CSIT Vagrant-based tutorial (dfarrell07, 16:33:59)
    2. LuisGomez giving openflow tutorial, and jamoluhrsen giving csit tutorial (jamoluhrsen, 16:34:01)
    3. jamoluhrsen asking for people that can dynamically add new users to access sandbox. both zxiiro and anil should be able to help. (jamoluhrsen, 16:36:37)
    4. ddf sessions of interest (jamoluhrsen, 16:37:09)
    5. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Integration.2F.5BTest.7CPackaging.7CDistribution.5D_Open_Forum <--- Int/* open forum discussion (jamoluhrsen, 16:37:41)
    6. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#opendaylight_dashboard_with_project_visibillity <--- better test dashboard (jamoluhrsen, 16:38:16)
    7. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#ODL_Testing_coverage.2C_reporting_and_process <--- better test focus among projects (jamoluhrsen, 16:39:14)
    8. anipbu notes that long term sustainability of a dashboard needs to be the main focus and not the quick one-off dashboards. maybe consolidate around spectrometer (jamoluhrsen, 16:40:34)
    9. http://sched.co/8NPX spectrometer planning (zxiiro, 16:41:28)
    10. https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum#Spectrometer_Planning <--- go sign up for this session if you are interested in dashboard stuff (jamoluhrsen, 16:41:46)
    11. mgkwill says his company has some useful internal dashboard. (jamoluhrsen, 16:42:13)
    12. http://events.linuxfoundation.org/events/opendaylight-summit/program/schedule (anipbu, 16:43:13)
    13. ACTION: jamoluhrsen to email phil to schedule a specific time for Int Open Forum (jamoluhrsen, 16:46:36)
    14. jamoluhrsen and LuisGomez going to try and clean/sift through trello at summit (jamoluhrsen, 16:48:17)


Meeting ended at 16:55:40 UTC (full logs).

Action items

  1. jamoluhrsen to email phil to schedule a specific time for Int Open Forum


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to email phil to schedule a specific time for Int Open Forum


People present (lines said)

  1. jamoluhrsen (39)
  2. dfarrell07 (6)
  3. odl_meetbot (4)
  4. odp-gerritbot (2)
  5. gvrangan (2)
  6. zxiiro (1)
  7. plaurin (1)
  8. anipbu (1)
  9. tykeal (0)
  10. LuisGomez (0)


Generated by MeetBot 0.1.4.