#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:34 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 16:05:29)
    1. jobs were aborting earlier in the week, but cleared orphans seemed to fix that. (jamoluhrsen, 16:06:22)
    2. contract signed with Rackspace to increase cloud infra size (jamoluhrsen, 16:07:19)
    3. when the new infra is online, we'll move CSIT back to private cloud (as much as we can) (jamoluhrsen, 16:07:45)
    4. if/when we see ODL forge in heavy use, CSIT will go back to the public cloud if needed. (jamoluhrsen, 16:08:06)
    5. we do have the ability to test CSIT jobs in both clouds using the sandbox, so we can use that to figure out if jobs are ok to migrate back and forth. (jamoluhrsen, 16:10:08)
    6. sanity check jobs can first move to the private cloud (jamoluhrsen, 16:11:43)
    7. zxiiro|pto gone until next week, and tykeal and anil gone starting next week (jamoluhrsen, 16:12:42)

  2. release (jamoluhrsen, 16:13:33)
    1. Beryllium SR4 (last Be release) in 1.5 weeks (jamoluhrsen, 16:14:00)
    2. Beryllium passing autorel and seems healthy (jamoluhrsen, 16:14:16)
    3. Boron SR1 in 3 weeks. no idea the health there or if a lot of patches coming in. (jamoluhrsen, 16:15:05)
    4. autorelease is too hard to debug! we/anipbu needs help (jamoluhrsen, 16:21:00)

  3. distribution (jamoluhrsen, 16:22:47)
    1. https://git.opendaylight.org/gerrit/#/c/46258/ <--- better distro verification (jamoluhrsen, 16:24:41)
    2. master failing distro check. (jamoluhrsen, 16:25:52)
    3. ACTION: jamoluhrsen to point Vishal to helpdesk for distro check issue (jamoluhrsen, 16:27:11)

  4. misc (jamoluhrsen, 16:28:40)
    1. at the summit it was pointed out that the Integration group is not very "test" focused. talked about ways to fix it. one idea is to create a "test" mailing list and "test" meeting. (jamoluhrsen, 16:32:34)
    2. anipbu thinks this existing Int/* meeting is more internally focused, and maybe we need a more externally focused meeting. (jamoluhrsen, 16:35:34)
    3. LuisGomez asks if we need to add anything from Int/* to the Carbon release plan? (jamoluhrsen, 16:43:01)
    4. the "experimental" label did seem to help in the Boron release, and really gave a good view in to the projects that really care about system test and those that do not care (jamoluhrsen, 16:45:12)
    5. for Carbon, we want to start implementing "sanity" jobs that run quickly and ALWAYS pass. if they fail, it means that something is totally broken. (jamoluhrsen, 16:45:44)
    6. we still need to define what a "sanity" test case is. basically if a sanity test fails, we should think there is some critical/blocking bug (jamoluhrsen, 16:46:42)
    7. another summit takeaway was that we should start pointing our dashboard ideas to the spectrometer project (jamoluhrsen, 16:48:50)
    8. one summit session was asking (again) for ssh access to the vms as they are running tests (jamoluhrsen, 16:49:37)
    9. there may be some infra changes in the near future (especially in networking) and may allow us to possibly grant certain people access to our cloud systems via shell (so ssh access may be possible soon). sandbox systems (jamoluhrsen, 16:51:31)
    10. another idea we are trying out from a summit session is to run nested vms inside a CSIT VM to run our openstack jobs. (jamoluhrsen, 16:54:14)
    11. ACTION: dfarrell07 to send email to release formally stating that Int/Pak will not participate in Carbon SR (jamoluhrsen, 16:57:30)


Meeting ended at 17:04:01 UTC (full logs).

Action items

  1. jamoluhrsen to point Vishal to helpdesk for distro check issue
  2. dfarrell07 to send email to release formally stating that Int/Pak will not participate in Carbon SR


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to point Vishal to helpdesk for distro check issue


People present (lines said)

  1. jamoluhrsen (31)
  2. odl_meetbot (3)
  3. tykeal (3)
  4. odp-gerritbot (2)


Generated by MeetBot 0.1.4.