#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:01:28 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 17:03:32)
    1. no major release news. (jamoluhrsen, 17:04:18)
    2. probably a good idea for Integration team to analyze project CSIT at some point and give report if they are meeting expectations. (jamoluhrsen, 17:05:10)
    3. probably best to wait for M5 to send the full CSIT analysis per project (jamoluhrsen, 17:07:03)
    4. anipbu wondering how we can make the system test plan better? (jamoluhrsen, 17:10:49)
    5. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template <--- existing test plan (jamoluhrsen, 17:10:57)
    6. one reason to have better test plans is to help understand if "blocker" bugs are really blockers. (jamoluhrsen, 17:13:13)
    7. ACTION: anipbu to provide a wiki/doc with these ideas about projects giving better test plans (jamoluhrsen, 17:16:43)

  2. packaging (jamoluhrsen, 17:17:13)
    1. dfarrell07 working a lot on downstream/internal packaging (jamoluhrsen, 17:17:45)
    2. any upstream packaging work is slowly moving along via internship projects (jamoluhrsen, 17:18:25)
    3. ODL intern projects can now be submitted by mentors (jamoluhrsen, 17:19:37)
    4. we need to get autorelease for carbon working sooner rather than later (jamoluhrsen, 17:20:27)
    5. might not be anyone looking at it. (jamoluhrsen, 17:21:12)
    6. ACTION: zxiiro and/or anipbu will try to see what's wrong with it. maybe an email already went out (jamoluhrsen, 17:21:38)
    7. dfarrell07 added a bunch of trello cards and more coming. (jamoluhrsen, 17:22:08)

  3. distribution (jamoluhrsen, 17:22:20)
    1. distribution is late with M1 status. no release plan yet, but probably nothing specific for carbon (jamoluhrsen, 17:23:07)

  4. builder (jamoluhrsen, 17:23:56)
    1. lots of new patches in builder repo to set "defaults" instead of our existing static values. ie. varialbe for email receipients instead of jenkins-user (jamoluhrsen, 17:25:03)
    2. patch test jobs are now slightly higher priority. (jamoluhrsen, 17:25:36)
    3. also patch test jobs are now running concurrently. (jamoluhrsen, 17:25:55)
    4. should be ok to change our CSIT jobs to run concurrently. (jamoluhrsen, 17:26:50)
    5. ACTION: jamoluhrsen to give example patch for running csit concurrently on integration-dev list (jamoluhrsen, 17:27:43)
    6. historically, our prioritization was not as good as it is now, so running in parallel should be ok. (jamoluhrsen, 17:28:07)
    7. this label: ubuntu-trusty-mininet-ovs-23-2c-2g seems to not be coming up (jamoluhrsen, 17:29:27)
    8. jamoluhrsen points out that some projects like netvirt are trying to move forward with automatic gating with CSIT (jamoluhrsen, 17:31:24)
    9. https://jenkins.opendaylight.org/releng/job/genius-csit-1node-genius-only-boron/ <--- job that shows the ubuntu-trusty-ovs23 label not working (jamoluhrsen, 17:32:51)
    10. ACTION: zxiiro to check in to ubuntu-trusty-mininet-ovs-23-2c-2g node not coming up (jamoluhrsen, 17:33:48)

  5. misc (jamoluhrsen, 17:34:05)
    1. ACTION: zxiiro and jamoluhrsen to take a look at https://git.opendaylight.org/gerrit/#/c/48211/ (jamoluhrsen, 17:37:27)


Meeting ended at 17:39:36 UTC (full logs).

Action items

  1. anipbu to provide a wiki/doc with these ideas about projects giving better test plans
  2. zxiiro and/or anipbu will try to see what's wrong with it. maybe an email already went out
  3. jamoluhrsen to give example patch for running csit concurrently on integration-dev list
  4. zxiiro to check in to ubuntu-trusty-mininet-ovs-23-2c-2g node not coming up
  5. zxiiro and jamoluhrsen to take a look at https://git.opendaylight.org/gerrit/#/c/48211/


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to give example patch for running csit concurrently on integration-dev list
    2. zxiiro and jamoluhrsen to take a look at https://git.opendaylight.org/gerrit/#/c/48211/
  2. UNASSIGNED
    1. anipbu to provide a wiki/doc with these ideas about projects giving better test plans
    2. zxiiro and/or anipbu will try to see what's wrong with it. maybe an email already went out
    3. zxiiro to check in to ubuntu-trusty-mininet-ovs-23-2c-2g node not coming up


People present (lines said)

  1. jamoluhrsen (33)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)


Generated by MeetBot 0.1.4.