#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:18 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 17:04:37)
    1. boron sr2 in 1 month (jamoluhrsen, 17:05:01)
    2. autorelease build successful for Carbon.... w00t! (jamoluhrsen, 17:05:18)
    3. huge improvement from previous releases, because we are doing things better. better communication, etc. (jamoluhrsen, 17:05:55)
    4. the distro size is 435MB (jamoluhrsen, 17:06:47)
    5. yangtools changes coming to make the parser more strict, which could have a larger impact to lots of ODL projects (jamoluhrsen, 17:10:01)
    6. anipbu points out that our system test plan template does ask for the what and how to test. we need to be better at enforcing it. (jamoluhrsen, 17:12:02)

  2. packaging (jamoluhrsen, 17:12:16)
    1. new contributor in packaging to help rpm/deb build environment (jamoluhrsen, 17:12:57)
    2. nothing happening on the intern front this week (jamoluhrsen, 17:13:39)
    3. new trello for moving our ansible roles to ansible upstream (jamoluhrsen, 17:15:04)
    4. dfarrell07 says some interns are fishing for "easy" trello cards. add them, if you have them. (jamoluhrsen, 17:15:35)

  3. misc (jamoluhrsen, 17:17:10)
    1. there is ongoing discussions/meetings to see if there are ways the different LF projects can share/collaborate better. (jamoluhrsen, 17:17:50)

  4. distribution (jamoluhrsen, 17:18:30)
    1. https://docs.google.com/document/d/1Y6YjahxCRM0l35BoBXaSLMe8kFlUJuSU25n6g3U_k68 LF infra brainstorming doc, feel free to add stuff (dfarrell07, 17:18:37)
    2. no news (jamoluhrsen, 17:18:43)

  5. builder (jamoluhrsen, 17:18:56)
    1. might be some storage infra issues we have to deal with. probably a maintenance window coming. possibly the 11/26 date (jamoluhrsen, 17:19:47)
    2. tykeal worked with Rackspace+dfarrell07 to debug/partly-fix Nexus caps, went from 13mbps to 50mbps per download (dfarrell07, 17:20:31)
    3. we did have a large jenkins queue a few days ago (~300 jobs), but that seems to have been an anomaly and we wont worry about it until it becomes a regular problem. (jamoluhrsen, 17:22:48)
    4. there is a firewall that we would saturate if we increased 50mbps cap much more, which would impact other ppl, says a Rackspace person (dfarrell07, 17:24:40)

  6. the job migration from maven to freestyle still having some issues. the patches are there, but if we merge we will lose some csit tracking capability (jamoluhrsen, 17:25:22)
    1. LuisGomez wants to know if it's a big problem to leave some jobs as maven style (jamoluhrsen, 17:25:57)
    2. downside is that all artifacts in maven jobs are archived so it can slow down jenkins (jamoluhrsen, 17:26:20)
    3. other downside is that maven jobs are slightly slower, but maybe only a few minutes in the jobs we are worried about here. (jamoluhrsen, 17:26:53)
    4. patch ids for this maven->freestyle migration: 46019 46021 46030 (jamoluhrsen, 17:27:43)
    5. ACTION: LuisGomez to review this patch https://git.opendaylight.org/gerrit/#/c/48311/ (jamoluhrsen, 17:46:30)


Meeting ended at 17:46:33 UTC (full logs).

Action items

  1. LuisGomez to review this patch https://git.opendaylight.org/gerrit/#/c/48311/


People present (lines said)

  1. jamoluhrsen (31)
  2. odl_meetbot (4)
  3. dfarrell07 (3)


Generated by MeetBot 0.1.4.