#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:05 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 17:03:38)
    1. boron SR2 cutoff coming in 2 weeks (jamoluhrsen, 17:04:00)
    2. boron autorelease was broken but recently fixed. (jamoluhrsen, 17:04:23)
    3. carbon autorelease broken and waiting on centinel (jamoluhrsen, 17:04:40)
    4. autorelease is always building the next release, so for example boron autorelease is currently giving us SR2 (jamoluhrsen, 17:06:02)
    5. there has only been one system test waiver request (odlparent). expecting more to come (jamoluhrsen, 17:07:44)
    6. questions around projects requiring sys test for user-facing or top-level features (jamoluhrsen, 17:11:40)
    7. https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template <--- system test template (jamoluhrsen, 17:11:58)
    8. https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features <-- top level feature definition (jamoluhrsen, 17:12:39)
    9. we need to revisit odlparent's waiver request because they do have top level features that we may want to require CSIT (jamoluhrsen, 17:13:36)
    10. ACTION: jamoluhrsen to respond to odlparent waiver request (jamoluhrsen, 17:14:20)

  2. distribution (jamoluhrsen, 17:14:28)
    1. new contributions in progress (karaf 4, netconf feature incompatibility, and bug 4296) (jamoluhrsen, 17:16:02)
    2. bug 4296 is around the version feature and should be good before boron SR2 (jamoluhrsen, 17:16:37)
    3. anipbu wonders if we should start pushing odlparent to help us get to a stable distribution. (jamoluhrsen, 17:18:55)
    4. even if odlparent gives us a stable feature(s) it's not giving us anything usable so maybe we should wait until we have more "useful" stable features? (jamoluhrsen, 17:20:40)
    5. the distribution team should wait until other projects with useful features are stable should we do the work to actually create the stable distribution (jamoluhrsen, 17:22:07)

  3. packaging (jamoluhrsen, 17:22:20)
    1. deb support added in ansible role. (jamoluhrsen, 17:22:46)
    2. puppet opendaylight CI (travis) being looked at by possible new ODL intern. (jamoluhrsen, 17:23:55)
    3. AAA patch merged to help change ODL user passwords via NB REST without restarting controller (jamoluhrsen, 17:24:44)
    4. packaging trello cards are now freshly updated and current (jamoluhrsen, 17:25:27)
    5. incorrect explanation about AAA patch. it's actually a jar file to manipulate (jamoluhrsen, 17:27:03)

  4. builder (jamoluhrsen, 17:27:08)
    1. recent RackSpace upgrade issues (orphaned ports, new image creation) should now be resolved (jamoluhrsen, 17:28:08)
    2. RackSpace is now on Liberty (jamoluhrsen, 17:28:31)
    3. jamoluhrsen asks where we should store custom cirros images for our openstack CSIT jobs. (jamoluhrsen, 17:30:52)
    4. idea is that we find a way to *build* the image in our infra and then store it on our nexus (jamoluhrsen, 17:31:31)
    5. BUT, we can just directly pull it down from the internet as well. (jamoluhrsen, 17:31:47)
    6. we can put the packer definition in the builder repo and then directly pull it from our private cloud swift, or put it on nexus (jamoluhrsen, 17:33:02)
    7. jamoluhrsen asks about using a groovy script to generate a custom email report from robot results (jamoluhrsen, 17:33:56)
    8. the answer is that it would require manual work every time a job is updated. groovy scripts are a pain to maintain. (jamoluhrsen, 17:34:46)
    9. https://gerrit.zephyrproject.org/r/#/admin/projects/ci-management Zephyr Project ci-management. Check the zephyr sub-project for custom email examples (tykeal, 17:37:15)

  5. infra collab initiative (jamoluhrsen, 17:37:26)
    1. https://drive.google.com/open?id=1WwK-49QfFBz1PeAKFg4dyCUDj-EYc_jeEqpgzsLLEbw <--- google doc (jamoluhrsen, 17:37:38)
    2. infra collab group has a weekly meeting. (jamoluhrsen, 17:41:31)
    3. ACTION: LuisGomez to send email invites to interested folks ( anipbu and zxiiro ) (jamoluhrsen, 17:42:13)

  6. misc (jamoluhrsen, 17:50:35)
    1. vrpolak points out beryllium is failing because of a circular dependency, but fix is in place (jamoluhrsen, 17:51:22)
    2. jamoluhrsen wondering if we have any way to exclude certain robot.tidy tox failures, like we see in this one: https://git.opendaylight.org/gerrit/#/c/48646/7/csit/libraries/Netvirt.robot (jamoluhrsen, 17:53:16)
    3. vrpolak mentions that karaf 4 is coming and some files are formatted in different ways, so our releng builder scripts may need some work to make this easier on odlparent folks (jamoluhrsen, 17:54:28)
    4. ACTION: vrpolak can share a concrete example of this problem via mailing list (jamoluhrsen, 17:54:47)
    5. we had collateral damage from a recent CSIT patch in a library file: https://git.opendaylight.org/gerrit/#/c/48602/ (jamoluhrsen, 17:56:03)
    6. tl;dr a utils keyword started returning 2 values instead of 1 so some consumers broke. but not all (jamoluhrsen, 17:57:06)
    7. ACTION: LuisGomez jamoluhrsen to double check all jobs using this library to see if we have too many failures and should revert (jamoluhrsen, 17:57:57)


Meeting ended at 17:59:11 UTC (full logs).

Action items

  1. jamoluhrsen to respond to odlparent waiver request
  2. LuisGomez to send email invites to interested folks ( anipbu and zxiiro )
  3. vrpolak can share a concrete example of this problem via mailing list
  4. LuisGomez jamoluhrsen to double check all jobs using this library to see if we have too many failures and should revert


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to respond to odlparent waiver request
    2. LuisGomez jamoluhrsen to double check all jobs using this library to see if we have too many failures and should revert
  2. UNASSIGNED
    1. LuisGomez to send email invites to interested folks ( anipbu and zxiiro )
    2. vrpolak can share a concrete example of this problem via mailing list


People present (lines said)

  1. jamoluhrsen (46)
  2. odl_meetbot (3)
  3. tykeal (1)
  4. odp-gerritbot (1)


Generated by MeetBot 0.1.4.