#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:00 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 17:05:05)
    1. lots of intern activity, which is awesome (jamoluhrsen, 17:05:21)
    2. not all of the current intern activity will result in official internships (jamoluhrsen, 17:06:16)
    3. rpm build logic will now be able to find latest snapshot distro and create and rpm... helpful for opnfv we think (jamoluhrsen, 17:06:57)
    4. coala linter now available (jamoluhrsen, 17:07:21)
    5. so good linting on things like json, md, etc (jamoluhrsen, 17:07:43)
    6. puppet modules are being updated now. more tests (jamoluhrsen, 17:08:33)
    7. opnfv/apex consuming rpms constantly. (jamoluhrsen, 17:08:52)

  2. builder (jamoluhrsen, 17:10:11)
    1. we now store console logs with timestamps on log server (jamoluhrsen, 17:10:49)
    2. ACTION: jamoluhrsen to send email why robot logs are showing local timezone? (jamoluhrsen, 17:13:38)
    3. infra folks hoping to minimize changes as we approach the end of the year (jamoluhrsen, 17:15:14)
    4. odlforge still has slow progress towards getting online (jamoluhrsen, 17:15:27)

  3. release (jamoluhrsen, 17:16:26)
    1. ACTION: LuisGomez to look at L2Switch failures in SR2 (jamoluhrsen, 17:17:15)
    2. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020 <--- Boron SR2 status (jamoluhrsen, 17:17:25)
    3. hopefully try to approve SR2 today (jamoluhrsen, 17:17:43)

  4. distribution (jamoluhrsen, 17:17:52)
    1. cardinal failures in SFT for carbon because of a change in odlparent. (jamoluhrsen, 17:18:30)
    2. vrpolak looking at these failures, but no simple solution yet. (jamoluhrsen, 17:18:50)
    3. worst case is that cardinal might need to be removed from distribution (jamoluhrsen, 17:19:21)
    4. dlux apps are now being added to distribution (jamoluhrsen, 17:19:34)
    5. vorburger has patches to make all features created the same way. vrpolak reviewing those patches (jamoluhrsen, 17:19:59)

  5. misc (jamoluhrsen, 17:20:41)
    1. jamoluhrsen asks if we should start purging logs with the same cadence (every Sat) as we do jobs (jamoluhrsen, 17:22:57)
    2. current method is to delete logs when they are 7 days old, so there is some overlap that could cause confusion when people create jobs with the same name. (jamoluhrsen, 17:24:25)
    3. ACTION: jamoluhrsen to give PSA about how logs are purged... (jamoluhrsen, 17:26:20)
    4. vrpolak would prefer logs to be purged on Sat like the jobs (jamoluhrsen, 17:27:43)
    5. ACTION: jamoluhrsen to open helpdesk ticket for log purging. (jamoluhrsen, 17:29:56)
    6. LuisGomez noticed that yangtools merge job is failing for Beryllium so we cannot build a distro at this point. (jamoluhrsen, 17:31:25)
    7. since we will *probably* not release another Beryllium release it may not be a big deal, but there is the possibility that a security issue could force another release. (jamoluhrsen, 17:32:04)
    8. LuisGomez proposes that we move all of our periodic jobs away from running daily on SNAPSHOT distros and only to run on autorelease distros (jamoluhrsen, 17:35:04)
    9. problem with running periodic jobs on autorelease, is that master is not creating the distro hardly ever (jamoluhrsen, 17:36:29)
    10. ACTION: LuisGomez to come up with a plan for running periodic jobs on autorelease taking in to account that master autorelease is not successful most of the time (jamoluhrsen, 17:38:21)
    11. vrpolak points out that autorelease is probably not triggering enough CSIT jobs (jamoluhrsen, 17:42:17)
    12. jamoluhrsen points out that we have to use the older version of paramiko because the newer version broke the robot framework SSHLibrary. (jamoluhrsen, 17:43:51)
    13. ACTION: jamoluhrsen to create trello card to investigate the paramiko issue and see if we can find a solution so we can use the newer lib (jamoluhrsen, 17:44:46)


Meeting ended at 17:47:04 UTC (full logs).

Action items

  1. jamoluhrsen to send email why robot logs are showing local timezone?
  2. LuisGomez to look at L2Switch failures in SR2
  3. jamoluhrsen to give PSA about how logs are purged...
  4. jamoluhrsen to open helpdesk ticket for log purging.
  5. LuisGomez to come up with a plan for running periodic jobs on autorelease taking in to account that master autorelease is not successful most of the time
  6. jamoluhrsen to create trello card to investigate the paramiko issue and see if we can find a solution so we can use the newer lib


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send email why robot logs are showing local timezone?
    2. jamoluhrsen to give PSA about how logs are purged...
    3. jamoluhrsen to open helpdesk ticket for log purging.
    4. jamoluhrsen to create trello card to investigate the paramiko issue and see if we can find a solution so we can use the newer lib
  2. UNASSIGNED
    1. LuisGomez to look at L2Switch failures in SR2
    2. LuisGomez to come up with a plan for running periodic jobs on autorelease taking in to account that master autorelease is not successful most of the time


People present (lines said)

  1. jamoluhrsen (39)
  2. odl_meetbot (3)
  3. odp-gerritbot (2)


Generated by MeetBot 0.1.4.