#opendaylight-integration: performance and cluster test

Meeting started by jamoluhrsen at 16:03:48 UTC (full logs).

Meeting summary

    1. first performance related focus can be to get our one off tests that people are running locally pushed to test repo and running in releng (jamoluhrsen, 16:04:30)
    2. we need a dashboard. there is an intern working in this area (jamoluhrsen, 16:05:13)
    3. pramod from intel has a sort of dashboard that collects tempest results (jamoluhrsen, 16:06:42)
    4. http://pramodrj07.github.io/odl/ pramod's dashboard (jamoluhrsen, 16:07:33)
    5. should we get access to a physical performance lab hosted by LF? (jamoluhrsen, 16:09:52)
    6. this would be a separate effort than CPERF in OPNFV. CPERF is controller agnostic, whereas this LF perf lab would be ODL specific (jamoluhrsen, 16:11:54)
    7. ACTION: mgkwill to start more conversations on mailing list (jamoluhrsen, 16:14:21)
    8. mgkwill can submit a CFP for performance numbers as we assume we will be collecting numbers and again like we did at the end of Beryllium release. (jamoluhrsen, 16:17:59)
    9. vratko notes that peter is retesting ONOS with new version and ONOS performance is much better. (jamoluhrsen, 16:22:23)
    10. mgkwill confirms those findings (jamoluhrsen, 16:22:30)
    11. ONOS added batch flow programming in newest version. (jamoluhrsen, 16:23:20)
    12. next week we will try to present/summarize all the different upstream releng performance tests (jamoluhrsen, 16:26:33)

  1. cluster testing (jamoluhrsen, 16:27:01)
    1. cluster tests should start moving to clustermanagment.robot library from clusterkeywords.robot (jamoluhrsen, 16:27:41)
    2. in otherwords, clusterkeywords.robot should be considered "deprecated" (jamoluhrsen, 16:28:24)
    3. sanjib points out that a new feature is introduced in boron to do bulk requests via REST. (jamoluhrsen, 16:32:03)
    4. still not sure what this new feature is providing, need more info. (jamoluhrsen, 16:34:00)
    5. vratko describes three ways to create a lot of flows 1) restconf with container with lots of items. 2) batch method that may be unreliable. 3) openflow has implemented RPC batch method, bulk-o-matic. (jamoluhrsen, 16:36:24)
    6. ACTION: jamoluhrsen to look in to issue where slowly bringing up controllers in a cluster means clustering is broken. (jamoluhrsen, 16:40:33)
    7. https://lists.opendaylight.org/pipermail/integration-dev/2016-May/006616.html to see discussion about controllers not able to be in a healthy cluster if they come up too far apart (jamoluhrsen, 16:41:33)
    8. jamoluhrsen points out that OVSDB cluster tests consistently fail, but no traction from project to get the bugs fixed (jamoluhrsen, 16:52:32)
    9. openflowplugin clustering CSIT has some failures and bugs are filed for them. (jamoluhrsen, 16:57:37)
    10. new netconf suite for clustering has been merged. open bug is there for the failures. (jamoluhrsen, 16:58:29)
    11. jozef may be going away from test work. (jamoluhrsen, 16:59:48)


Meeting ended at 17:02:28 UTC (full logs).

Action items

  1. mgkwill to start more conversations on mailing list
  2. jamoluhrsen to look in to issue where slowly bringing up controllers in a cluster means clustering is broken.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to look in to issue where slowly bringing up controllers in a cluster means clustering is broken.


People present (lines said)

  1. jamoluhrsen (27)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.