#opendaylight-integration: s3p

Meeting started by dfarrell07 at 15:32:46 UTC (full logs).

Meeting summary

    1. dfarrell07 took a deep-dive into existing NetVirt CSIT, what's working/broken/usable (dfarrell07, 15:33:44)
    2. dfarrell07 is starting to base a new job on {project}-csit-1node-openstack-{openstack}-{functionality}-{stream} template (dfarrell07, 15:33:49)
    3. dfarrell07 sync'd with Marcus about ongoing Intel NetVirt scale work (dfarrell07, 15:33:53)
    4. Marcus and team seem to be making good progress, see CPerf minutes for details (dfarrell07, 15:33:58)
    5. Starting to look like Maracus et al will drive quick-results/big-numbers tests in private lab, dfarrell07 will drive in CSIT (dfarrell07, 15:34:03)
    6. Great discussion on integration-dev mailing list about Luis' OpenFlow tests, feedback from Al et al about timing/metrics/tests (dfarrell07, 15:34:07)
    7. https://wiki.opendaylight.org/view/Integration/Test/S3P/Performance_Test_Reports/Boron_Performance_Test_Report_Plan Main Boron whitepaper link (dfarrell07, 15:38:39)
    8. mgkwill starts off going over that link^^,reviewing past discussions (dfarrell07, 15:38:51)
    9. LuisGomez talks about switch scale tests, maybe with Veryx, maybe mininet (dfarrell07, 15:39:03)
    10. mgkwill asks Vratko about NetConf/BGP tests (dfarrell07, 15:39:45)
    11. NetConf/BGP tests will be done with existing upstream tests, shouldn't take too much time, week or two, they are starting on this in next day or two (dfarrell07, 15:40:15)
    12. ACTION: dfarrell07 to create stub readthedocs for whitepaper (dfarrell07, 15:42:17)
    13. https://wiki.opendaylight.org/view/Integration/Test/S3P/OpenFlow (LuisGomez, 15:45:17)
    14. Discussion about Netvirt scale tests (dfarrell07, 15:52:02)
    15. Min sim: OVS instance, ports/routers etc get added to simulate neutron config, start programming flows (dfarrell07, 15:52:39)
    16. Can ignore VMs, traffic, etc for now jamoluhrsen says, just scale to a large number of ovs instances with the right connections, create ~20 ports each, next level make sure we can send traffic (dfarrell07, 15:55:46)
    17. mgkwill talks about existing code he has upstream, spins up OVSs, sets up connections, would need to add logic to install netvirt and do some network/port creation (dfarrell07, 15:57:46)
    18. discussion about benefits of full-vm-node tests intel is doing on their hw, how that tests other things like NBB, different traffic (dfarrell07, 15:59:44)
    19. mgkwill and dfarrell07 will work on getting ovs instances spinning up in containers against NetVirt CSIT jobs this coming up week (dfarrell07, 16:01:18)
    20. mgkwill talks about moving these tests into OPNFV CPerf eventually, would be able to scale much larger (dfarrell07, 16:01:38)
    21. Discussion about OF testing LuisGomez and Al are talking about metrics/timing on-list, discussion will continue on-list, should doc these timing details in report (dfarrell07, 16:05:34)
    22. LuisGomez is out next week, jamoluhrsen is out part of next week (dfarrell07, 16:05:42)
    23. Sanjib is working on bulk-o-matic this week (dfarrell07, 16:07:00)
    24. Vratko and mgkwill talk about netconf/bgp tests, Vratko will support with bug fixes if test results find problems (dfarrell07, 16:11:37)


Meeting ended at 16:17:44 UTC (full logs).

Action items

  1. dfarrell07 to create stub readthedocs for whitepaper


Action items, by person

  1. dfarrell07
    1. dfarrell07 to create stub readthedocs for whitepaper


People present (lines said)

  1. dfarrell07 (26)
  2. odl_meetbot (4)
  3. LuisGomez (2)
  4. mgkwill (0)
  5. jamoluhrsen (0)


Generated by MeetBot 0.1.4.