#opendaylight-integration: s3p

Meeting started by dfarrell07 at 15:32:43 UTC (full logs).

Meeting summary

    1. Discussion about when we should target report for release (dfarrell07, 15:35:08)
    2. There are clustering fixes in the works, we thought they would land for SR1, but now seems like not until Carbon (dfarrell07, 15:35:29)
    3. There are new OF tests we would like to run/include (dfarrell07, 15:35:43)
    4. Luis, Marcus et al think timing is tight for Summit, so SR1 is nice in that regard (dfarrell07, 15:36:09)
    5. Can focus on jobs in CI, show public graphs, for this report (dfarrell07, 15:36:32)
    6. dfarrell07 asks for tech details on why clustering is slow, Luis says slow part in current clustering is backend pipeline (dfarrell07, 15:39:05)
    7. Phil, Colin, Robert et all have been following this, Phil gives more info, we're currently syncing and locking one transaction across the cluster, need pipelineing and batching to improve that (dfarrell07, 15:40:15)
    8. Pipelining is best solution but hard, short term option may be to do transparent batching, which maybe could happen for SR1 (dfarrell07, 15:40:41)
    9. OF also needs ability to use transparent batching, then we'd have big perf increase (dfarrell07, 15:41:00)
    10. Colin is figuring out if we have resources for that work, if it can be done for SR1 (dfarrell07, 15:41:22)
    11. jamoluhrsen asks how bad we are now, and how that compares to clustering exactly (dfarrell07, 15:41:41)
    12. Luis says bulk-o-matic and NB API tests are the relevant ones, because they touch the data store, in first runs he's seeing 4x less for cluster, still getting data for proper results (dfarrell07, 15:42:50)
    13. Latency and flows per second are of course major considerations, but Luis also seeing instances die when you try to slam it with many flows, doesn't see this with single instance (so maybe bugs+perf issues) (dfarrell07, 15:43:41)
    14. Luis asks phrobb for recommendation, Phil isn't sure, gathering opinions (dfarrell07, 15:45:05)
    15. dfarrell07 suggests focusing on CI tests, describing what they are doing, what they mean, that we're trying to drive perf work towards stuff in CI (dfarrell07, 15:47:39)
    16. Discussion about how we really should do this after the release, so we can build/run tests against stable ODL (dfarrell07, 15:48:41)
    17. Luis suggests getting as much infra automatic as possible, target SR1 for paper (dfarrell07, 15:49:07)
    18. phrobb asks about perf tests of ODL through OpenStack, mgkwill says that's what they are doing internally, setting up ODL+O/S and benchmarking with Rally, comparing to default neutron networking (dfarrell07, 15:50:38)
    19. https://git.opendaylight.org/gerrit/#/c/45714/ Boron perf report stub gerrit by dfarrell07 (dfarrell07, 15:53:43)
    20. AGREED: We will complete the stub perf report below to describe tests we're doing in CI, what they do and mean, put them in context (dfarrell07, 15:54:09)
    21. Luis points out we might could create a dashboard with his intern's project to show all the perf results we care about, intern may be able to do for us (dfarrell07, 15:54:57)
    22. ACTION: Luis to contact dashboard intern to see if they can do this, tell them which jobs we want to track on dashboard (dfarrell07, 15:55:28)
    23. Party line for clustering perf is that we've been focused on clustering functional tests this release, has gotten much more stable in Boron, are adding perf tests as well, we know perf currently sucks and we know why and we're planning on fixing it in SR1 or Carbon (dfarrell07, 15:59:12)
    24. AGREED: Not going to do big-machine, big-number perf tests for Summit, will monitor cluster perf via CI jobs and see if possible for SR1 (dfarrell07, 16:02:30)
    25. We should be honest, as an open source project, about clustering not being where we want to be (dfarrell07, 16:02:47)
    26. Our more marketing-focused peers will likely not be nice ;), but we should just do the right thing (dfarrell07, 16:03:44)
    27. ACTION: phrobb will send out email about status of perf testing, plans (dfarrell07, 16:12:20)
    28. , a party line alternative...Party line for clustering perf is that we've been focused on clustering functional tests this release, has gotten much more stable in Boron, are adding perf tests as well, we know perf currently is lacking and we know why. We have plans in place to improve clustering performance and to construct tests to validate and (phrobb, 16:13:59)
    29. (cont) ...measure those improvements in the next release. (dfarrell07, 16:14:35)
    30. Discussion about groups we know are using clustering, that it works okay when not pushing it hard for perf testing it seems (dfarrell07, 16:16:01)
    31. https://git.opendaylight.org/gerrit/#/c/45714/ <--- patch with perf report stub (jamoluhrsen, 16:16:52)


Meeting ended at 16:20:31 UTC (full logs).

Action items

  1. Luis to contact dashboard intern to see if they can do this, tell them which jobs we want to track on dashboard
  2. phrobb will send out email about status of perf testing, plans


Action items, by person

  1. phrobb
    1. phrobb will send out email about status of perf testing, plans


People present (lines said)

  1. dfarrell07 (34)
  2. odl_meetbot (4)
  3. phrobb (2)
  4. odp-gerritbot (2)
  5. jamoluhrsen (2)
  6. mgkwill (0)


Generated by MeetBot 0.1.4.