#opendaylight-integration: integration

Meeting started by jamoluhrsen at 07:38:38 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 07:38:50)
    1. still good progress happening from prospective interns (jamoluhrsen, 07:38:50)
    2. new jobs coming online, like testing the rpm, creating snapshot builds (jamoluhrsen, 07:39:07)
    3. maybe some refactoring in the work for how .deb and .rpm logic are sharing code (jamoluhrsen, 07:39:07)
    4. jamoluhrsen wondering if there is some demo worthy packaging work? (jamoluhrsen, 07:39:07)
    5. a good demo would showing how the rpm and deb packaging works. (jamoluhrsen, 07:39:07)
    6. we want to extend the packaging internship to include 2 interns instead of 1. (jamoluhrsen, 07:39:07)

  2. distribution (jamoluhrsen, 07:39:08)
    1. karaf 4 work is starting to happen now, but nothing landing yet. (jamoluhrsen, 07:39:18)
    2. beir project verification is failing due to possible issues in ietf models. (jamoluhrsen, 07:39:18)
    3. seems that only the beir project is hitting these issues. (jamoluhrsen, 07:39:18)
    4. anipbu thinks it possible that the beir issue is resolved for autorelease, but vrpolak points out this is a failure in distribution not autorelease (jamoluhrsen, 07:39:18)

  3. release (jamoluhrsen, 07:39:19)
    1. autorelease is still failing in carbon, but fine with boron (jamoluhrsen, 07:39:25)
    2. karaf 4 migration is going to need some push for projects to migrate sooner rather than later. (jamoluhrsen, 07:39:25)
    3. if the plan is to only release carbon with karaf4, we need to figure out how we will deal with those projects that are in maint. mode and wont be able to do this migration on their own. (jamoluhrsen, 07:39:28)
    4. do we drop them from release, do the work for them, other? (jamoluhrsen, 07:39:31)
    5. we need to know how much work is really needed per project. requesting a TWS for this. (jamoluhrsen, 07:39:33)
    6. autorelease for carbon now failing with of-config (jamoluhrsen, 07:39:36)

  4. builder (jamoluhrsen, 07:39:38)
    1. no infra changes the past few weeks, but updates coming (e.g., jenkins upgrade to 2.x, gerrit update to 2.12, security updates, and more...) (jamoluhrsen, 07:39:40)
    2. the releng periodic jobs are now removed (jamoluhrsen, 07:39:43)
    3. the jenkins queue is very large and it's mostly CSIT jobs. (jamoluhrsen, 07:39:45)
    4. one problem we have now is that we have a lot more CSIT jobs and we cannot start any more simultaneous robot jobs without jenkins crashing. (jamoluhrsen, 07:39:47)
    5. the issue is with RackSpace API + jclouds, not with the available resources (jamoluhrsen, 07:39:50)
    6. one effort we can try is to use heat to spin up nodes, instead of jclouds. (jamoluhrsen, 07:39:54)
    7. initial investigation by zxiiro is promising. (jamoluhrsen, 07:39:56)
    8. another advantage from heat is it would make it easier to do multi-network VMs (jamoluhrsen, 07:39:58)
    9. tykeal wants to make it known that the main consumer of this large jenkins queue is netvirt (jamoluhrsen, 07:40:00)
    10. zxiiro thinks maybe another big user of CSIT resources are these post merge jobs and periodic jobs (jamoluhrsen, 07:40:03)
    11. short term solution is to find and stop any unnecessary CSIT jobs. (jamoluhrsen, 07:40:06)
    12. long term is to get heat working (jamoluhrsen, 07:40:09)
    13. also we need to really sit and think through all that is happening with CSIT and make sure we are really doing what we want. (jamoluhrsen, 07:40:10)
    14. maybe a short/small hackfest only focused around the jenkins jobs is in order. (jamoluhrsen, 07:40:13)
    15. ACTION: jamoluhrsen to start an email on this. (jamoluhrsen, 07:40:15)
    16. internally, LF has a new public repo coming in with useful tools that are being used in other LF projects (e.g. version bumping) (jamoluhrsen, 07:40:17)

  5. misc (jamoluhrsen, 07:40:20)
    1. should we grant system test waivers to odlparent, infrautils and neutron nb as we did in Boron? (jamoluhrsen, 07:40:24)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test <--- boron system test waiver approval (jamoluhrsen, 07:40:27)
    3. vrpolak wonders if odlparent might actually have top level features that should have some system test (jamoluhrsen, 07:40:30)
    4. we need a more explicit test description for next release (jamoluhrsen, 07:40:33)
    5. skitt points out that some odlparent features can break in subtle ways that it would be nice to have automation around. (jamoluhrsen, 07:40:35)
    6. vrpolak thinks infrautils could use small system tests as well. (jamoluhrsen, 07:40:38)
    7. anipbu agrees that infrautils could/should have system test. (jamoluhrsen, 07:40:40)
    8. ACTION: jamoluhrsen to ask for a report of other projects consuming infrautils and if their CSIT is really testing features of infrautils (jamoluhrsen, 07:40:43)
    9. also we should consider their IT/UT coverage as well. (jamoluhrsen, 07:40:45)
    10. will approve neutron NB and odlparent. then email infrautils (jamoluhrsen, 07:40:47)

  6. karaf4 migration (jamoluhrsen, 07:40:49)
    1. skitt thinks the migration work is not too hefty, and mostly mechanical (jamoluhrsen, 07:40:53)
    2. this work is done already for most of offset-0 (jamoluhrsen, 07:40:55)
    3. most time consuming part is testing all the features. (jamoluhrsen, 07:40:57)
    4. most breakages are hopefully already fixed in odlparent (jamoluhrsen, 07:40:59)
    5. biggest dependency is the number of features a project has (jamoluhrsen, 07:41:01)
    6. some non-responsive projects should be fairly easy to migrate if they are using features-parent (jamoluhrsen, 07:41:04)
    7. projects that are not using single feature test are going to be hard to migrate (jamoluhrsen, 07:41:06)
    8. we need to poll these projects to get an idea of how painful this migration might be (jamoluhrsen, 07:41:08)
    9. LuisGomez asks how critical this migration would be, and it seems from community emails that it's a pretty big deal (jamoluhrsen, 07:41:11)
    10. https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008819.html (jamoluhrsen, 07:41:14)


Meeting ended at 07:41:16 UTC (full logs).

Action items

  1. jamoluhrsen to start an email on this.
  2. jamoluhrsen to ask for a report of other projects consuming infrautils and if their CSIT is really testing features of infrautils


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to start an email on this.
    2. jamoluhrsen to ask for a report of other projects consuming infrautils and if their CSIT is really testing features of infrautils


People present (lines said)

  1. jamoluhrsen (60)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.