#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:15 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:03:49)
    1. configure_cluster script discussion ongoing because it has broken recently because controller project did not know about it. (jamoluhrsen, 17:04:25)
    2. vrpolak thinks we should probably move the controller script to the controller project (jamoluhrsen, 17:04:51)
    3. if it does move to controller project, hopefully we can keep it in /bin still (jamoluhrsen, 17:05:41)
    4. beir project is having trouble putting their features in integration. some yang model conflict (jamoluhrsen, 17:06:06)
    5. honeycomb/vbd is also seeing this issue (jamoluhrsen, 17:06:58)
    6. vrpolak will have a bug for these issues and md-sal project can hopefully take care. (jamoluhrsen, 17:07:21)
    7. controller project has reverted their akka conf change so clustering should not be broken. the cluster_config script change has also been reverted. (jamoluhrsen, 17:09:37)
    8. vrpolak has an email out for int/dist about moving the cluster_config script to controller project. (jamoluhrsen, 17:10:50)

  2. packaging (jamoluhrsen, 17:12:16)
    1. intern applications are finalized and we will have two packaging interns. (jamoluhrsen, 17:12:48)
    2. ansible linting done and some ansible test framework potential being investigated (jamoluhrsen, 17:13:24)
    3. readthedocs patch coming to move wiki content to readthedocs (still open for review) (jamoluhrsen, 17:14:03)
    4. no autorelease for boron for ~1week. (jamoluhrsen, 17:14:22)
    5. boron autorelease blocker should be fixed today (it was of-config) (jamoluhrsen, 17:14:41)

  3. release (jamoluhrsen, 17:15:06)
    1. waiting for AAA, controller and netconf feature freeze. (jamoluhrsen, 17:15:58)
    2. system test waiver came from bier project. anipbu recommends we do not approve the waiver without more info from the project (jamoluhrsen, 17:16:24)
    3. anipbu asked beir project for more info. waiting on their response? (jamoluhrsen, 17:17:05)
    4. https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008922.html (anipbu, 17:18:36)
    5. https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008922.html <--- email to beir asking for more info about sys test waiver (jamoluhrsen, 17:19:07)
    6. carbon autorelease still failing and we continue to hound projects to help unbreak it. (jamoluhrsen, 17:23:00)

  4. builder (jamoluhrsen, 17:23:27)
    1. https://github.com/opendaylight/releng-builder/blob/master/jjb/opendaylight-infra-stack.sh opendaylight-infra-stack (zxiiro, 17:23:43)
    2. all csit jobs that used to spin up with jclouds are now using heat (jamoluhrsen, 17:23:43)
    3. https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-macros.yaml#L264-L284 integration-infra-stack (zxiiro, 17:26:41)
    4. https://developer.rackspace.com/docs/cloud-servers/v2/general-api-info/flavors/ <--- shows all the VM flavors we can get from RackSpace public cloud (jamoluhrsen, 17:30:13)
    5. even with this flexibility now to more easily get VM flavors, we still want to use the smallest vm possible (jamoluhrsen, 17:32:06)
    6. heat will fail a lot faster now, which is good :) (jamoluhrsen, 17:32:20)
    7. https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-templates.yaml#L81-L88 integration template heat changes (zxiiro, 17:33:02)
    8. https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-defaults.yaml#L30-L42 default variables related to heat (zxiiro, 17:34:41)
    9. vrpolak wondering about the ssh issue and wondering if we can add an entropy check in the spinup scripts? (jamoluhrsen, 17:42:46)
    10. ACTION: jamoluhrsen to look in to installing/running havegd in spinup scripts. (jamoluhrsen, 17:44:56)
    11. maybe it can be inside packer too (jamoluhrsen, 17:45:32)
    12. we need a script that calls an ssh command/script to vote on a gerrit. it would be a macro to end up as a last step in a job (jamoluhrsen, 17:47:59)
    13. we would also need some work in the patch test job to know if it should be a -1,0,+1 (jamoluhrsen, 17:48:40)


Meeting ended at 18:02:48 UTC (full logs).

Action items

  1. jamoluhrsen to look in to installing/running havegd in spinup scripts.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to look in to installing/running havegd in spinup scripts.


People present (lines said)

  1. jamoluhrsen (39)
  2. zxiiro (5)
  3. odl_meetbot (4)
  4. odp-gerritbot (3)
  5. vrpolak (1)
  6. dfarrell07 (1)
  7. anipbu (1)


Generated by MeetBot 0.1.4.