#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:20 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:04:56)
    1. distribution is quiet mostly. (jamoluhrsen, 17:05:15)
    2. some AAA features were removed (they were unused) (jamoluhrsen, 17:05:29)
    3. m2 status report is due (jamoluhrsen, 17:05:34)
    4. filed a bug to get cluster config scripts moved to the controller project (jamoluhrsen, 17:05:55)
    5. bier project still failing distribution build (jamoluhrsen, 17:06:15)

  2. release (jamoluhrsen, 17:08:02)
    1. M3 offset 1 is due today (1/19) (jamoluhrsen, 17:08:25)
    2. carbon autorelease still not working. we need to be more aggressive to get this working. (jamoluhrsen, 17:08:54)
    3. we still have had successful carbon autorelease in the past, which is still better compared to other releases (Boron). (jamoluhrsen, 17:09:44)

  3. builder (jamoluhrsen, 17:09:57)
    1. we will have a 2-hour maintenance window this weekend. (jamoluhrsen, 17:10:15)
    2. we'll get some jenkins/gerrit/etc version increases (jamoluhrsen, 17:10:34)
    3. not moving to gerrit 2.13, just latest of 2.12 (jamoluhrsen, 17:10:49)
    4. it appears that all the job queue tuning we have done recently, the queue has remained small (jamoluhrsen, 17:11:31)
    5. we are now running with 30 parallel robot jobs, up from 20. (jamoluhrsen, 17:12:45)
    6. we are still only able to run 5 jobs in parallel in the sandbox (jamoluhrsen, 17:13:36)
    7. a lot of jobs that get pushed to the sandbox are configured with timers, so the sandbox queue is being consumed by some of those jobs (jamoluhrsen, 17:14:24)
    8. tykeal- threatens to introduce the choas butler in the sandbox (jamoluhrsen, 17:14:49)
    9. it looks like we may be getting a new job type that has 3 nodes (odl, tools, devstack) instead of our typical 2 node type jobs (jamoluhrsen, 17:16:16)
    10. we need to be careful about the larger stacks of nodes in our jobs, because we will eventually run in to resource limits (e.g. CPU/Mem) (jamoluhrsen, 17:17:35)
    11. tykeal- found a job with 11+ nodes. (jamoluhrsen, 17:18:35)
    12. ACTION: tykeal- to find that job and email. (jamoluhrsen, 17:18:49)

  4. packaging (jamoluhrsen, 17:19:11)
    1. boron autorelease is now working so apex is consuming the packaging based on that. (jamoluhrsen, 17:19:29)
    2. puppet module work happening recently, and pull requests coming in to fix apex (jamoluhrsen, 17:20:00)
    3. packer fixes coming in as well, and dockerhub has all the standard flavors now. (jamoluhrsen, 17:20:38)

  5. misc (jamoluhrsen, 17:22:09)
    1. looks like with latest csit workarounds (longer ssh timeout, retries) the ssh connection rejection issues have gone away (jamoluhrsen, 17:22:33)
    2. https://wiki.opendaylight.org/view/Weather#Make_distribution-check_more_strict <--- stricter distribution-check job coming (jamoluhrsen, 17:23:03)

  6. OPNFV infra/test presentation (jamoluhrsen, 17:23:56)
    1. https://wiki.opnfv.org/display/INF/Infra+Collaboration?preview=/8687389/8689634/LF_InfraCollaboration_OPNFV_Infra_CICD_Test.pptx#InfraCollaboration-CrossCommunityPresentations <--- opnfv infra/test slide deck (jamoluhrsen, 17:25:36)


Meeting ended at 18:17:20 UTC (full logs).

Action items

  1. tykeal- to find that job and email.


People present (lines said)

  1. jamoluhrsen (37)
  2. odp-gerritbot (7)
  3. dfarrell07 (5)
  4. odl_meetbot (3)
  5. tykeal- (1)
  6. LuisGomez (1)
  7. colindixon (1)
  8. anipbu (1)


Generated by MeetBot 0.1.4.