#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:02:19 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 17:03:57)
    1. there has been a lot of work for how our heat stack create is working (jamoluhrsen, 17:04:17)
    2. https://git.opendaylight.org/gerrit/#/c/51276/ <--- new heat patch (jamoluhrsen, 17:04:41)
    3. there is still trouble with our openstack config file plugin, so still looking for a workaround (jamoluhrsen, 17:05:53)
    4. this plugin fix needs to be there for the openstack api limit checks to work. (jamoluhrsen, 17:07:14)
    5. RackSpace doubled our api limits from 5k to 10k (jamoluhrsen, 17:07:52)
    6. https://git.opendaylight.org/gerrit/51321 (zxiiro, 17:08:37)
    7. https://git.opendaylight.org/gerrit/51321 coming soon, log server URL in jenkins emails (jamoluhrsen, 17:08:57)

  2. distribution (jamoluhrsen, 17:09:06)
    1. karaf 4 migration under way, but not done yet (jamoluhrsen, 17:10:16)
    2. still need other core projects to migrate anyway (jamoluhrsen, 17:10:47)

  3. release (jamoluhrsen, 17:11:39)
    1. controller karaf 4 patch has been merged, so we hope to see a lot of other projects migrate now (jamoluhrsen, 17:13:10)
    2. today is M4 (API FREEZE!!!) (jamoluhrsen, 17:13:29)
    3. in the middle of M5 we are going to have a boron release SR3 (jamoluhrsen, 17:13:49)

  4. misc (jamoluhrsen, 17:14:34)
    1. now that we run CSIT daily on snapshot and autorelease we can potentially be using 19hours of robot resources (jamoluhrsen, 17:17:29)
    2. https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-boron/103/ (LuisGomez, 17:17:49)
    3. csit job list is auto updated on builderpatch merges (jamoluhrsen, 17:21:01)
    4. LuisGomez points out that other groups/consumers are really wanting to see a way to *know* if a distribution is good, so sanity job will be important (jamoluhrsen, 17:21:37)
    5. https://trello.com/c/EGYoCYXX Autorelease build failure email notification automation (zxiiro, 17:23:16)
    6. also worked on some patches to get patch differences between distros to be output in the distribution job (jamoluhrsen, 17:24:01)

  5. cluster doc (jamoluhrsen, 17:24:26)
    1. https://git.opendaylight.org/gerrit/#/c/51253/ (vrpolak, 17:24:40)
    2. ACTION: jamoluhrsen to make a trello card to auto publish robot testdoc (note: we already do this for libdoc) (jamoluhrsen, 17:44:51)
    3. zxiiro asks if we can upgrade our ubuntu from 14.04 to 16.04 mininet VM? (jamoluhrsen, 17:59:47)
    4. I think it's safe to test on sandbox and then upgrade in releng if relevant CSIT jobs are ok (jamoluhrsen, 18:00:28)


Meeting ended at 18:00:32 UTC (full logs).

Action items

  1. jamoluhrsen to make a trello card to auto publish robot testdoc (note: we already do this for libdoc)


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to make a trello card to auto publish robot testdoc (note: we already do this for libdoc)


People present (lines said)

  1. jamoluhrsen (29)
  2. odp-gerritbot (4)
  3. zxiiro (4)
  4. vrpolak (3)
  5. odl_meetbot (3)
  6. rovarga (2)
  7. dfarrell07 (2)
  8. tykeal (1)
  9. LuisGomez (1)


Generated by MeetBot 0.1.4.