#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:01:36 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:07:19)
    1. sdninterface app features are back in integration. (jamoluhrsen, 17:07:28)
    2. no support for karaf 4 yet, no milestone reports yet (jamoluhrsen, 17:07:36)
    3. anipbu says that it's not really until M5 when we probably will have to worry about the distribution milestone reports (jamoluhrsen, 17:08:07)

  2. packaging (jamoluhrsen, 17:08:58)
    1. debian work for puppet module work making good progress (jamoluhrsen, 17:09:28)
    2. rpms soon to be triggered from autorelease. patch yet to be merged (jamoluhrsen, 17:09:52)
    3. single click cluster setup project given to us from alexis in int/packaging/tutorials. (jamoluhrsen, 17:10:18)
    4. tsc gave approval for us to create new repos under int/pak without creating new projects. this will let us import ansible and puppet github repos to be hosted in int/pak (jamoluhrsen, 17:11:17)

  3. release (jamoluhrsen, 17:13:03)
    1. lots of projects that have not reported M3. this is feature freeze (jamoluhrsen, 17:13:31)
    2. offset 0 and 1 only have one missing projects. all other delayed projects are offset 2 which are easier to drop from release if needed (jamoluhrsen, 17:14:15)

  4. builder (jamoluhrsen, 17:17:53)
    1. RackSpace 503 errrors we saw in some jobs were on their side and now reported to be fixed. (jamoluhrsen, 17:18:22)
    2. jenkins minion image list is now auto-updated in our docs (jamoluhrsen, 17:19:00)
    3. there are still "private" images that are not listed in the docs, but we can use those in the sandbox (jamoluhrsen, 17:19:39)
    4. LuisGomez and jamoluhrsen point out that there are more errors to talk about (jamoluhrsen, 17:21:03)
    5. ubuntu mininet upgrades underway. current plan is to keep old OVS on 14.04, but all newer ovs will be on 16.04 (jamoluhrsen, 17:21:31)
    6. zxiiro asks if we can change our default from java7 to java8? (jamoluhrsen, 17:22:09)
    7. we do have some csit tools using java7, but they should detect and switch to the right version, so changing the default to java8 should be fine (jamoluhrsen, 17:23:40)
    8. packer builds are now detecting failed installs of packages (e.g. yum install failures). this wont fail a packer patch verify job, but will fail the merge job so we wont get borked images at least (jamoluhrsen, 17:25:17)
    9. all builds will now run a git status to show projects which might be editing their git repo during a build. this might be unintentional and will help projects find thta. (jamoluhrsen, 17:26:41)
    10. autorel and builder scripts are starting to move to a shared LF repo to be used by other LF projects (e.g. OPEN-O) (jamoluhrsen, 17:27:18)
    11. initial committers for this new repo/project is just zxiiro, but it will need more. (jamoluhrsen, 17:27:57)
    12. autorelease auto-email should be coming soon (jamoluhrsen, 17:30:51)
    13. https://git.opendaylight.org/gerrit/51096 Autorelease Auto Notify Patch (zxiiro, 17:30:53)
    14. discussion around jobs aborting (red dots) (jamoluhrsen, 17:34:04)
    15. we can put some retries in our jobs for those times when infra is intermittently not coming up, but LuisGomez points out that we are just hiding the issue. (jamoluhrsen, 17:37:10)
    16. another issue is that the "lab" comes up, but we cannot ssh to the VMs (jamoluhrsen, 17:37:22)
    17. LuisGomez wants us to collect more concrete data on when we are having trouble and what kinds of trouble they are (jamoluhrsen, 17:39:03)
    18. how we get this data is a different, maybe not easy, problem. (jamoluhrsen, 17:39:24)
    19. ACTION: jamoluhrsen or zxiiro to look in to a retry for stacking scripts (jamoluhrsen, 17:42:24)
    20. ACTION: zxiiro to send patch/email about ideas for collecting data on job aborts (jamoluhrsen, 17:44:13)

  5. misc (jamoluhrsen, 17:44:35)
    1. vrpolak brings up cluster acceptance test request (jamoluhrsen, 17:45:02)
    2. https://lists.opendaylight.org/pipermail/integration-dev/2017-February/009069.html <-- cluster acceptance test email for projects to respond to (jamoluhrsen, 17:45:46)
    3. ACTION: jamoluhrsen to respond to cluster acceptance email for ovsdb (jamoluhrsen, 17:46:45)
    4. ACTION: gvrangan to respond to cluster acceptance email for netvirt (jamoluhrsen, 17:46:55)
    5. we do have a 3node jenkins tab to quickly see cluster csit status. (jamoluhrsen, 17:48:37)
    6. we still have our friday 3sp + cluster call. we should get back to going through results (jamoluhrsen, 17:48:55)


Meeting ended at 17:49:49 UTC (full logs).

Action items

  1. jamoluhrsen or zxiiro to look in to a retry for stacking scripts
  2. zxiiro to send patch/email about ideas for collecting data on job aborts
  3. jamoluhrsen to respond to cluster acceptance email for ovsdb
  4. gvrangan to respond to cluster acceptance email for netvirt


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen or zxiiro to look in to a retry for stacking scripts
    2. jamoluhrsen to respond to cluster acceptance email for ovsdb
  2. zxiiro
    1. jamoluhrsen or zxiiro to look in to a retry for stacking scripts
    2. zxiiro to send patch/email about ideas for collecting data on job aborts


People present (lines said)

  1. jamoluhrsen (41)
  2. odl_meetbot (3)
  3. anipbu (1)
  4. zxiiro (1)


Generated by MeetBot 0.1.4.