#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:50 UTC (full logs).

Meeting summary

    1. https://bugs.opendaylight.org/show_bug.cgi?id=7728 (vrpolak, 17:04:03)
    2. ACTION: vrpolak to increase priority of bug 7728. maybe a blocker (jamoluhrsen, 17:05:35)
    3. ACTION: jamoluhrsen to respond to own email about this cluster bringup issues (jamoluhrsen, 17:06:07)

  1. release (jamoluhrsen, 17:06:22)
    1. no new info on release stuff. (jamoluhrsen, 17:07:15)
    2. karaf 4 upgrades and inactive projects are major items from release team (jamoluhrsen, 17:07:36)
    3. LACP was removed from autorel and distribution, but they have done the work to be put back. (jamoluhrsen, 17:08:45)
    4. ball is in LACP's court for now (jamoluhrsen, 17:09:16)

  2. distribution (jamoluhrsen, 17:11:15)
    1. karaf 4 patch is prepared and ready for review (jamoluhrsen, 17:11:42)
    2. https://git.opendaylight.org/gerrit/51762 (vrpolak, 17:11:49)

  3. packaging (jamoluhrsen, 17:12:08)
    1. autorelease is now creating rpm builds now (jamoluhrsen, 17:12:34)
    2. pak/tutorial directory has the 1-click cluster tool merged (jamoluhrsen, 17:13:05)
    3. docker containers for openstack being brought in to packaging. (jamoluhrsen, 17:13:21)
    4. openstack kola patches in progress (jamoluhrsen, 17:13:42)
    5. odl interns working on deb deployments + puppet-opendaylight. nearly done (jamoluhrsen, 17:14:06)
    6. opnfv plugfest report out, good info regarding ODL (jamoluhrsen, 17:15:25)

  4. builder (jamoluhrsen, 17:15:32)
    1. https://www.opnfv.org/wp-content/uploads/2017/02/OPNFV_Plugfest_II_Report_FINAL.pdf OPNFV plugfest report, good PR for ODL CI/CD (dfarrell07, 17:15:59)
    2. jjbuilder node is not used any more. builder jobs all now run on the same java builders as other projects. (jamoluhrsen, 17:16:15)
    3. openstack plugin was broken but new release seems ok, and our custom workaround for retry is now upstream (jamoluhrsen, 17:18:48)
    4. heat stack retry is now merged (jamoluhrsen, 17:19:08)
    5. ssh key copy is now more resilient because we now *wait* for connectivity on the spun up vms before cloning the releng/builder repo. (jamoluhrsen, 17:20:01)
    6. because of the above two points, the hope is that all further RED dots are hopefully problems in ODL things (test, jjb, odl) (jamoluhrsen, 17:20:40)
    7. please please report any red dot aborts that are infra related from now on (jamoluhrsen, 17:21:47)
    8. maybe some logstash work coming where we can send data from our jobs to help collect stats (like infra failures, etc) to help us have a better idea. the beginnings of an ODL "top" (jamoluhrsen, 17:22:57)
    9. autorelease will hopefully start sending auto-emails when it fails. some patches are in the works (jamoluhrsen, 17:24:47)
    10. we also need projects to give better <name> fields in their poms (jamoluhrsen, 17:25:00)
    11. https://logs.opendaylight.org/releng/jenkins092/distribution-merge-carbon/566/archives/distribution_differences.txt.gz <-- shows diffs between created distro and last posted to nexus (jamoluhrsen, 17:27:07)
    12. we can demo the distcompare tool to TWS (jamoluhrsen, 17:29:20)

  5. misc (jamoluhrsen, 17:29:39)
    1. lots of discussions happening to make the networky projects of LF be more collaborative (jamoluhrsen, 17:30:21)
    2. several cross-project/tsc/board meetings happened last week at the open source leadership summit (jamoluhrsen, 17:30:43)
    3. as it pertains to us, some ideas were to try a POC to make OPNFV the cloud for ODL infra (jamoluhrsen, 17:31:13)
    4. one main concern is who/how is this supported. currently we *pay* RackSpace and we can expect them to help resolve issues. If we use OPNFV, it's opensource and we don't know who/how it would be supported... yet (jamoluhrsen, 17:34:23)
    5. not just internal ODL is asking for a sanity CSIT job. even others (e.g. OPNFV) wants to see this 100% always passing sanity job. (jamoluhrsen, 17:39:17)
    6. having unstable CSIT does not help others get an idea of the quality of some distro. (jamoluhrsen, 17:40:01)
    7. ACTION: jamoluhrsen to create trello card(s) for the steps needed to get to this sanity job (jamoluhrsen, 17:41:02)
    8. maybe we can use a sanity -gate- job. projects can use those for their gating and it can be for our sanity job (jamoluhrsen, 17:43:17)
    9. another new idea is to create a smaller distribution. for example, an opnfv autorelease job that only creates a distro with projects that opnfv needs (jamoluhrsen, 17:45:02)
    10. there was an idea that opnfv apex was going to be able to give ODL snapshots to deploy in our RackSpace cloud, but that idea is probably dead. RackSpace cloud wont let us use non-rackspace images (jamoluhrsen, 17:47:39)
    11. there are containers that we could deploy that use devstack. but we wonder if something like apex could create containers with their triple0 deployment (jamoluhrsen, 17:48:45)
    12. LuisGomez_ brings up the idea that downstream projects gate on upstream CSIT jobs. (jamoluhrsen, 17:49:15)
    13. can we define a process that makes this more of a requirement. (jamoluhrsen, 17:49:42)
    14. first step is just to provide the jobs and gerrit keywords for projects to use if they want. (jamoluhrsen, 17:50:24)
    15. maybe we provide the highly reliable (still nonexistent) sanity job as the gate (jamoluhrsen, 17:51:56)
    16. LuisGomez_ notes that we need a naming convention (jamoluhrsen, 17:52:58)


Meeting ended at 17:56:53 UTC (full logs).

Action items

  1. vrpolak to increase priority of bug 7728. maybe a blocker
  2. jamoluhrsen to respond to own email about this cluster bringup issues
  3. jamoluhrsen to create trello card(s) for the steps needed to get to this sanity job


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to respond to own email about this cluster bringup issues
    2. jamoluhrsen to create trello card(s) for the steps needed to get to this sanity job
  2. vrpolak
    1. vrpolak to increase priority of bug 7728. maybe a blocker


People present (lines said)

  1. jamoluhrsen (47)
  2. odl_meetbot (3)
  3. vrpolak (2)
  4. zxiiro (1)
  5. dfarrell07 (1)


Generated by MeetBot 0.1.4.