#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:01:15 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 17:04:51)
    1. new deb changes merged this week, making deb packaging easier (jamoluhrsen, 17:05:35)
    2. autorelease job now triggering rpm jobs, but they are now broken. (jamoluhrsen, 17:06:12)
    3. ACTION: dfarrell07 to disable the rpm jobs, using disable in the jjb patch (jamoluhrsen, 17:07:01)
    4. trello re-org for packaging always happening . kudos to dfarrell07 for that (jamoluhrsen, 17:07:39)

  2. release (jamoluhrsen, 17:07:46)
    1. boron SR3 is in 3 weeks. cutoff in 2.5 weeks (jamoluhrsen, 17:08:21)
    2. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule <--- Boron SR3 is in three weeks on 3/23/2017, with cutoff in 2.5 weeks. (anipbu, 17:08:22)
    3. ACTION: jamoluhrsen to poke in to distribution-test job for Boron to see if it's not totally broken (jamoluhrsen, 17:08:46)
    4. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/184/ (anipbu, 17:09:04)
    5. feb 26th was last successful boron autorelease (jamoluhrsen, 17:09:07)
    6. ACTION: zxiiro abelur to check if autorelease needs extra help/debug? (jamoluhrsen, 17:09:30)
    7. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- M5 Offset 0 and M4 Offset 2 is due today. (anipbu, 17:09:33)
    8. Carbon Mx statuses are due today (jamoluhrsen, 17:09:43)
    9. M5 report is expecting projects to link in karaf4 upgrade patch (jamoluhrsen, 17:10:03)
    10. At this point, all projects should be in Autorelease. TSC reserves right to remove projects by RC0 if they do not build successfully in autorelease. (anipbu, 17:10:13)
    11. techincally all projects should be included in autorelease now. federation is the last project, but looks like it should be good. (jamoluhrsen, 17:11:13)
    12. https://git.opendaylight.org/gerrit/#/q/topic:karaf4 <--- Karaf 4 moving on target. Status is GREEN light. "Kernal" projects done. Protocol projects pending. App projects patches are being submited at the moment. (anipbu, 17:11:28)
    13. Huge thanks to Stephen Kitt (anipbu, 17:11:50)
    14. karaf4 upgrade is on-target, status green. all kernel projects mostly done, protocol on the way and app patches in progress (jamoluhrsen, 17:12:01)
    15. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend <--- no successfully in month (anipbu, 17:12:35)
    16. anipbu raises red flags about autorelease failing (jamoluhrsen, 17:13:12)
    17. https://docs.google.com/spreadsheets/d/1MufwajG-YwGU7dth97x07VVRznVx4UgPHkfRFk6-bQg/edit#gid=1293046707 <--- Catagorizing autorelease failures (anipbu, 17:13:28)
    18. one autorelease failure (e.g. dlux) was failing because of an external problem (like some server is down) that is an expensive failure when autorel is an 8h job (jamoluhrsen, 17:17:10)
    19. Luis points out we can ask projects to remove these unstable tests if they happen frequently (jamoluhrsen, 17:17:39)
    20. will bring this autorelease red flag to the TSC (jamoluhrsen, 17:18:48)
    21. https://lists.opendaylight.org/pipermail/dev/2017-March/003371.html <--- MD-SAL Binding Generator API Change Waiver (anipbu, 17:19:09)
    22. we are now at API freeze. projects must submit api change waiver request going forward (jamoluhrsen, 17:19:11)
    23. openflow java change coming (perf related change) with a weather request. not an API change (jamoluhrsen, 17:21:15)
    24. ACTION: anipbu will investigate the openflowplugin weather item and report back some risk analysis next week. (jamoluhrsen, 17:21:57)

  3. distribution (jamoluhrsen, 17:22:52)
    1. aaa project is removing aaa-auth feature (jamoluhrsen, 17:23:11)
    2. lacp project added back to distribution, and -ui feature added (jamoluhrsen, 17:23:23)
    3. federation is coming to distribution soon (jamoluhrsen, 17:23:35)
    4. karaf 4 patch is ready to merge after next verify (did a rebase) (jamoluhrsen, 17:23:58)
    5. releng issues y'day with distribution-merge, but fixed (jamoluhrsen, 17:24:17)
    6. https://git.opendaylight.org/gerrit/#/c/52560/ <--- patch to fix distribution-merge (jamoluhrsen, 17:24:43)

  4. builder (jamoluhrsen, 17:26:21)
    1. https://trello.com/b/wH8qcNSO/odl-releng releng/builder Trello board (zxiiro, 17:26:21)
    2. https://git.opendaylight.org/gerrit/#/q/topic:improve-linting Improve Linting (zxiiro, 17:26:21)
    3. auto release notify script is working and sending emails. (jamoluhrsen, 17:27:41)
    4. https://trello.com/c/EGYoCYXX autorelease notify email script (zxiiro, 17:27:55)
    5. auto release email will not be able to be specific until projects update their <name> fields in all of their poms (jamoluhrsen, 17:28:53)
    6. anipbu suggests we might want to wait for karaf4 merged, but zxiiro thinks the merge conflicts would be minimal (jamoluhrsen, 17:30:38)
    7. jamoluhrsen points out that infra felt ok last week and early this week. (jamoluhrsen, 17:32:05)

  5. misc (jamoluhrsen, 17:32:13)
    1. releng builder had some issue recently that broke the 1node-verify csit job, but fixed recently (jamoluhrsen, 17:33:24)
    2. ACTION: jamoluhrsen to reply to bier project (jamoluhrsen, 17:34:40)
    3. https://trello.com/c/bLIRcSbV/461-create-sanity-test-for-projects-relevant-to-opnfv <--- trello card for sanity csit job (jamoluhrsen, 17:35:06)
    4. Luis can work to get an OFP suite for this sanity job. (jamoluhrsen, 17:35:31)
    5. ACTION: LuisGomez will drive this sanity test work (jamoluhrsen, 17:39:24)
    6. one idea we've had in the past was to submit system test plans in robot code, and it could be the new way for projects to submit their test plans (jamoluhrsen, 17:43:17)
    7. https://git.opendaylight.org/gerrit/#/c/51397/ <-- patch with an example of robot style test plan (jamoluhrsen, 17:43:45)
    8. seems like an agreement that we should require this kind of test plan for nitrogen and forward (jamoluhrsen, 17:45:36)
    9. we need a wiki to help start listing our nitrogen requirements (jamoluhrsen, 17:45:49)
    10. ACTION: jamoluhrsen to start nitrogen planning/requirements wiki (jamoluhrsen, 17:46:39)
    11. we scrubbed the Doing column in Trello (jamoluhrsen, 17:54:10)


Meeting ended at 17:54:13 UTC (full logs).

Action items

  1. dfarrell07 to disable the rpm jobs, using disable in the jjb patch
  2. jamoluhrsen to poke in to distribution-test job for Boron to see if it's not totally broken
  3. zxiiro abelur to check if autorelease needs extra help/debug?
  4. anipbu will investigate the openflowplugin weather item and report back some risk analysis next week.
  5. jamoluhrsen to reply to bier project
  6. LuisGomez will drive this sanity test work
  7. jamoluhrsen to start nitrogen planning/requirements wiki


Action items, by person

  1. anipbu
    1. anipbu will investigate the openflowplugin weather item and report back some risk analysis next week.
  2. jamoluhrsen
    1. jamoluhrsen to poke in to distribution-test job for Boron to see if it's not totally broken
    2. jamoluhrsen to reply to bier project
    3. jamoluhrsen to start nitrogen planning/requirements wiki
  3. zxiiro
    1. zxiiro abelur to check if autorelease needs extra help/debug?
  4. UNASSIGNED
    1. dfarrell07 to disable the rpm jobs, using disable in the jjb patch
    2. LuisGomez will drive this sanity test work


People present (lines said)

  1. jamoluhrsen (50)
  2. anipbu (10)
  3. odl_meetbot (3)
  4. zxiiro (3)
  5. odp-gerritbot (2)
  6. skitt (1)
  7. vrpolak (1)


Generated by MeetBot 0.1.4.