#opendaylight-integration: integration

Meeting started by jamoluhrsen at 17:03:09 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 17:05:01)
    1. M2 and most of M3 status are sent now. (jamoluhrsen, 17:05:21)
    2. tsdr project is working on getting feature back to features-test, but verify job is failing (jamoluhrsen, 17:06:11)
    3. also strange error came in distro check in a yangtools patch... (jamoluhrsen, 17:06:55)
    4. karaf4 changes have a risk to other projects that might break other projects. maybe monday we will merge (jamoluhrsen, 17:08:39)

  2. release (jamoluhrsen, 17:10:51)
    1. https://lists.opendaylight.org/pipermail/release/2017-March/009409.html (anipbu, 17:11:17)
    2. https://lists.opendaylight.org/pipermail/release/2017-March/009409.html <-- mdsal api change waiver may have a bigger impact to several projects. (jamoluhrsen, 17:11:49)
    3. depending projects snmp snbi tsdr capwap (tcp l2switch with abandoned patches) need to merge patches or will need to be removed from release (jamoluhrsen, 17:12:43)
    4. projects will get a notice, then 2 weeks to click +2/submit, then removal from distribution and autorelease. (jamoluhrsen, 17:13:27)
    5. Boron release in 2 weeks, cutoff in 1.5 weeks. autorelease is failing again. (jamoluhrsen, 17:14:15)
    6. time to start logging blocking bugs for autorelease failures (jamoluhrsen, 17:14:47)
    7. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/198/ (anipbu, 17:15:01)
    8. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046 (anipbu, 17:15:56)
    9. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=294913046 <-- tracking sheet for autorelease failures (jamoluhrsen, 17:16:13)

  3. packaging (jamoluhrsen, 17:16:34)
    1. work is done so that rpm builds are coming from autorelease builds w00t! (jamoluhrsen, 17:17:03)
    2. still trouble publishing rpms to koji (sp?) (jamoluhrsen, 17:17:44)
    3. regarding smaller distro (opnfv-distro) dfarrell07 wonders how to test the work (jamoluhrsen, 17:20:32)
    4. new packaging repos are in place for puppet and ansible, but no permissions to push yet? (jamoluhrsen, 17:24:45)
    5. int/pak has readthedocs pages now. (jamoluhrsen, 17:27:08)
    6. lots of linting coming in from everywhere, and coming to int/pak soon (jamoluhrsen, 17:27:44)

  4. builder (jamoluhrsen, 17:28:29)
    1. https://git.opendaylight.org/gerrit/#/c/51325/ This is ready to be merged to RelEng/Builder imho, if someone else wants to look (dfarrell07, 17:28:45)
    2. lftools coming along. (jamoluhrsen, 17:28:52)
    3. https://lf-releng-tools.readthedocs.io/en/latest/ lftools (zxiiro, 17:28:52)
    4. https://gerrit.linuxfoundation.org/infra/#/admin/projects/releng/releng-tools lftools git (zxiiro, 17:29:10)
    5. common tools will be moving from project repos to lftools (e.g. autorel version bumping) (jamoluhrsen, 17:30:22)
    6. there may be a lf-jjb repo coming that we can submodule in to our specific projects jjb repos (jamoluhrsen, 17:31:23)
    7. shellcheck linting came in, but some breakages came because of it. (e.g. CSIT all failed because ssh key copy broke) (jamoluhrsen, 17:32:01)
    8. new ubuntu mininet images in the sandbox now. needs to be tested (jamoluhrsen, 17:32:44)
    9. ACTION: LuisGomez will be validating the new ubuntu image in sandbox. (jamoluhrsen, 17:33:53)
    10. https://github.com/opendaylight/releng-builder/blob/master/jjb/netvirt/netvirt-csit-hwvtep-openstack.yaml#L64 example of changing image type for csit (zxiiro, 17:33:54)
    11. http://docs.opendaylight.org/en/latest/submodules/releng/builder/docs/jenkins.html#build-minions available-images (zxiiro, 17:35:03)
    12. our jenkins queue is large. autorelease beryllium is one hog. (jamoluhrsen, 17:37:36)
    13. ACTION: zxiiro to turn beryllium autorelease down from once a day to once a week. (jamoluhrsen, 17:37:59)
    14. ACTION: jamoluhrsen to bring it up with netvirt that their jobs are major jenkins users. can we be nicer? (jamoluhrsen, 17:41:21)
    15. vrpolak suggests that if our @daily CSIT job could possibly check if the autorelease trigger has recently run? (jamoluhrsen, 17:43:01)
    16. one idea could be to stick a shell script at the top of our @daily distribution-test job that will forcefully abort if it found that autorelease has already triggered (jamoluhrsen, 17:45:43)
    17. ACTION: LuisGomez to send an email about strategy for triggering csit (jamoluhrsen, 17:46:26)
    18. autorelease notify script improvements coming. maybe dont need <name> in pom.xml s (jamoluhrsen, 17:48:54)

  5. misc (jamoluhrsen, 17:48:59)
    1. ACTION: jamoluhrsen to send email to release to ask them to update the system test report (jamoluhrsen, 17:52:33)
    2. https://wiki.opendaylight.org/view/Integration/Distribution/Carbon_Feature_Tests (vrpolak, 17:54:24)
    3. https://wiki.opendaylight.org/view/Integration/Distribution/Carbon_Test_Report (vrpolak, 17:54:29)
    4. https://git.opendaylight.org/gerrit/53097 Patch to make Beryllium autorelease only build once a week (zxiiro, 17:55:36)


Meeting ended at 18:02:54 UTC (full logs).

Action items

  1. LuisGomez will be validating the new ubuntu image in sandbox.
  2. zxiiro to turn beryllium autorelease down from once a day to once a week.
  3. jamoluhrsen to bring it up with netvirt that their jobs are major jenkins users. can we be nicer?
  4. LuisGomez to send an email about strategy for triggering csit
  5. jamoluhrsen to send email to release to ask them to update the system test report


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to bring it up with netvirt that their jobs are major jenkins users. can we be nicer?
    2. jamoluhrsen to send email to release to ask them to update the system test report
  2. zxiiro
    1. zxiiro to turn beryllium autorelease down from once a day to once a week.
  3. UNASSIGNED
    1. LuisGomez will be validating the new ubuntu image in sandbox.
    2. LuisGomez to send an email about strategy for triggering csit


People present (lines said)

  1. jamoluhrsen (39)
  2. zxiiro (8)
  3. anipbu (3)
  4. odl_meetbot (3)
  5. gvrangan (2)
  6. vrpolak (2)
  7. dfarrell07 (1)
  8. odp-gerritbot (1)


Generated by MeetBot 0.1.4.