#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:03:52 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:05:04)
    1. karaf4 distro is being built but no restconf yet (jamoluhrsen, 16:05:23)
    2. distribution verify jobs are not good enough, we've realized (jamoluhrsen, 16:05:51)
    3. vrpolak has ideas for a better verify job, but nothing quite working yet. (jamoluhrsen, 16:06:24)
    4. verify job hopefully ready by monday 3/20 (jamoluhrsen, 16:06:49)
    5. ttp renamed top level feature (jamoluhrsen, 16:06:55)
    6. LuisGomez points out that when other projects start converting to karaf4 we will then have two distro-check jobs per project (jamoluhrsen, 16:08:14)
    7. concern around delivering karaf4 in carbon with things not working yet (jamoluhrsen, 16:09:53)
    8. vrpolak thinks it's probably 50/50 that we deliver karaf4 in carbon (jamoluhrsen, 16:11:01)

  2. release (jamoluhrsen, 16:12:04)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Schedule <--- Boron SR3 Cutoff this Sunday at 3/19/2017 23:59 UTC with a release on 3/23/2017 (anipbu, 16:12:34)
    2. https://bugs.opendaylight.org/buglist.cgi?bug_severity=blocker&bug_status=UNCONFIRMED&bug_status=CONFIRMED&bug_status=IN_PROGRESS&bug_status=WAITING_FOR_REVIEW&f1=cf_target_milestone&f2=cf_target_milestone&j_top=OR&list_id=67733&o1=substring&o2=substring&query_format=advanced&resolution=---&v1=Boron&v2=--- <--- Eight blocker bugs in openflowplugin, (anipbu, 16:12:42)
    3. boron SR3 cutoff is in 3 days. release one week after (jamoluhrsen, 16:12:42)
    4. https://git.opendaylight.org/gerrit/#/q/status:open+branch:stable/boron <--- 46 patches pending for stable/boron (anipbu, 16:13:05)
    5. https://git.opendaylight.org/gerrit/#/dashboard/?title=Boron+Status&Yang+File+Changes+Since+Boron+SR2=branch:stable/boron+status:merged+file:%22%255E.%252Byang%22+after:2016-12-15 <--- 46 patches modifying yang files without API Freeze Waiver between Boron SR2 and Boron SR3 (anipbu, 16:13:13)
    6. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/ <--- Boron Autorelease Build Failure. Last successful on Sunday 3/12/2017. ***RED FLAG*** (anipbu, 16:15:04)
    7. FAILURE! - in org.opendaylight.controller.sal.restconf.impl.nn.to.xml.test.NnToXmlTest (anipbu, 16:15:39)
    8. https://git.opendaylight.org/gerrit/#/c/53411/ (anipbu, 16:18:23)
    9. M4 Status Missing aaa, snmp, capwap, cardinal, eman, int/dis, next, of-config, opflex, packetcable, ttp, snbi, natapp, didm, sdninterfaceapp (anipbu, 16:19:21)
    10. https://lists.opendaylight.org/pipermail/release/2017-March/009409.html <--- MD-SAL Binding Generator API Change Impacted Projects ahve merged Patches (anipbu, 16:19:43)
    11. https://git.opendaylight.org/gerrit/#/q/topic:binding-gen-v1-refactoring-package-naming <--- No Projects Removed (anipbu, 16:19:50)
    12. https://lists.opendaylight.org/pipermail/release/2017-March/009499.html <-- SFC MAC Chaining Merged (anipbu, 16:20:17)
    13. https://lists.opendaylight.org/pipermail/release/2017-March/009587.html <-- NetVirt Intent to seek functionality freeze waiver (anipbu, 16:20:40)
    14. https://git.opendaylight.org/gerrit/#/q/topic:karaf4 <--- Insuffcient patches submitted for App projects for Karaf 4. (anipbu, 16:20:51)

  3. builder (jamoluhrsen, 16:21:56)
    1. https://lists.opendaylight.org/pipermail/release/2017-March/009566.html Certificates Update for Chrome 57 (zxiiro, 16:22:13)
    2. there is a beryllium failure that may be infra related, but issue is it can't find files... low priority but will get investigated (jamoluhrsen, 16:23:59)
    3. https://wiki.opendaylight.org/view/BestPractices/Commit_Messages (vrpolak, 16:24:51)
    4. releng/builder is now doing verify on commit messages (jamoluhrsen, 16:24:56)
    5. coala rules: https://github.com/coala/bear-docs/blob/master/docs/GitCommitBear.rst (vrpolak, 16:25:35)
    6. ACTION: zxiiro to send email reminder about commit message bear validation (jamoluhrsen, 16:25:40)
    7. AGREED: to enable git commit bear to int/test and int/pak (jamoluhrsen, 16:27:37)
    8. one idea is to find a way to get the "best practices" for commit messages shown when the bear fails. (jamoluhrsen, 16:28:58)
    9. ACTION: jamoluhrsen dfarrell07 to enable gitcommitbear in int/test int/pak (jamoluhrsen, 16:29:53)

  4. packaging (jamoluhrsen, 16:30:26)
    1. still work going on for the mini opnfv release (jamoluhrsen, 16:30:57)
    2. puppet module work to enable/configure repo file (jamoluhrsen, 16:31:22)

  5. misc (jamoluhrsen, 16:32:31)
    1. https://www.linuxfoundation.org/announcements/linux-foundation-announces-merger-of-open-source-ecomp-and-open-o%C2%A0to-form-new-open <--- ONAP Announced. ECOMP uses ODL. (anipbu, 16:35:10)
    2. ONS is in 3 weeks. reminder about docfest starting Sunday through Monday midday (jamoluhrsen, 16:37:22)
    3. karaf4 troubles on integration list, maybe vrpolak knows (jamoluhrsen, 16:39:09)
    4. https://lists.opendaylight.org/pipermail/integration-dev/2017-March/009272.html <-- email about karaf4 troubles (jamoluhrsen, 16:39:30)
    5. talk about shorter release ideas (6 months) possibly syncing up with OPNFV (jamoluhrsen, 16:40:28)
    6. talk about peer documentation review. current proposal would be to put integragtion team in group with FAAS, bier, packetcable (jamoluhrsen, 16:40:53)


Meeting ended at 16:41:00 UTC (full logs).

Action items

  1. zxiiro to send email reminder about commit message bear validation
  2. jamoluhrsen dfarrell07 to enable gitcommitbear in int/test int/pak


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen dfarrell07 to enable gitcommitbear in int/test int/pak
  2. zxiiro
    1. zxiiro to send email reminder about commit message bear validation


People present (lines said)

  1. jamoluhrsen (29)
  2. anipbu (16)
  3. odl_meetbot (3)
  4. vrpolak (2)
  5. zxiiro (1)


Generated by MeetBot 0.1.4.