#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:04:26 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:04:53)
    1. karaf4 progress is blocked because restconf just does not work. (jamoluhrsen, 16:05:25)
    2. one problem is that SFT might not be failing in karaf4 when it should (jamoluhrsen, 16:05:44)
    3. other problem is that netconf devs are too busy to take a look (jamoluhrsen, 16:05:55)
    4. https://git.opendaylight.org/gerrit/53986 (vrpolak, 16:06:30)
    5. ACTION: LuisGomez to look at distribution patches 54031 and 53986 (jamoluhrsen, 16:06:33)

  2. builder (jamoluhrsen, 16:07:05)
    1. still getting complaints about sandbox queue being too large. (jamoluhrsen, 16:08:36)
    2. ACTION: jamoluhrsen to look at jenkins job rename script in releng/builder to see if we can quickly get a script to auto-disable jobs (jamoluhrsen, 16:09:00)
    3. there is a python rest lib for jenkins we can look at too. (jamoluhrsen, 16:09:13)
    4. we cannot add any more robot jobs to the sandbox. it was recently reduced from 6 to 5 because we are at our limits (jamoluhrsen, 16:10:04)

  3. packaging (jamoluhrsen, 16:10:29)
    1. tons of linting work done for int/pak repo. (jamoluhrsen, 16:10:52)
    2. puppet-opendaylight was broken and fixed recently thanks to the auto-test job (jamoluhrsen, 16:11:47)
    3. opnfv subset distro is still making back burner progress (jamoluhrsen, 16:12:30)

  4. release (jamoluhrsen, 16:12:55)
    1. https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1703426731 <--- boron sr3 status tracker (jamoluhrsen, 16:13:15)
    2. vrpolak has updated his key projects for sr3. jamoluhrsen will do his after tsc today. (jamoluhrsen, 16:14:07)

  5. misc (jamoluhrsen, 16:21:03)
    1. jamoluhrsen asks if we want to move to carbon? answer is either when we release carbon or when we cut stable/carbon? (jamoluhrsen, 16:22:14)
    2. vrpolak thinks we should wait until we get carbon release (jamoluhrsen, 16:22:40)
    3. zxiiro points out that once we cut stable/carbon we will now have Be, Bo, C, and master branches active and will make a lot more jobs. (jamoluhrsen, 16:23:45)
    4. suggestion that we wait to cut stable/carbon? still a lot of work coming in, bug fixes, etc. (jamoluhrsen, 16:24:23)
    5. AGREED: to wait to change verify job to carbon. (jamoluhrsen, 16:25:45)
    6. question about moving VMs w/ ovs from 2.3 to 2.5? LuisGomez says it's done... Only OVS 2.x is now 2.5. (jamoluhrsen, 16:27:46)
    7. currently we only have very old 2.0 and now 2.5 (jamoluhrsen, 16:28:19)
    8. LuisGomez reports the sanity job is finally stable (jamoluhrsen, 16:28:43)
    9. https://jenkins.opendaylight.org/releng/view/Sanity-Jobs/ <--- sanity job tab in jenkins (jamoluhrsen, 16:29:25)
    10. sanity job is still just triggering as part of distribution-test (jamoluhrsen, 16:30:19)
    11. plan is to create a distribution-test-sanity which will only include these sanity jobs. (jamoluhrsen, 16:30:45)
    12. jamoluhrsen wants to have some automation/alarms around the sanity job having any failures. it should NEVER fail unless something is broken. (jamoluhrsen, 16:31:43)
    13. vrpolak has an idea to create a script that will automatically remove projects from both autorelease and distribution and creates the gerrit patches. (jamoluhrsen, 16:33:29)
    14. the script to do this auto-remove might not be trivial (jamoluhrsen, 16:33:50)
    15. even with the script, we need a process (from TSC) in order to figure out when we can use this automation to remove projects (jamoluhrsen, 16:34:10)
    16. vrpolak points out the process is just around who/how/when the gerrit patches are +2/merge, but the script can be run at any time to create the patches (jamoluhrsen, 16:34:50)
    17. sounds like a good hackfest project (jamoluhrsen, 16:35:23)
    18. looking for docfest ideas. wiki cleanup (move stuff to readthedocs, delete/deprecate old junk), search and destroy stale/wrong cluster docs, remove wiki duplication, test coding guidelines page to readthedocs, integration requirements for the release, (jamoluhrsen, 16:39:38)
    19. auto document robot test suites (like we already do for test libs) (jamoluhrsen, 16:40:14)
    20. conversation around https://git.opendaylight.org/gerrit/#/c/53130 with new weekly job type being created. (jamoluhrsen, 16:46:07)
    21. new paradigm to run our distribution-test job daily on snapshot, *only* if autorelease had failed. if autorel had passed, it will run distribution-test and no need to also run it with a daily trigger (jamoluhrsen, 16:52:25)
    22. https://git.opendaylight.org/gerrit/#/c/54068/ <--- patch to run distro-test only if autorelease has failed. (jamoluhrsen, 16:52:50)
    23. just to be clear, it's possible that we will not run very much on SNAPSHOT distributions if autorelease is very healthy (jamoluhrsen, 16:54:25)
    24. we may want to add the ability to run SNAPSHOT periodically in case autorelease is only what triggers distribution-test (jamoluhrsen, 16:55:01)


Meeting ended at 17:00:21 UTC (full logs).

Action items

  1. LuisGomez to look at distribution patches 54031 and 53986
  2. jamoluhrsen to look at jenkins job rename script in releng/builder to see if we can quickly get a script to auto-disable jobs


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to look at jenkins job rename script in releng/builder to see if we can quickly get a script to auto-disable jobs
  2. LuisGomez
    1. LuisGomez to look at distribution patches 54031 and 53986


People present (lines said)

  1. jamoluhrsen (44)
  2. odl_meetbot (3)
  3. vrpolak (2)
  4. LuisGomez (1)


Generated by MeetBot 0.1.4.