#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:03:36 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:04:19)
    1. nitrogen branch cut happened, but there was a period when branches weren't fully locked so some troubles came in (jamoluhrsen, 16:05:32)
    2. netvirt had a bad patch in nitrogen which conflicts wiht carbon artifacts so sometimes netvirt carbon wont build (jamoluhrsen, 16:06:53)
    3. but eman also has a bad features file in nitrogen so no nitrogen will build (jamoluhrsen, 16:07:19)
    4. https://git.opendaylight.org/gerrit/#/c/54860/3 https://git.opendaylight.org/gerrit/#/c/54923/ <--- EMAN blocking Carbon-RC0 (anipbu, 16:08:50)
    5. anipbu points out that we can remove eman because they are preventing us from building carbon and RC0 is here (jamoluhrsen, 16:09:23)
    6. actually, we just realized that the eman patches have JUST NOW been merged. (jamoluhrsen, 16:09:39)
    7. capwap project is officially dropped out of Carbon SR. (jamoluhrsen, 16:10:22)
    8. vrpolak has the patch(es) to remove capwap from distribution features (jamoluhrsen, 16:10:53)
    9. ACTION: zxiiro will remove capwap from autorelease (jamoluhrsen, 16:11:12)
    10. karaf4 csit jobs are in progress still, and being debugged. (jamoluhrsen, 16:12:01)
    11. zxiiro asks if we should remove capwap from nitrogen too? (jamoluhrsen, 16:12:36)
    12. https://bugs.opendaylight.org/show_bug.cgi?id=8208 (vrpolak, 16:12:42)
    13. ACTION: zxiiro to remove capwap from autorelease nitrogen (jamoluhrsen, 16:13:00)
    14. ACTION: LuisGomez to remove capwap from int/dist for nitrogren branh (jamoluhrsen, 16:13:16)

  2. packaging (jamoluhrsen, 16:14:21)
    1. more iterations on packaging automation (jamoluhrsen, 16:14:40)
    2. some strange issue around our ubuntu hosts (jamoluhrsen, 16:15:08)
    3. boron sr3 packages are released (jamoluhrsen, 16:15:38)
    4. new puppet and ansible repos are passed IPR so we can now move them from github to our ODL repos (jamoluhrsen, 16:17:37)
    5. we are going to use the method to keep the history on these repo migrations (jamoluhrsen, 16:18:02)
    6. mgkwill and dfarrell07 gave a packaging related talk at ONS (jamoluhrsen, 16:19:19)

  3. builder (jamoluhrsen, 16:20:02)
    1. https://git.opendaylight.org/gerrit/#/q/topic:RELENG-11 (zxiiro, 16:20:13)
    2. artifacts will now go to nexus instead of hanging off of jenkins (jamoluhrsen, 16:21:53)
    3. before we merge these patches to store artifacts on nexus, we need to know that patch-test works (jamoluhrsen, 16:23:23)
    4. we should get these patches merged later today. (jamoluhrsen, 16:24:44)
    5. currently the link to the nexus artifact for the distribution will be in the console log. we can look in to making it a gerrit comment (jamoluhrsen, 16:26:33)

  4. release (jamoluhrsen, 16:26:38)
    1. https://git.opendaylight.org/gerrit/#/c/54860/3 https://git.opendaylight.org/gerrit/#/c/54923/ <--- EMAN blocking Carbon-RC0. They have merge their patches. (anipbu, 16:26:50)
    2. https://lists.opendaylight.org/pipermail/capwap-dev/2017-April/000193.html <--- CAPWAP officially dropped out of Carbon-RC0 (anipbu, 16:26:57)
    3. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=31712896 <--- Karaf 4 Migration 78% complete: 8 patches pending, 3 without patches (anipbu, 16:27:06)
    4. All projects have been notified of Karaf 4 (see column I) (anipbu, 16:27:06)
    5. anipbu suggests it's time to remove the projects still left with pending (or no) karaf4 patches (jamoluhrsen, 16:27:49)
    6. we can bring this up on the TSC today and get agreement to remove these 8 projects, and we can take those steps today (jamoluhrsen, 16:29:28)
    7. correction, not 8 projects, it's 11. (jamoluhrsen, 16:30:04)
    8. vrpolak notes that only 2 features are actually in karaf4 distribution (jamoluhrsen, 16:30:53)
    9. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=921315511 <--- 13 Carbon Blocker Bugs. (anipbu, 16:32:52)
    10. All projects have been notified of carbon blocker bugs. See column D. (anipbu, 16:33:04)
    11. abelur: zxiiro: Need releng to submit patch for labeling Carbon-RC0. (anipbu, 16:33:19)
    12. https://wiki.opendaylight.org/view/Sample_Release_Notes https://wiki.opendaylight.org/view/Sample_Release_Review <--- Release Documentation Due Next Week (anipbu, 16:33:42)
    13. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- RC0 Today. RC1 4/20/2017. Branches are locked on RC1 next week. (anipbu, 16:34:14)
    14. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#M3:_Functionality_Freeze (anipbu, 16:36:30)

  5. misc (jamoluhrsen, 16:37:50)
    1. LuisGomez did send the M4 and M5 reports for integration/distribution. thanks (jamoluhrsen, 16:38:14)
    2. zxiiro was surprised that the distribution-check job is not skipping tests (jamoluhrsen, 16:38:51)
    3. the assumption was that the distribution-check doesn't need to run the tests, because it's being run by the other verify job (jamoluhrsen, 16:39:22)
    4. vrpolak points out that the tests being run in the distro-check job are different tests (jamoluhrsen, 16:39:54)
    5. zxiiro notes that distribution-check is now taking aprox 40m, but maybe some of that time is coming because we are also building karaf4 at the same time (jamoluhrsen, 16:40:48)
    6. DDF coming. add your topics and sign up. (jamoluhrsen, 16:44:44)
    7. https://wiki.opendaylight.org/view/Events:Nitrogen_Dev_Forum <--- ddf wiki (jamoluhrsen, 16:44:49)
    8. jamoluhrsen on PTO from now until the 24th, zxiiro starts PTO on the 24th, anipbu will be gone from now until 5/2. (jamoluhrsen, 16:46:51)
    9. LuisGomez in talks with other groups (e.g. OPNFV) for test strategy/collab (jamoluhrsen, 16:48:43)
    10. one idea would be for all of ODL openstack related jobs to run solely in OPNFV (jamoluhrsen, 16:49:58)
    11. OPNFV is able to stand up openstack test environments in a few minutes as opposed to our current 20-30 minutes (jamoluhrsen, 16:50:34)
    12. LuisGomez will ask some people from the infra/collab group to show up to the ddf and we could have a session around this (jamoluhrsen, 16:54:29)


Meeting ended at 16:55:28 UTC (full logs).

Action items

  1. zxiiro will remove capwap from autorelease
  2. zxiiro to remove capwap from autorelease nitrogen
  3. LuisGomez to remove capwap from int/dist for nitrogren branh


Action items, by person

  1. zxiiro
    1. zxiiro will remove capwap from autorelease
    2. zxiiro to remove capwap from autorelease nitrogen


People present (lines said)

  1. jamoluhrsen (49)
  2. anipbu (11)
  3. odl_meetbot (4)
  4. odp-gerritbot (3)
  5. zxiiro (2)
  6. vrpolak (1)
  7. dfarrell07 (1)


Generated by MeetBot 0.1.4.