#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:00:31 UTC (full logs).

Meeting summary

    1. https://zoom.us/j/770709266 Using Zoom today FYI (dfarrell07, 16:01:20)

  1. distribution (jamoluhrsen, 16:06:25)
    1. all projects not helping with karaf4 have now been removed (jamoluhrsen, 16:06:50)
    2. features started getting added, but distro check was taking too long, so we have now removed those features (was taking over 2 hours) (jamoluhrsen, 16:07:25)
    3. aaa project had some changes that added issues that affected other projects, but now that features are removed the distro-check job works. (jamoluhrsen, 16:08:44)
    4. ACTION: tykeal to add distribution4-check to priority (jamoluhrsen, 16:10:56)
    5. snmp4sdn is now back in distribution after dist4-check job passeds (jamoluhrsen, 16:12:03)
    6. bug 7900 (feature repos too big, takes too long) fix is merged, but behavior is now changed and each feature is tested in isolation which might report new failures (jamoluhrsen, 16:12:50)
    7. projects might start seeing failures in their verify job because of bugfix for 7900 (jamoluhrsen, 16:13:23)
    8. nitrogen csit is only karaf4, so no reason to run autorelease because no features are there to be tested (jamoluhrsen, 16:15:29)
    9. nitro patch-test will use karaf3, so if dev in gerrit runs patch test it will be ok. (jamoluhrsen, 16:16:10)
    10. we can revisit when to enable nitro autorel when we start to see features in karaf4 distro? (jamoluhrsen, 16:17:33)

  2. release (jamoluhrsen, 16:18:51)
    1. jamoluhrsen thinks top priority should be to release carbon (jamoluhrsen, 16:19:13)
    2. if we have to fix bugs to release carbon. if we *must* ship karaf4 in carbon, then we have to realize it's hard to fix bugs while trying to bring in karaf4 (jamoluhrsen, 16:21:54)
    3. LuisGomez points out that we are seeing some inconsistent pass/fail on same patches for project verifications, so it's hard to be fully confident that things are going to be ok. (jamoluhrsen, 16:24:20)
    4. not until we are settled with distro-check and jenkins queue is flushed to know if our recent fixes are stable or not. So, maybe by tomorrow we can know some better timeline with where we are going with karaf4 and carbon release (jamoluhrsen, 16:25:39)
    5. vrpolak suggests that the first bucket of features to add to karaf4 should be netconf as they have shown similar inconsistent issues that we saw with aaa. so if netconf is stable, we have a little confidence (jamoluhrsen, 16:28:30)
    6. autorelease is always breaking. colindixon wants to run it twice, once with no tests to produce actual stuff, then again with tests so we can all cheer for the new random test that is going to fail (jamoluhrsen, 16:30:49)
    7. are these tests really only failing in autorelease, or are they just unstable tests in the projects themselves (jamoluhrsen, 16:31:50)
    8. UT probably has way better coverage compared to CSIT, so we need to care about those failures, but how/why are these damn things popping up every single time we run autorelease but not in the project builds (jamoluhrsen, 16:33:16)

  3. builder (jamoluhrsen, 16:33:57)
    1. mandatory maint this saturday. things like jenkins security update (jamoluhrsen, 16:34:33)
    2. all long running jobs will be cancelled for this maint window, and wont be restarted (except autorelease) (jamoluhrsen, 16:35:55)
    3. jamoluhrsen thinks it sucks for LF guys to have to stop jenkins, wait, clear stale nodes, restart jenkins.... seems to happen multiple times a week. (jamoluhrsen, 16:37:01)
    4. we are moving from RackSpace to vexhost. RackSpace contract is up and we are moving on. (jamoluhrsen, 16:37:54)
    5. still wont have ssh access in vexhost, but we will be able to use apex images in vexhost. (jamoluhrsen, 16:39:49)
    6. the move happen before the end of the year. (jamoluhrsen, 16:40:32)
    7. csit can use the 172 net on a subnet interface (e.g. eth0:1) and should be fine. but those addresses cannot exit the localhost because the openstack networking will be blocking EVERYTHING but the localhost ip (jamoluhrsen, 16:43:28)
    8. ACTION: jamoluhrsen to check the other CSIT that is spinning up a VM, grabbing an ip and then using that ip on a subinterface. (tykeal thinks that should not work) (jamoluhrsen, 16:46:54)
    9. ACTION: vrpolak to send email on integration-dev with a link to that job. (jamoluhrsen, 16:47:15)

  4. packaging (jamoluhrsen, 16:47:40)
    1. puppet opendaylight jobs are now online (jamoluhrsen, 16:48:03)
    2. verify job for puppet sanity is now working (jamoluhrsen, 16:48:36)
    3. https://git.opendaylight.org/gerrit/49334 <-- suite taking IP address from other VM. (vrpolak, 16:48:46)
    4. vpp patch came in for puppet-opendaylight (jamoluhrsen, 16:49:44)
    5. ansible-opendaylight import having trouble (git troubles) (jamoluhrsen, 16:50:18)
    6. probably will wait for zxiiro-away to help with that. (jamoluhrsen, 16:50:31)
    7. https://logs.opendaylight.org/releng/jenkins092/sxp-csit-3node-periodic-routing-only-carbon/14/archives/log.html.gz <-- one successful run in production. (vrpolak, 16:51:07)
    8. puppet-opendaylight import was fine and we were able to keep history (jamoluhrsen, 16:51:09)
    9. dfarrell07 wants a packaging tab in jenkins (jamoluhrsen, 16:52:03)
    10. ACTION: dfarrell07 to send helpdesk ticket with regex for said packaging tab (jamoluhrsen, 16:52:17)

  5. misc (jamoluhrsen, 16:53:44)
    1. gvrangan can figure out best way forward to move openstack jobs to only use openstack cli (assuming gbp and vtn remove mitaka jobs) (jamoluhrsen, 16:56:42)
    2. vrpolak brings up how an isolated member should behave. currently it responds with 401 on every query. (jamoluhrsen, 16:57:32)


Meeting ended at 16:59:58 UTC (full logs).

Action items

  1. tykeal to add distribution4-check to priority
  2. jamoluhrsen to check the other CSIT that is spinning up a VM, grabbing an ip and then using that ip on a subinterface. (tykeal thinks that should not work)
  3. vrpolak to send email on integration-dev with a link to that job.
  4. dfarrell07 to send helpdesk ticket with regex for said packaging tab


Action items, by person

  1. dfarrell07
    1. dfarrell07 to send helpdesk ticket with regex for said packaging tab
  2. jamoluhrsen
    1. jamoluhrsen to check the other CSIT that is spinning up a VM, grabbing an ip and then using that ip on a subinterface. (tykeal thinks that should not work)
  3. vrpolak
    1. vrpolak to send email on integration-dev with a link to that job.


People present (lines said)

  1. jamoluhrsen (45)
  2. odl_meetbot (3)
  3. vrpolak (2)
  4. odp-gerritbot (2)
  5. dfarrell07 (1)


Generated by MeetBot 0.1.4.