#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:01 UTC (full logs).

Meeting summary

  1. distribution (jamoluhrsen, 16:05:00)
    1. carbon will release with karaf3, no distribution problems that we know of. (jamoluhrsen, 16:05:33)
    2. LuisGomez asks if we should remove the karaf4 distro-check in carbon? (jamoluhrsen, 16:05:52)
    3. we need to remove the karaf4 features from distro as well, and move all this work to master. (jamoluhrsen, 16:06:55)
    4. vrpolak thinks the low risk way is to just keep karaf4 features with the karaf4 sft in distribution and not spend cycles worrying about it. (jamoluhrsen, 16:09:19)
    5. iotdm project was still not in carbon distribution, so we may need to wait for them (jamoluhrsen, 16:10:57)
    6. correction, iotdm not in autorelease (jamoluhrsen, 16:11:19)
    7. https://lists.opendaylight.org/pipermail/release/2017-May/010803.html <--- iotdm wondering why they are not in autorelease (jamoluhrsen, 16:12:30)
    8. vrpolak wants all of these automated (adding/removing projects from distro and autorel) (jamoluhrsen, 16:12:58)

  2. release (jamoluhrsen, 16:14:51)
    1. RC0 probably coming by monday, is best guess. (jamoluhrsen, 16:15:39)
    2. CSIT analysis will be a big task when RCs are coming (jamoluhrsen, 16:15:55)
    3. there is a sense that something is broken in openflowplugin that might need to be a blocker bug (jamoluhrsen, 16:18:36)
    4. https://lists.opendaylight.org/pipermail/openflowplugin-dev/2017-May/007157.html <--- chatter about trouble in openflowplugin (jamoluhrsen, 16:19:35)

  3. packaging (jamoluhrsen, 16:20:11)
    1. packing changes on master have broken something on boron distros, which is a good example of why we are moving to branches in packaging (jamoluhrsen, 16:21:08)
    2. carbon deb packaging making progress (jamoluhrsen, 16:21:39)
    3. opnfv is using our daily carbon packages and no major reports of trouble there (jamoluhrsen, 16:22:32)

  4. misc (jamoluhrsen, 16:22:55)
    1. cancel weekly S3P/cluster call on Friday, and we'll report anything related to that on the CPERF call for S3P. And we'll use this integration meeting for any cluster updates (jamoluhrsen, 16:23:50)

  5. clustering (jamoluhrsen, 16:24:02)
    1. small improvement last week, but still a large class of suites still failing. (jamoluhrsen, 16:24:32)
    2. carbon is using a new cluster backend from boron (akka tell vs ask) and bugs are being opened (jamoluhrsen, 16:26:40)
    3. hard to tell that this new back-end is better... yet. failures are different, but the assumption is that it will end up better. (jamoluhrsen, 16:27:27)
    4. bottom line is that we'll be releasing clustering again that is not fully stable. (jamoluhrsen, 16:27:55)
    5. maybe in a carbon SR it will be? (jamoluhrsen, 16:28:02)
    6. LuisGomez reports OFP cluster CSIT has regressions from boron, so maybe we assume it's from the new cluster back-end. (jamoluhrsen, 16:30:33)
    7. new back-end is not used by default (jamoluhrsen, 16:31:05)
    8. https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-openstack-newton-nodl-v2-gate-stateful-nitrogen/ (jamoluhrsen, 16:36:49)

  6. misc (jamoluhrsen, 16:37:08)
    1. gate jobs are now waiting in line too long (jamoluhrsen, 16:37:18)
    2. ACTION: jamoluhrsen to send an email to check if -gate- jobs are still having priority? (jamoluhrsen, 16:38:24)
    3. some backup restore csit work is in progress (jamoluhrsen, 16:41:00)
    4. https://git.opendaylight.org/gerrit/#/c/55165/ <--- backup/restore CSIT patch (jamoluhrsen, 16:41:23)
    5. gvrangan wonders if it's possible to add a new node to a live cluster (jamoluhrsen, 16:42:12)
    6. vratko thinks it's possible with some restrictions, but only theoretically. never tried it. (jamoluhrsen, 16:43:09)
    7. even if it's possible, it's not trivial and not documented. (jamoluhrsen, 16:43:38)


Meeting ended at 16:45:25 UTC (full logs).

Action items

  1. jamoluhrsen to send an email to check if -gate- jobs are still having priority?


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send an email to check if -gate- jobs are still having priority?


People present (lines said)

  1. jamoluhrsen (39)
  2. odl_meetbot (3)


Generated by MeetBot 0.1.4.