#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:33 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:04:54)
    1. good news! Carbon is ready to release (jamoluhrsen, 16:05:10)
    2. https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-25-14.59.html (anipbu, 16:05:12)
    3. https://meetings.opendaylight.org/opendaylight-meeting/2017/carbon_release_sync/opendaylight-meeting-carbon_release_sync.2017-05-25-14.59.html <-- release tracking sheet (jamoluhrsen, 16:05:40)
    4. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan (anipbu, 16:06:18)
    5. https://wiki.opendaylight.org/view/Simultaneous_Release:Nitrogen_Release_Plan nitrogen release plan (jamoluhrsen, 16:06:37)
    6. boron SR, carbon SR and nitro milestones all hitting in the same 6 weeks this summer (jamoluhrsen, 16:07:14)
    7. karaf4 will likely be the major deliverable (jamoluhrsen, 16:08:00)
    8. we are close to removing all projects and getting karaf4 working from the ground up to start the nitrogen release (jamoluhrsen, 16:08:58)
    9. we have problems getting clustering working with karaf4 at this point. (jamoluhrsen, 16:09:12)
    10. the cluster issue in karaf4 should not block us from adding other projects (jamoluhrsen, 16:09:36)
    11. we need a way for each project to tweak if their CSIT is using karaf3 or karaf4 (jamoluhrsen, 16:12:33)
    12. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:14:51)
    13. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <-- nitrogen karaf4 migration tracker (jamoluhrsen, 16:15:10)
    14. CSIT jobs that we track for a release should not be marked IGNORE if the failures are valid and will be worked on going forward. (jamoluhrsen, 16:21:38)
    15. the problem is that the release team will use IGNORE from previous releases to automatically mark IGNORE in future releases (jamoluhrsen, 16:22:12)

  2. builder (jamoluhrsen, 16:23:46)
    1. centos images are unable to make new builds. they cannot connect to jenkins. abelur working on a fix (jamoluhrsen, 16:24:38)
    2. carbon is releasing, new set of scripts to try version bumping and hoping it will take only a few hours vs 12+ hours (jamoluhrsen, 16:25:25)
    3. one idea is we can run the version bumping stuff now, and then only merge the patches when TSC approves the release (jamoluhrsen, 16:27:23)
    4. abelur is working on a job that will go find old/stale nodes in our cloud which might help our issues where we have to pause jenkins and delete old nodes (jamoluhrsen, 16:29:08)

  3. packaging (jamoluhrsen, 16:31:15)
    1. ansible opendaylight imports pushed to new repo (jamoluhrsen, 16:31:31)
    2. dfarrell07 recruiting help from others to help with the ansible stuff (jamoluhrsen, 16:31:59)
    3. carbon .deb should be there after release (jamoluhrsen, 16:32:41)
    4. questions around how to host packaging things on nexus (e.g., yum repos) (jamoluhrsen, 16:33:43)
    5. ACTION: dfarrell07 to forward Akshita's email about nexus hosting to help-desk (jamoluhrsen, 16:34:03)
    6. odl summer interns starting in the next week or so. two for packaging (jamoluhrsen, 16:34:24)
    7. packaging knows that opnfv has not reported any major issues with carbon... so w00t! there. (jamoluhrsen, 16:36:03)

  4. distribution (jamoluhrsen, 16:37:33)
    1. carbon changes to get distro to karaf4 was migrated to nitrogen (jamoluhrsen, 16:38:35)

  5. misc (jamoluhrsen, 16:38:45)
    1. coala issues have all been fixed. they need to stick to the same version (jamoluhrsen, 16:39:17)

  6. clustering (jamoluhrsen, 16:40:10)
    1. in high perf (lots of chatter) situations, it seems we can get cluster mgmt connections to *think* they are isolated. seems like an akka limitation (jamoluhrsen, 16:44:33)
    2. we'll skip next week's integration call due to DDF (jamoluhrsen, 16:55:00)


Meeting ended at 16:55:26 UTC (full logs).

Action items

  1. dfarrell07 to forward Akshita's email about nexus hosting to help-desk


People present (lines said)

  1. jamoluhrsen (36)
  2. odl_meetbot (3)
  3. anipbu (3)
  4. odp-gerritbot (1)
  5. zxiiro (1)


Generated by MeetBot 0.1.4.