#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:02:09 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:05:58)
    1. boron SR4 looks healthy and we should probably release on time/schedule next week. (jamoluhrsen, 16:06:18)
    2. we asked projects to blacklist their CSIT results which will help the process more efficient. this is voluntary (jamoluhrsen, 16:07:04)
    3. carbon is still waiting on 3 projects to merge their release notes (jamoluhrsen, 16:07:19)
    4. nitrogen M0 status due now (jamoluhrsen, 16:07:40)
    5. nitrogen project proposal approval is coming. P4Plugin and Bier_APP so far (jamoluhrsen, 16:08:24)
    6. it's going to be hard to get these projects released in nitrogen with the struggle to get to karaf4 (jamoluhrsen, 16:08:45)
    7. zxiiro suggests we just deny nitrogen and ask them to be in oxygen only. (jamoluhrsen, 16:09:12)
    8. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf (anipbu, 16:09:21)
    9. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:09:46)
    10. https://wiki.opendaylight.org/view/Simultaneous_Release/Nitrogen/Karaf <-- wiki tracker for karaf4 progess (jamoluhrsen, 16:10:12)
    11. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <-- google sheet for tracking karaf4 (jamoluhrsen, 16:10:27)
    12. initial goal is to push for this k4 migration by end of june (jamoluhrsen, 16:11:27)
    13. bug 8627 needs to be worked on by integration team. (jamoluhrsen, 16:12:55)
    14. ACTION: vrpolak to update bug 8627 to give details on *why* we need to stop using featuresBoot (jamoluhrsen, 16:13:14)
    15. bug 8625 to remove all offset 0 projects from int/dist needs to be removed (jamoluhrsen, 16:15:17)
    16. ACTION: vrpolak to update bug 8625 with status (jamoluhrsen, 16:15:29)

  2. packaging (jamoluhrsen, 16:16:15)
    1. nitrogen rpms are being built now, which doesn't mean much because it wont work, but the logic is there which is great (jamoluhrsen, 16:16:56)
    2. still need carbon containers and vagrant base boxes (jamoluhrsen, 16:17:14)
    3. planning to combine rpm and deb logic to help keep the deb builder alive (jamoluhrsen, 16:17:39)
    4. hoping to move the vagrant-opendaylight from dfarrell07's github to the int/pak repo tutorials dir (jamoluhrsen, 16:18:18)
    5. puppet module fixes recently (jamoluhrsen, 16:22:04)

  3. builder (jamoluhrsen, 16:23:01)
    1. shiplogs macro is now using the lfinfra tools from the global-jjb repo (jamoluhrsen, 16:23:41)
    2. https://review.openstack.org/#/c/468340/ OpenStack blueprint for ODL integration into ansible-opendaylight (dfarrell07, 16:24:24)
    3. still the simple way is just to create an archives/ folder in the $workspace and they'll get logged (jamoluhrsen, 16:25:04)
    4. all centos images are now updated... finally... seems there was some issue in selinux that was not compatible with the rackspace base image which was updated in recent months (jamoluhrsen, 16:25:45)
    5. venv workaround has been getting put in place, but feels kind of hacky (jamoluhrsen, 16:26:41)
    6. ACTION: jamoluhrsen to send email about csit job he found with venv job that failed because the name was too long (jamoluhrsen, 16:27:06)
    7. non-kernel projects are removed from autorelease (jamoluhrsen, 16:27:35)
    8. int/dist is also not part of autorelease. autorelease is currently passing, so we can now put int/dist back maybe (jamoluhrsen, 16:28:40)
    9. https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001036.html (anipbu, 16:33:18)
    10. https://lists.opendaylight.org/pipermail/odlparent-dev/2017-June/001036.html <--- odl parent plans for nitrogen (jamoluhrsen, 16:34:53)
    11. we need to figure out if/how we want to keep doing a karaf3 distribution for nitrogen so projects can keep running CSIT... (jamoluhrsen, 16:38:30)
    12. ACTION: jamoluhrsen to send email asking what we really want to do about this. (jamoluhrsen, 16:39:02)
    13. zxiiro is heads down working on the generic release job so odlparent can release outside of autorelease (jamoluhrsen, 16:39:59)
    14. latest shellcheck version is now there in latest minion images so hopefully local tox results will match releng tox results (jamoluhrsen, 16:40:48)
    15. lfinfra projects have their own CI jobs. these projects are for building common tools that are used across lf projects (opnfv, odl, etc) (jamoluhrsen, 16:41:40)
    16. still no docs around these projects yet (still bootstrapping) (jamoluhrsen, 16:42:28)

  4. distribution (jamoluhrsen, 16:46:33)
    1. ACTION: jamoluhrsen to send email about bug 8627 because using featuresBoot with automated tools is kind of the easy/normal way to go about it. (jamoluhrsen, 16:47:59)
    2. nothing merged yet, but patches are in place to move forward with k4 (jamoluhrsen, 16:48:50)

  5. misc (jamoluhrsen, 16:49:14)
    1. we are still running boron jobs nightly, but since carbon is out so maybe next week we can move boron to run weekly like we were doing with Be (will bring it up next week) (jamoluhrsen, 16:52:01)
    2. gvrangan is working the ocata openstack job, and found some problems locally. (jamoluhrsen, 16:54:23)


Meeting ended at 16:55:40 UTC (full logs).

Action items

  1. vrpolak to update bug 8627 to give details on *why* we need to stop using featuresBoot
  2. vrpolak to update bug 8625 with status
  3. jamoluhrsen to send email about csit job he found with venv job that failed because the name was too long
  4. jamoluhrsen to send email asking what we really want to do about this.
  5. jamoluhrsen to send email about bug 8627 because using featuresBoot with automated tools is kind of the easy/normal way to go about it.


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to send email about csit job he found with venv job that failed because the name was too long
    2. jamoluhrsen to send email asking what we really want to do about this.
    3. jamoluhrsen to send email about bug 8627 because using featuresBoot with automated tools is kind of the easy/normal way to go about it.
  2. UNASSIGNED
    1. vrpolak to update bug 8627 to give details on *why* we need to stop using featuresBoot
    2. vrpolak to update bug 8625 with status


People present (lines said)

  1. jamoluhrsen (44)
  2. odl_meetbot (3)
  3. anipbu (3)
  4. dfarrell07 (2)
  5. odp-gerritbot (2)
  6. gvrangan (1)


Generated by MeetBot 0.1.4.