#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:00:02 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:04:27)
    1. boron sr4 will be delayed by a day or two because of a blocker in netvirt (jamoluhrsen, 16:04:51)
    2. netvirt fix coming tomorrow (jamoluhrsen, 16:04:58)
    3. carbon SR1 in 3 weeks (jamoluhrsen, 16:05:47)
    4. 7/2 is the cut-off for carbon sr1 (jamoluhrsen, 16:06:16)
    5. nitrogen will have a painful next two weeks. (jamoluhrsen, 16:06:46)
    6. all projects are moving to odlparent 1.9.0 (jamoluhrsen, 16:07:12)
    7. infrautils is back now (jamoluhrsen, 16:07:54)
    8. next week we want to move projects to odlparent 2.0.0 (jamoluhrsen, 16:08:17)
    9. in summary we have two weeks of trouble in nitrogen while we have two weeks to get carbon sr1 done (jamoluhrsen, 16:09:02)
    10. vrpolak asks if we can get SFT back in autorel? (jamoluhrsen, 16:11:32)
    11. should we remove karaf4 from Carbon so we can run SFT in carbon? is it worth the effort to get projects to do this? (jamoluhrsen, 16:12:29)
    12. ACTION: vrpolak to put a patch to enable SFT in autorel for carbon. we can discuss if we want to merge it on the patch (jamoluhrsen, 16:16:41)
    13. ACTION: zxiiro to check in odlparent on how to flip the switch to not run SFT on k4 in autorel carbon (jamoluhrsen, 16:17:24)
    14. the plan is to just remove the k4 SFT in carbon, then try this in sandbox and if all is well, we will restore it. (jamoluhrsen, 16:18:47)

  2. distribution (jamoluhrsen, 16:19:06)
    1. all karaf3 is now removed from integration/distribution for nitrogen (jamoluhrsen, 16:20:02)
    2. most nitro csit should not be failing because projects haven't been added to int/dist for k4 yet (jamoluhrsen, 16:20:39)
    3. if projects want to run CSIT on their own local k4 distribution they can hard code the bundle url in to their jjb (jamoluhrsen, 16:23:11)
    4. https://git.opendaylight.org/gerrit/#/c/58987/ <--- patch to hard code bundle-url to test local k4 distribution (jamoluhrsen, 16:24:00)
    5. https://bugs.opendaylight.org/show_bug.cgi?id=8571 <-- Bug causing no configure_cluster.sh in Karaf 4 builds. (vrpolak, 16:26:41)
    6. odlparent bug where k4 distribution doesn't have our extra scripts (e.g. configure cluster, set persistence) (jamoluhrsen, 16:26:46)
    7. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:29:22)
    8. it seems that featuresBoot has problems and things work better when installing features from the karaf shell (jamoluhrsen, 16:37:02)
    9. the integration group wants to file blocking bugs for these situations where featuresBoot does not work and continue with the assumption that both should work. (jamoluhrsen, 16:37:41)
    10. ACTION: jamoluhrsen to file blocking bug on netvirt featuresBOot issue (jamoluhrsen, 16:38:08)

  3. builder (jamoluhrsen, 16:39:33)
    1. we now have a maven release job to help release odlparent (jamoluhrsen, 16:40:19)
    2. ODL sites had cert issues recently, which caused problems that is now temporarily worked around. Andy will give a permanent solution soon (jamoluhrsen, 16:41:00)
    3. RackSpace had some outage over the weekend, but seems to have been resolved. there was some broken battery and broke the jenkins production server (jamoluhrsen, 16:41:58)
    4. vrpolak saw that some longevity jobs failed after 24h (prematurely) so wondering if this could have been the new script to kill stale nodes (jamoluhrsen, 16:43:11)
    5. we need to reduce longevity job times to something like 23 hours. the zombie killer script is only granular by days (jamoluhrsen, 16:44:42)
    6. ACTION: jamoluhrsen to search for longevity timers in int/test to warn projects (jamoluhrsen, 16:45:00)
    7. https://jenkins.opendaylight.org/releng/job/controller-csit-3node-periodic-benchmark-only-boron/323/ Controller job hung (zxiiro, 16:45:49)

  4. packaging (jamoluhrsen, 16:46:00)
    1. nexus repo getting setup for int/pak so we can push artifacts to nexus (jamoluhrsen, 16:46:28)
    2. major docs update in int/pak that we need to review and merge: https://git.opendaylight.org/gerrit/58670 (jamoluhrsen, 16:48:13)
    3. dfarrell07 giving multiple talks at OPFNV Summit on behalf of ODL. -- kudos! (jamoluhrsen, 16:49:51)

  5. misc (jamoluhrsen, 16:51:40)
    1. some Ericcson folks emailed about S3P. jamoluhrsen will loop in mattw4 (jamoluhrsen, 16:52:17)
    2. LuisGomez thinks we may have some good intern resources this summer to help us with some of our "good ideas". e.g. vrpolak's banhammer script (jamoluhrsen, 16:53:16)
    3. LuisGomez wants to give a dashboard demo next week (jamoluhrsen, 16:53:59)
    4. mattw4 working on a scale framework with devstack and docker containers. things are stabilizing now and we can consider using these in upstream jobs (jamoluhrsen, 16:57:00)
    5. each devstack container is consuming ~3G of memory (jamoluhrsen, 16:58:14)
    6. mattw4 asking for input/test cases if anyone has it. dfarrell07 points out that afredette has a scale/perf related test doc. (jamoluhrsen, 16:59:49)


Meeting ended at 17:00:19 UTC (full logs).

Action items

  1. vrpolak to put a patch to enable SFT in autorel for carbon. we can discuss if we want to merge it on the patch
  2. zxiiro to check in odlparent on how to flip the switch to not run SFT on k4 in autorel carbon
  3. jamoluhrsen to file blocking bug on netvirt featuresBOot issue
  4. jamoluhrsen to search for longevity timers in int/test to warn projects


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to file blocking bug on netvirt featuresBOot issue
    2. jamoluhrsen to search for longevity timers in int/test to warn projects
  2. vrpolak
    1. vrpolak to put a patch to enable SFT in autorel for carbon. we can discuss if we want to merge it on the patch
  3. zxiiro
    1. zxiiro to check in odlparent on how to flip the switch to not run SFT on k4 in autorel carbon


People present (lines said)

  1. jamoluhrsen (45)
  2. zxiiro (5)
  3. odp-gerritbot (4)
  4. anipbu (3)
  5. odl_meetbot (3)
  6. vrpolak (2)


Generated by MeetBot 0.1.4.