#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:12 UTC (full logs).

Meeting summary

  1. builder (jamoluhrsen, 16:03:43)
    1. global jjb has new committers that we can review (jamoluhrsen, 16:04:41)

  2. release (jamoluhrsen, 16:06:31)
    1. see TSC meeting notes from 6/21 to get updates on releases (jamoluhrsen, 16:08:16)
    2. ACTION: jamoluhrsen to change Boron CSIT to run weekly instead of daily (jamoluhrsen, 16:08:35)

  3. distribution (jamoluhrsen, 16:08:40)
    1. https://jenkins.opendaylight.org/releng/job/netconf-merge-nitrogen/92/console (LuisGomez, 16:10:51)
    2. above link is related to slow uploads to nexus, zxiiro is debugging (jamoluhrsen, 16:11:24)
    3. current int/dist is only having restconf (jamoluhrsen, 16:11:56)
    4. https://git.opendaylight.org/gerrit/#/c/59265/ <--- patch to get int/dist to odlparent 2.0.0 (jamoluhrsen, 16:13:01)
    5. after migrating to odlparent 2.0.0, the next step is to get offset-0 projects back in to int/dist (jamoluhrsen, 16:13:32)
    6. https://git.opendaylight.org/gerrit/#/c/59303/ <--- patch to get kernel projects back in int/dist (jamoluhrsen, 16:14:03)
    7. anipbu suggests we can add kernel projects back one at a time because feature names may have changed and the revert patch might not work. (jamoluhrsen, 16:14:43)
    8. LuisGomez wants to ask projects to add their own features to int/dist (jamoluhrsen, 16:15:32)
    9. ACTION: anipbu will communicate to projects that they will need to add their own features to int/dist (jamoluhrsen, 16:17:21)
    10. important milestone is still when int/dist is using odlparent 2.0.0 because that's when distro-check will start to work which will help projects know if they have something wrong in their patches (jamoluhrsen, 16:18:24)

  4. clustering (jamoluhrsen, 16:20:14)
    1. small progress happening (jamoluhrsen, 16:20:35)
    2. data change listeners has a problem where it's not working on a member that does not have a replica for that specific shard (jamoluhrsen, 16:21:28)
    3. bug 8629 is an improvement request for this data change listener issue (jamoluhrsen, 16:23:24)
    4. two cluster bugs types (negative tests, when expecting error response with cluster member down is not always happening) -and- (problems when cluster is under heavy load) (jamoluhrsen, 16:24:51)

  5. S3P (jamoluhrsen, 16:27:09)
    1. compute node containers are now able to pack ~50 instances per container (jamoluhrsen, 16:27:47)
    2. some corner cases still being ironed out (e.g. some instances don't get ips when started) (jamoluhrsen, 16:28:25)
    3. hopefully some patches around this work coming soon. (jamoluhrsen, 16:28:37)

  6. misc (jamoluhrsen, 16:28:46)
    1. https://git.opendaylight.org/gerrit/#/c/59113/ <--- turns jobs from 24h to 23h (jamoluhrsen, 16:29:26)

  7. packaging (jamoluhrsen, 16:29:59)
    1. interns are not as active as we had hoped so far (jamoluhrsen, 16:30:21)
    2. docs patches on the way to keep things clear (jamoluhrsen, 16:31:02)

  8. misc (jamoluhrsen, 16:33:19)
    1. gvrangan has a patch to reduce 50% of robot test time (jamoluhrsen, 16:33:45)

  9. dashboard demo (jamoluhrsen, 16:35:31)
    1. https://github.com/ecelgp/opendaylight-dashboard (LuisGomez, 17:00:47)
    2. https://github.com/ecelgp/opendaylight-dashboard <--- docker/dashboard github (jamoluhrsen, 17:01:15)


Meeting ended at 17:01:19 UTC (full logs).

Action items

  1. jamoluhrsen to change Boron CSIT to run weekly instead of daily
  2. anipbu will communicate to projects that they will need to add their own features to int/dist


Action items, by person

  1. anipbu
    1. anipbu will communicate to projects that they will need to add their own features to int/dist
  2. jamoluhrsen
    1. jamoluhrsen to change Boron CSIT to run weekly instead of daily


People present (lines said)

  1. jamoluhrsen (38)
  2. odl_meetbot (3)
  3. LuisGomez (2)
  4. vrpolak (1)
  5. anipbu (1)


Generated by MeetBot 0.1.4.