#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:16 UTC (full logs).

Meeting summary

  1. release (jamoluhrsen, 16:06:14)
    1. ofp has a new critical bug https://bugs.opendaylight.org/show_bug.cgi?id=8805 not sure if it's a regression (jamoluhrsen, 16:06:38)
    2. ACTION: LuisGomez to check bug 8805 is there in the Carbon release (jamoluhrsen, 16:07:49)
    3. anipbu notes that Carbon SR1 is delayed at the moment (jamoluhrsen, 16:08:04)
    4. https://docs.google.com/spreadsheets/d/1VcB12FBiFV4GAEHZSspHBNxKI_9XugJp-6Qbbw20Omk/edit#gid=363467887 <--- CSIT results for latest SR1 (jamoluhrsen, 16:10:06)
    5. for Nitro, odl parent 2.0.2 is releasing soon. (jamoluhrsen, 16:11:39)
    6. ACTION: jamoluhrsen to figure out how to get some CSIT run against this new odlparent 2.0.2 (jamoluhrsen, 16:12:10)
    7. not *all* projects need to migrate to 2.0.2, so we could end up with a mix of projects on 2.0.0 and 2.0.2 in nitro (jamoluhrsen, 16:12:32)
    8. test patch for netvirt: https://git.opendaylight.org/gerrit/60007 (skitt, 16:12:34)
    9. all kernel projects have completed k4 migration (jamoluhrsen, 16:12:44)
    10. we are 1 week behind schedule in the k4 migration, which is better than anipbu had hoped for :) (jamoluhrsen, 16:13:08)
    11. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 (anipbu, 16:13:25)
    12. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 (anipbu, 16:13:37)
    13. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=1274532933 <--- k4 issue tracker (jamoluhrsen, 16:13:39)
    14. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 <-- k4 project status (jamoluhrsen, 16:14:10)
    15. nitro k4 blocker bug filed by LuisGomez (8803) (jamoluhrsen, 16:15:33)
    16. featuresBoot seems to be working ok now (jamoluhrsen, 16:17:25)
    17. ACTION: jamoluhrsen to remove 8627 from blocker list (jamoluhrsen, 16:17:59)

  2. builder (jamoluhrsen, 16:19:08)
    1. when/how should we be updating our releng/builder submodules. for example: https://git.opendaylight.org/gerrit/59952 (jamoluhrsen, 16:20:39)
    2. work done last week to make our maven site deploy much faster (~5 min faster) (jamoluhrsen, 16:23:41)
    3. autorelease has a verify job now, to help gate autorel patches (jamoluhrsen, 16:23:58)
    4. ACTION: zxiiro or jamoluhrsen to add dist-test script parser howto to some wiki (jamoluhrsen, 16:26:21)

  3. distribution (jamoluhrsen, 16:26:31)
    1. nitro has aprox 1/2 projects already merged to get in to int/dist (jamoluhrsen, 16:27:10)
    2. projects with legit -1 on int/dist patches are reacting slowly. We may need to find a way to light a fire (jamoluhrsen, 16:28:04)
    3. anipbu says that projects were supposed to be in int/dist last week, so we are way behind. (jamoluhrsen, 16:29:20)
    4. we can make a cutoff like M5 that projects would not be allowed in nitro if they are not in int/dist (jamoluhrsen, 16:29:42)

  4. clustering (jamoluhrsen, 16:40:24)
    1. in general cluster csit is better recently. (jamoluhrsen, 16:40:45)
    2. possibly hitting 3rd party bugs (e.g. akka) (jamoluhrsen, 16:41:03)
    3. still some sporadic/infrequent bugs showing up (timing issues) which are hard to fix (jamoluhrsen, 16:41:35)
    4. we have several 3node longevity jobs (maybe 7 of them) and aprox half pass and half fail (jamoluhrsen, 16:42:19)
    5. besides akka and infrequent bugs, we have other open known bugs being worked (jamoluhrsen, 16:43:30)

  5. S3P (jamoluhrsen, 16:44:14)
    1. int/pak/openstack repo will get the new openstack containers (jamoluhrsen, 16:45:00)
    2. https://git.opendaylight.org/gerrit/#/c/56454/109/docs/cluster/carbon_sr1.rst <-- current controller cluster test report draft (vrpolak, 16:45:16)
    3. the plan will be to merge the container first (as it can be used immediately) then other patches for all the side work (ansible, etc) (jamoluhrsen, 16:46:30)
    4. there is a POC to make the compute container work against an external ODL (jamoluhrsen, 16:46:46)
    5. latest test was 90 compute containers with 2 instances per compute, but at this point the openstack container was consuming way too many resources (jamoluhrsen, 16:47:25)
    6. in that same scale test, the java process (so, ODL) was the top consumer. seems like an issue to figure out. (jamoluhrsen, 16:48:17)
    7. LuisGomez mentions that yourkit could be used to profile ODL in these scale tests. CaseyODL is working to get our licenses back for yourkit (jamoluhrsen, 16:51:14)

  6. misc (jamoluhrsen, 16:53:53)
    1. https://github.com/matt-welch/docker-devstack (mattw4, 16:54:43)
    2. https://github.com/matt-welch/docker-devstack (mattw4, 16:55:13)
    3. https://github.com/intel-odl/socets (mattw4, 16:55:30)
    4. ^^ ansible deployment tools for S3P docker containers (mattw4, 16:55:52)


Meeting ended at 16:57:30 UTC (full logs).

Action items

  1. LuisGomez to check bug 8805 is there in the Carbon release
  2. jamoluhrsen to figure out how to get some CSIT run against this new odlparent 2.0.2
  3. jamoluhrsen to remove 8627 from blocker list
  4. zxiiro or jamoluhrsen to add dist-test script parser howto to some wiki


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to figure out how to get some CSIT run against this new odlparent 2.0.2
    2. jamoluhrsen to remove 8627 from blocker list
    3. zxiiro or jamoluhrsen to add dist-test script parser howto to some wiki
  2. zxiiro
    1. zxiiro or jamoluhrsen to add dist-test script parser howto to some wiki


People present (lines said)

  1. jamoluhrsen (46)
  2. mattw4 (4)
  3. odl_meetbot (4)
  4. zxiiro (3)
  5. anipbu (2)
  6. vrpolak (1)
  7. skitt (1)


Generated by MeetBot 0.1.4.