#opendaylight-integration: integration

Meeting started by jamoluhrsen at 16:01:05 UTC (full logs).

Meeting summary

  1. packaging (jamoluhrsen, 16:03:38)
    1. tons of maintenance stuff working down the trello cards in the packaging world (packer job cleanup, puppet ansible... ) (jamoluhrsen, 16:04:19)
    2. packaging now supports fedora 26 (jamoluhrsen, 16:04:43)
    3. big queue of patches for rpm/deb logic nearing completion... maybe 2/3rds done (jamoluhrsen, 16:05:58)

  2. builder (jamoluhrsen, 16:06:51)
    1. abelur is renaming scripts, removing the "include-raw" prefix (jamoluhrsen, 16:07:11)
    2. opflex has jobs to archive to log server, but now we are reworkings jobs to push to nexus repository (jamoluhrsen, 16:07:41)
    3. license header scanner tool from lftools. (jamoluhrsen, 16:08:09)
    4. the idea is that eventually we can run this license header tool in our tox/verify jobs (so projects don't override license header checks) (jamoluhrsen, 16:09:14)
    5. obviously int/test and/or int/pak will fail these license header checks. this will force us to do this better (jamoluhrsen, 16:11:08)

  3. distribution (jamoluhrsen, 16:11:47)
    1. odlparent has multiple versions releases this week. so, int/dist is on 2.0.4 now (jamoluhrsen, 16:12:28)
    2. but, 2.0.5 is on the way and will allow jenkins job to specify an intended heap space (jamoluhrsen, 16:13:12)
    3. the heap is so large though, so we can't upload to log server. (jamoluhrsen, 16:15:03)

  4. release (jamoluhrsen, 16:15:57)
    1. https://wiki.opendaylight.org/view/Simultaneous_Release:Carbon_Release_Plan#Schedule <--- Carbon SR2 on 8/17/2017 (anipbu, 16:16:16)
    2. https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-carbon/buildTimeTrend <--- We have not had a successful build of Carbon since July 27 (anipbu, 16:16:28)
    3. carbon planned release SR2 next week, so cutoff this Sunday (jamoluhrsen, 16:16:34)
    4. last autorelease worked 7/27 (jamoluhrsen, 16:16:46)
    5. last issues were related with unimgr and nic (jamoluhrsen, 16:17:08)
    6. if autorelease is not building, we cant get any RC candidates (jamoluhrsen, 16:17:51)
    7. ACTION: jamoluhrsen to look at carbon dist-test job (jamoluhrsen, 16:18:22)
    8. for nitrogen, offset 1 M5 was this past monday, but not all projects have met the milestone (jamoluhrsen, 16:19:30)
    9. https://git.opendaylight.org/gerrit/61328 <-- allows .hprof file generation at specified path. (vrpolak, 16:19:49)
    10. ACTION: klou__ to keep the nitro status spreadsheet updated (jamoluhrsen, 16:20:06)
    11. offset 2 is in 4 days (monday, 8/14) when RC0 will come (jamoluhrsen, 16:20:24)
    12. https://git.opendaylight.org/gerrit/61506 <-- fix allowing Jenkins to configure how much heap space is to be used for SingleFeatureTest (vrpolak, 16:20:50)
    13. nitro autorelease is still failing (latest failure is on Alto with a patch pending merge) (jamoluhrsen, 16:20:58)
    14. we probably need all patches to merge their odlparent 2.0.4 (jamoluhrsen, 16:21:11)
    15. one idea from dfarrell07 is we can modify the autorelease job to use an unmerged patch in the build so we don't have to wait on projects to merge a patch that we *know* needs to be merged to fix things (jamoluhrsen, 16:22:29)
    16. the last successful nitro autorel was 7/24 and that's when projects started adding themselves back in to distribution. (jamoluhrsen, 16:25:30)
    17. https://docs.google.com/spreadsheets/d/1MYyGLFWN2RzUkJl8XMzXQ-3zWuOrUCQpIS6ORbmf4_U/edit#gid=188095956 (anipbu, 16:27:13)
    18. ACTION: vrpolak to look at int/dist patches for projects trying to get back in to distribution (jamoluhrsen, 16:27:20)
    19. anipbu reports that only 29 projects are in int/dist and 14 waiting to be brought pack and we don't know how many have given patches yet (jamoluhrsen, 16:28:17)
    20. https://git.opendaylight.org/gerrit/#/q/project:integration/distribution+status:open (anipbu, 16:28:24)
    21. so we have 1/3rd of our projects NOT back in distribution and the goal was to have this done by Monday (in four days) (jamoluhrsen, 16:29:08)
    22. seems we need more committers on int/dist. Luis is on PTO now, vrpolak is also doing 1-day PTO tomorrow and edwarnicke is not usually around for this. so we are stuck with zero active committers at a critical time (jamoluhrsen, 16:31:34)
    23. some good news.... all projects (except tsdr) have been successfully migrated to karaf4. (jamoluhrsen, 16:33:36)
    24. tsdr is a leaf project and if they are not migrated by monday, they will be dropped from nitrogen. (jamoluhrsen, 16:34:16)

  5. S3P (jamoluhrsen, 16:35:14)
    1. https://git.opendaylight.org/gerrit/gitweb?p=integration/packaging.git;a=tree;f=ansible;h=932ae9e180475eb7b0add1c084e34df572db2e1c;hb=HEAD (mattw4, 16:35:57)
    2. mattw4 worried about a submodule in the int/pak repo pointing to dfarrell07's github. (jamoluhrsen, 16:36:35)
    3. testplan for S3P going to google docs soon, we hope (jamoluhrsen, 16:37:48)
    4. openstack python sdk test expert needed. (jamoluhrsen, 16:38:34)
    5. https://github.com/matt-welch/docker-devstack/tree/master/service/build/openstack (mattw4, 16:39:37)
    6. testing is ongoing, no new/better numbers from last week. probably hitting scale limitations in openstack (jamoluhrsen, 16:40:47)
    7. Nitrogen distribution update: Most open patches are merged now, except Bier and Groupbasedpolicy which seem to need more heap space for odl-integration-all SFT. I expect rapid merges may cause distribution-merge and {project}-distribution-check to start failing on heap space. Odlparent 2.0.5 would fix that. (vrpolak, 16:41:00)
    8. mattw4 saved off an 11G heap dump from ODL. how do we deal with that? (jamoluhrsen, 16:42:34)
    9. https://bugs.opendaylight.org/show_bug.cgi?id=8941 <-- Memory leak Bug with fix ready (both for Carbon and Nitrogen). (vrpolak, 16:42:46)
    10. ACTION: jamoluhrsen to document how to find the distribution created by the distribution-check job (jamoluhrsen, 16:46:02)
    11. ACTION: jamoluhrsen to email mattw4 the csit tutorial (jamoluhrsen, 16:47:11)

  6. clustering (jamoluhrsen, 16:47:48)
    1. test results are worse this week... possibly a regression or occurrence of infrequent bug in longevity test (jamoluhrsen, 16:48:30)
    2. documentation not done yet, but coming. (jamoluhrsen, 16:48:56)
    3. carbon SR2 might have two bugs able to be fixed, but they are not blockers so unless they come soon they wont make it (jamoluhrsen, 16:52:04)

  7. misc (jamoluhrsen, 16:52:19)
    1. anipbu corrects that nitrogen currently has 3 non-leaf projects (GBP, SNMP, <someone else>) that haven't been put back in to int/dist (jamoluhrsen, 16:53:35)
    2. two leaf projects not in int/dist.... so FIVE total, not 14 (jamoluhrsen, 16:53:48)
    3. but since 3 are non-leaf we MUST get them in. GBP should be find. FAAS is blocked by resources. SNMP has always had troubles but they have new committers we trust can get this working (jamoluhrsen, 16:54:49)
    4. anipbu suggests that we find whoever is dependent on FAAS to remove their dependency (jamoluhrsen, 16:55:07)
    5. gvrangan almost has the devstack pike job almost working. auth_strategy needed a change and we had to run the "discover" command earlier in the job. (jamoluhrsen, 16:56:25)
    6. anipbu asks if yangtools should be in int/dist? vrpolak notes they don't have user facing features, but they do have top-level features. they are just used as a lib, so no need to make their features visible in distribution (jamoluhrsen, 16:58:26)


Meeting ended at 17:01:33 UTC (full logs).

Action items

  1. jamoluhrsen to look at carbon dist-test job
  2. klou__ to keep the nitro status spreadsheet updated
  3. vrpolak to look at int/dist patches for projects trying to get back in to distribution
  4. jamoluhrsen to document how to find the distribution created by the distribution-check job
  5. jamoluhrsen to email mattw4 the csit tutorial


Action items, by person

  1. jamoluhrsen
    1. jamoluhrsen to look at carbon dist-test job
    2. jamoluhrsen to document how to find the distribution created by the distribution-check job
    3. jamoluhrsen to email mattw4 the csit tutorial
  2. mattw4
    1. jamoluhrsen to email mattw4 the csit tutorial
  3. vrpolak
    1. vrpolak to look at int/dist patches for projects trying to get back in to distribution


People present (lines said)

  1. jamoluhrsen (54)
  2. odp-gerritbot (6)
  3. anipbu (5)
  4. vrpolak (4)
  5. odl_meetbot (3)
  6. mattw4 (2)
  7. dfarrell07 (1)


Generated by MeetBot 0.1.4.